summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-16 15:52:16 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-16 15:52:16 +0000
commit102eb1da907a9df717c74955edf0c0895b574804 (patch)
tree0d1a7490c70e169f8ec923f45850599dbf6cbde5 /games-util/gslist
parentbump drumstick dep, bug #543342 (diff)
downloadgentoo-2-102eb1da907a9df717c74955edf0c0895b574804.tar.gz
gentoo-2-102eb1da907a9df717c74955edf0c0895b574804.tar.bz2
gentoo-2-102eb1da907a9df717c74955edf0c0895b574804.zip
version bump
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-util/gslist')
-rw-r--r--games-util/gslist/ChangeLog9
-rw-r--r--games-util/gslist/files/gslist-0.8.11a-build.patch41
-rw-r--r--games-util/gslist/gslist-0.8.11a.ebuild36
3 files changed, 85 insertions, 1 deletions
diff --git a/games-util/gslist/ChangeLog b/games-util/gslist/ChangeLog
index 993ef7cb35de..4350464c5ffb 100644
--- a/games-util/gslist/ChangeLog
+++ b/games-util/gslist/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-util/gslist
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/ChangeLog,v 1.10 2015/02/25 08:19:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/ChangeLog,v 1.11 2015/03/16 15:52:16 mr_bones_ Exp $
+
+*gslist-0.8.11a (16 Mar 2015)
+
+ 16 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/gslist-0.8.11a-build.patch, +gslist-0.8.11a.ebuild,
+ files/gslist-0.8.8a-build.patch:
+ version bump
25 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> gslist-0.8.8a.ebuild:
Fix S
diff --git a/games-util/gslist/files/gslist-0.8.11a-build.patch b/games-util/gslist/files/gslist-0.8.11a-build.patch
new file mode 100644
index 000000000000..4ffbfd94e012
--- /dev/null
+++ b/games-util/gslist/files/gslist-0.8.11a-build.patch
@@ -0,0 +1,41 @@
+--- work.orig/Makefile
++++ work/Makefile
+@@ -1,26 +1,30 @@
+-CFLAGS += -O2 -s -fstack-protector-all
++CFLAGS += -Wall -D_GNU_SOURCE
+ PREFIX = /usr/local
+ BINDIR = $(PREFIX)/bin
+ SRC = src/gslist.c src/enctype1_decoder.c src/enctype2_decoder.c src/enctype_shared.c src/mydownlib.c
+ #LIBS = -lpthread /usr/lib/libGeoIP.a /usr/lib/i386-linux-gnu/libz.a
+ #SQLIBS = /usr/lib/i386-linux-gnu/libmysqlclient.a /usr/lib/i386-linux-gnu/libm.a -ldl
+ LIBS = -lpthread -lGeoIP -lz
+-SQLIBS = -lmysqlclient
+ O = $(SRC:.c=.o)
+
+-all: gslist gslistsql
++ifneq ($(GSWEB),0)
++CFLAGS += -DGSWEB
++endif
+
+-gslist:
+- $(CC) $(SRC) $(CFLAGS) -o gslist $(LIBS) -DGSWEB
+- $(CC) $(SRC) $(CFLAGS) -o gslistsql $(SQLIBS) $(LIBS) -DGSWEB -DSQL
++ifneq ($(SQL),0)
++CFLAGS += -DSQL
++LIBS += -lmysqlclient
++endif
++
++gslist: $(O)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o gslist $(O) $(LIBS)
+
+ clean:
+- rm -f gslist gslistsql src/gslist.o src/enctype1_decoder.o src/enctype2_decoder.o src/enctype_shared.o src/enctypex_decoder.o src/mydownlib.o
++ rm -f gslist $(O)
+
+ install:
+ install -m 755 -d $(BINDIR)
+ install -m 755 gslist $(BINDIR)/gslist
+- install -m 755 gslistsql $(BINDIR)/gslistsql
+
+ .PHONY:
+ clean install
diff --git a/games-util/gslist/gslist-0.8.11a.ebuild b/games-util/gslist/gslist-0.8.11a.ebuild
new file mode 100644
index 000000000000..1518834aa60d
--- /dev/null
+++ b/games-util/gslist/gslist-0.8.11a.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/gslist/gslist-0.8.11a.ebuild,v 1.1 2015/03/16 15:52:16 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils games
+
+DESCRIPTION="A GameSpy server browser"
+HOMEPAGE="http://aluigi.altervista.org/papers.htm#gslist"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+IUSE="web"
+
+RDEPEND="dev-libs/geoip"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S=${WORKDIR}
+
+src_prepare() {
+ rm -f gslist gslistsql *.exe *.dll || die
+ epatch "${FILESDIR}"/${P}-build.patch
+}
+
+src_compile() {
+ emake SQL=0 $(use web || echo GSWEB=0)
+}
+
+src_install() {
+ dogamesbin ${PN}
+ dodoc ${PN}.txt
+ prepgamesdirs
+}