summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-11 16:42:06 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-11 16:42:06 +0000
commitead8c2b4964caf13602a590438f34053119c33ce (patch)
treea7272d18f171e4556ef9bbd67edd8403d1005fba /games-strategy
parentStable on ppc wrt bug 181621 (diff)
downloadgentoo-2-ead8c2b4964caf13602a590438f34053119c33ce.tar.gz
gentoo-2-ead8c2b4964caf13602a590438f34053119c33ce.tar.bz2
gentoo-2-ead8c2b4964caf13602a590438f34053119c33ce.zip
Don't use egamesinstall
(Portage version: 2.1.2.9)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/xconq/ChangeLog5
-rw-r--r--games-strategy/xconq/xconq-7.4.1.ebuild40
2 files changed, 28 insertions, 17 deletions
diff --git a/games-strategy/xconq/ChangeLog b/games-strategy/xconq/ChangeLog
index 61d0fc50a6b9..8b1be226c632 100644
--- a/games-strategy/xconq/ChangeLog
+++ b/games-strategy/xconq/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-strategy/xconq
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.9 2007/02/22 00:07:09 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/ChangeLog,v 1.10 2007/06/11 16:42:06 nyhm Exp $
+
+ 11 Jun 2007; Tristan Heaven <nyhm@gentoo.org> xconq-7.4.1.ebuild:
+ Don't use egamesinstall
22 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/games-strategy/xconq/xconq-7.4.1.ebuild b/games-strategy/xconq/xconq-7.4.1.ebuild
index 6f142c508880..573831ea8ac2 100644
--- a/games-strategy/xconq/xconq-7.4.1.ebuild
+++ b/games-strategy/xconq/xconq-7.4.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.10 2006/12/06 21:12:09 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/xconq/xconq-7.4.1.ebuild,v 1.11 2007/06/11 16:42:06 nyhm Exp $
inherit eutils games
@@ -10,37 +10,45 @@ SRC_URI="ftp://sources.redhat.com/pub/xconq/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc"
+KEYWORDS="ppc x86"
IUSE=""
+RESTRICT="test"
-RDEPEND="x11-libs/libXmu
+DEPEND="x11-libs/libXmu
+ x11-libs/libXaw
dev-lang/tk
dev-lang/tcl"
-DEPEND="${RDEPEND}
- x11-libs/libXaw"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-gcc-3.4.patch \
- ${FILESDIR}/${PN}-tkconq.patch
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${PN}-gcc-3.4.patch \
+ "${FILESDIR}"/${PN}-tkconq.patch
}
src_compile() {
egamesconf \
- --enable-alternate-scoresdir=${GAMES_STATEDIR}/${PN}/scores \
+ --enable-alternate-scoresdir="${GAMES_STATEDIR}"/${PN} \
|| die
emake \
CFLAGS="${CFLAGS}" \
- datadir=${GAMES_DATADIR}/${PN} \
+ datadir="${GAMES_DATADIR}"/${PN} \
|| die "emake failed"
}
src_install() {
- dodir ${GAMES_STATEDIR}/${PN} ${GAMES_DATADIR}/${PN}
- egamesinstall \
- scoresdir=${D}/${GAMES_STATEDIR}/${PN}/scores \
- datadir=${D}/${GAMES_DATADIR}/${PN} \
- || die
+ dogamesbin x11/{imf2x,x2imf,xconq,ximfapp} || die "dogamesbin failed"
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r images lib tcltk/*.tcl || die "doins failed"
+ rm -f "${D}/${GAMES_DATADIR}"/${PN}/{images,lib}/{m,M}ake*
+
+ dodir "${GAMES_STATEDIR}"/${PN}
+ touch "${D}/${GAMES_STATEDIR}"/${PN}/scores.xcq
+ fperms 660 "${GAMES_STATEDIR}"/${PN}/scores.xcq || die
+
+ doman x11/${PN}.6
+ dodoc ChangeLog NEWS README
prepgamesdirs
}