summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-11 13:31:26 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-11 13:31:26 +0000
commit06ea64ba424cc48c8d78e160c1c5f28cc83d9ffc (patch)
tree84b93f79dd7413fa4e0c020939dd703767f42ddb /games-sports
parentAdd files repomon forgot to commit, Bug #258584. (diff)
downloadgentoo-2-06ea64ba424cc48c8d78e160c1c5f28cc83d9ffc.tar.gz
gentoo-2-06ea64ba424cc48c8d78e160c1c5f28cc83d9ffc.tar.bz2
gentoo-2-06ea64ba424cc48c8d78e160c1c5f28cc83d9ffc.zip
Fix --as-needed bug #247473
(Portage version: 2.1.6.4/cvs/Linux 2.6.27-gentoo-r8 x86_64)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/gracer/ChangeLog8
-rw-r--r--games-sports/gracer/files/gracer-0.1.5-as-needed.patch11
-rw-r--r--games-sports/gracer/gracer-0.1.5.ebuild15
3 files changed, 24 insertions, 10 deletions
diff --git a/games-sports/gracer/ChangeLog b/games-sports/gracer/ChangeLog
index d651bcd2fffc..27c27224fed1 100644
--- a/games-sports/gracer/ChangeLog
+++ b/games-sports/gracer/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-sports/gracer
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/ChangeLog,v 1.17 2008/01/19 00:43:31 mr_bones_ Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/ChangeLog,v 1.18 2009/02/11 13:31:26 tupone Exp $
+
+ 11 Feb 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/gracer-0.1.5-as-needed.patch, gracer-0.1.5.ebuild:
+ Fix --as-needed bug #247473 by flameeyes@gentoo.org
19 Jan 2008; Michael Sterrett <mr_bones_@gentoo.org> gracer-0.1.5.ebuild:
deps actually are hard (bug #206415)
diff --git a/games-sports/gracer/files/gracer-0.1.5-as-needed.patch b/games-sports/gracer/files/gracer-0.1.5-as-needed.patch
new file mode 100644
index 000000000000..3d3c53bcd46e
--- /dev/null
+++ b/games-sports/gracer/files/gracer-0.1.5-as-needed.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.in.old 2009-02-11 14:31:56.000000000 +0100
++++ src/Makefile.in 2009-02-11 14:32:29.000000000 +0100
+@@ -109,7 +109,7 @@
+ INCLUDES = -I$(top_srcdir) @X_CFLAGS@ @GL_CFLAGS@ @GLUT_CFLAGS@ @TCL_CFLAGS@ @GIF_CFLAGS@ @JPEG_CFLAGS@ @PNG_CFLAGS@ @PLIB_CFLAGS@
+
+
+-gracer_LDADD = @PLIB_LDFLAGS@ @GIF_LDFLAGS@ @JPEG_LDFLAGS@ @PNG_LDFLAGS@ @GL_LDFLAGS@ @GLUT_LDFLAGS@ @X_LDFLAGS@ @TCL_LDFLAGS@ @TCL_LIBS@ @X_LIBS@ @GL_LIBS@ @GLUT_LIBS@ @GIF_LIBS@ @JPEG_LIBS@ @PNG_LIBS@ @SOUND_LIBS@ $(top_builddir)/common/libcommon.a
++gracer_LDADD = $(top_builddir)/common/libcommon.a @PLIB_LDFLAGS@ @GIF_LDFLAGS@ @JPEG_LDFLAGS@ @PNG_LDFLAGS@ @GL_LDFLAGS@ @GLUT_LDFLAGS@ @X_LDFLAGS@ @TCL_LDFLAGS@ @TCL_LIBS@ @X_LIBS@ @GL_LIBS@ @GLUT_LIBS@ @GIF_LIBS@ @JPEG_LIBS@ @PNG_LIBS@ @SOUND_LIBS@
+
+
+ gracer_SOURCES = control.h glbind.c glbind.h glutwidgets.c glutwidgets.h gluttclwidgets.c gluttclwidgets.h glutgame.c glutgame.h gr_world.c gr_world.h glhash.h gluthash.h vehicle.c vehicle.h lap.c lap.h joystick.c joystick.h tcldefs.h sound.h sound.cxx main.cxx
diff --git a/games-sports/gracer/gracer-0.1.5.ebuild b/games-sports/gracer/gracer-0.1.5.ebuild
index 76ad27115b3f..ea8e1a33fb74 100644
--- a/games-sports/gracer/gracer-0.1.5.ebuild
+++ b/games-sports/gracer/gracer-0.1.5.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/gracer-0.1.5.ebuild,v 1.17 2008/01/19 00:43:31 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-sports/gracer/gracer-0.1.5.ebuild,v 1.18 2009/02/11 13:31:26 tupone Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="3D motor sports simulator"
@@ -24,15 +25,14 @@ DEPEND="x11-libs/libXi
media-libs/libpng
media-libs/plib"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch "${FILESDIR}"/${PV}-gldefs.patch \
"${FILESDIR}"/${PN}-gcc-3.4.patch \
- "${FILESDIR}/${P}"-gcc41.patch
+ "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}"/${P}-as-needed.patch
}
-src_compile() {
+src_configure() {
egamesconf \
--enable-gif \
--enable-jpeg \
@@ -42,7 +42,6 @@ src_compile() {
sed -i \
-e 's:-lplibsl:-lplibsl -lplibul:' $(find -name Makefile) \
|| die "sed Makefiles failed"
- emake || die "emake failed"
}
src_install() {