summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-05-22 07:02:27 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-05-22 07:02:27 +0000
commit574d5bd725a01636c3e410a47a747e4eed3f53f6 (patch)
treed93d63f75839c48576cb1d1e8eb27375cfd1c1b0 /games-simulation
parentVersion bump (diff)
downloadgentoo-2-574d5bd725a01636c3e410a47a747e4eed3f53f6.tar.gz
gentoo-2-574d5bd725a01636c3e410a47a747e4eed3f53f6.tar.bz2
gentoo-2-574d5bd725a01636c3e410a47a747e4eed3f53f6.zip
Fix build with gcc-4.4.0 Bug #269866
(Portage version: 2.1.6.11/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/flightgear/ChangeLog6
-rw-r--r--games-simulation/flightgear/files/flightgear-1.9.1-gcc44.patch10
-rw-r--r--games-simulation/flightgear/flightgear-1.9.1.ebuild3
3 files changed, 17 insertions, 2 deletions
diff --git a/games-simulation/flightgear/ChangeLog b/games-simulation/flightgear/ChangeLog
index 3596736b6a94..f87386ebf154 100644
--- a/games-simulation/flightgear/ChangeLog
+++ b/games-simulation/flightgear/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/flightgear
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.38 2009/03/20 14:56:45 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.39 2009/05/22 07:02:27 tupone Exp $
+
+ 22 May 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/flightgear-1.9.1-gcc44.patch, flightgear-1.9.1.ebuild:
+ Fix build with gcc-4.4.0 Bug #269866 by Oschtan
20 Mar 2009; Joseph Jezak <josejx@gentoo.org> flightgear-1.9.1.ebuild:
Marked ~ppc for bug #252202.
diff --git a/games-simulation/flightgear/files/flightgear-1.9.1-gcc44.patch b/games-simulation/flightgear/files/flightgear-1.9.1-gcc44.patch
new file mode 100644
index 000000000000..778ffe506d99
--- /dev/null
+++ b/games-simulation/flightgear/files/flightgear-1.9.1-gcc44.patch
@@ -0,0 +1,10 @@
+--- utils/GPSsmooth/UGear_command.cxx.old 2009-05-22 08:46:02.000000000 +0200
++++ utils/GPSsmooth/UGear_command.cxx 2009-05-22 08:46:58.000000000 +0200
+@@ -1,6 +1,7 @@
+ #include <cstring>
+
+ #include "UGear_command.hxx"
++#include <cstdio>
+
+
+ UGCommand::UGCommand():
diff --git a/games-simulation/flightgear/flightgear-1.9.1.ebuild b/games-simulation/flightgear/flightgear-1.9.1.ebuild
index 51c8e7f8ac2a..7996d0ce3e2a 100644
--- a/games-simulation/flightgear/flightgear-1.9.1.ebuild
+++ b/games-simulation/flightgear/flightgear-1.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-1.9.1.ebuild,v 1.2 2009/03/20 14:56:45 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-1.9.1.ebuild,v 1.3 2009/05/22 07:02:27 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -27,6 +27,7 @@ S=${WORKDIR}/${MY_P}
src_prepare() {
epatch "${FILESDIR}"/${P}-sdl.patch \
+ "${FILESDIR}"/${P}-gcc44.patch \
"${FILESDIR}"/${P}-parallel.patch
eautoreconf
}