summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-11 12:22:49 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-11 12:22:49 +0000
commit24cea9be2d2942f1a56de593b1a1455defa581f5 (patch)
treebabf0042eddc7e1e9769bfc4c4e9aafa8e876c06 /games-simulation/corewars
parentfix dvdr support (diff)
downloadgentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.tar.gz
gentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.tar.bz2
gentoo-2-24cea9be2d2942f1a56de593b1a1455defa581f5.zip
simulation type games
Diffstat (limited to 'games-simulation/corewars')
-rw-r--r--games-simulation/corewars/ChangeLog25
-rw-r--r--games-simulation/corewars/Manifest5
-rw-r--r--games-simulation/corewars/corewars-0.9.12.ebuild34
-rw-r--r--games-simulation/corewars/corewars-0.9.13.ebuild34
-rw-r--r--games-simulation/corewars/files/digest-corewars-0.9.121
-rw-r--r--games-simulation/corewars/files/digest-corewars-0.9.131
6 files changed, 100 insertions, 0 deletions
diff --git a/games-simulation/corewars/ChangeLog b/games-simulation/corewars/ChangeLog
new file mode 100644
index 000000000000..cffe19bce6a4
--- /dev/null
+++ b/games-simulation/corewars/ChangeLog
@@ -0,0 +1,25 @@
+# ChangeLog for app-games/corewars
+# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/corewars/ChangeLog,v 1.1 2003/09/11 12:22:49 vapier Exp $
+
+ 12 Jul 2003; Michael Sterrett <msterret@gentoo.org> corewars-0.9.12.ebuild,
+ corewars-0.9.13.ebuild:
+ fix DESCRIPTION
+
+*corewars-0.9.13 (05 Jun 2003)
+
+ 05 Jun 2003; Martin Holzer <mholzer@gentoo.org> corewars-0.9.13.ebuild:
+ Version bumped. closes #20332.
+
+ 06 Dec 2003; Mark Guertin <gerk@gentoo.org> :
+ Added ~ppc to keywords
+
+*corewars-0.9.12 (14 April 2002)
+
+ 17 jul 2002; Jose Alberto Suárez López <bass@gentoo.org> corewars-0.9.12.ebuild :
+ Added LICENSE, KEYWORDS, SLOT.
+
+ 14 April 2002; Bart Verwilst <verwilst@gentoo.org> Changelog :
+
+ Initial ebuild, SLOT'ified.. Enjoy!
+
diff --git a/games-simulation/corewars/Manifest b/games-simulation/corewars/Manifest
new file mode 100644
index 000000000000..ef3f366f54c8
--- /dev/null
+++ b/games-simulation/corewars/Manifest
@@ -0,0 +1,5 @@
+MD5 04e8119ea5bfea29ed40eedaa5af764f ChangeLog 814
+MD5 3444bec71e3242daa6cace75c0aad8aa corewars-0.9.12.ebuild 850
+MD5 51f2f148281e7d39c3e9843226258900 corewars-0.9.13.ebuild 847
+MD5 bef37270bb17c6337ce7fe924ba75c58 files/digest-corewars-0.9.12 67
+MD5 9586d26f0c5617e0d69dc087ae1599fd files/digest-corewars-0.9.13 67
diff --git a/games-simulation/corewars/corewars-0.9.12.ebuild b/games-simulation/corewars/corewars-0.9.12.ebuild
new file mode 100644
index 000000000000..3c7f20fc6f4c
--- /dev/null
+++ b/games-simulation/corewars/corewars-0.9.12.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/corewars/corewars-0.9.12.ebuild,v 1.1 2003/09/11 12:22:49 vapier Exp $
+
+DESCRIPTION="Simulation game involving virtual machine code"
+SRC_URI="mirror://sourceforge/corewars/${P}.tar.gz"
+HOMEPAGE="http://corewars.sourceforge.net/"
+
+KEYWORDS="x86 ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/x11
+ virtual/glibc
+ >=dev-libs/glib-1.2.10-r1
+ =x11-libs/gtk+-1.2*"
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+
+ emake || die
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc ChangeLog COPYING README TODO DIFFERENCES INTERESTING-COMBINATIONS
+}
diff --git a/games-simulation/corewars/corewars-0.9.13.ebuild b/games-simulation/corewars/corewars-0.9.13.ebuild
new file mode 100644
index 000000000000..05b55e7277f2
--- /dev/null
+++ b/games-simulation/corewars/corewars-0.9.13.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/corewars/corewars-0.9.13.ebuild,v 1.1 2003/09/11 12:22:49 vapier Exp $
+
+DESCRIPTION="Simulation game involving virtual machine code"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+HOMEPAGE="http://corewars.sourceforge.net/"
+
+KEYWORDS="x86 ~ppc"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND="virtual/x11
+ virtual/glibc
+ >=dev-libs/glib-1.2.10-r1
+ =x11-libs/gtk+-1.2*"
+
+src_compile() {
+ ./configure --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info || die
+
+ emake || die
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc ChangeLog COPYING README TODO DIFFERENCES INTERESTING-COMBINATIONS
+}
diff --git a/games-simulation/corewars/files/digest-corewars-0.9.12 b/games-simulation/corewars/files/digest-corewars-0.9.12
new file mode 100644
index 000000000000..ea245f20525e
--- /dev/null
+++ b/games-simulation/corewars/files/digest-corewars-0.9.12
@@ -0,0 +1 @@
+MD5 3420dcf9c03927c8b3905a31c36a1cf3 corewars-0.9.12.tar.gz 163214
diff --git a/games-simulation/corewars/files/digest-corewars-0.9.13 b/games-simulation/corewars/files/digest-corewars-0.9.13
new file mode 100644
index 000000000000..1445bc9bbd91
--- /dev/null
+++ b/games-simulation/corewars/files/digest-corewars-0.9.13
@@ -0,0 +1 @@
+MD5 0a0b8067533b83a96488109ee265f664 corewars-0.9.13.tar.gz 203874