summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-03-24 15:45:04 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-03-24 15:45:04 +0000
commit5c00f792dfb69c6315bea045ae2258cf25c2a386 (patch)
tree1056428230cdf01e0c120d11ba1b1e8230b19178 /games-server
parentUpdate module name for plugincache generation. (diff)
downloadgentoo-2-5c00f792dfb69c6315bea045ae2258cf25c2a386.tar.gz
gentoo-2-5c00f792dfb69c6315bea045ae2258cf25c2a386.tar.bz2
gentoo-2-5c00f792dfb69c6315bea045ae2258cf25c2a386.zip
version bump (bug #544322)
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-server')
-rw-r--r--games-server/monopd/ChangeLog7
-rw-r--r--games-server/monopd/monopd-0.9.8.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/games-server/monopd/ChangeLog b/games-server/monopd/ChangeLog
index 85d5718fe412..62ca89ba358a 100644
--- a/games-server/monopd/ChangeLog
+++ b/games-server/monopd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-server/monopd
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/ChangeLog,v 1.27 2015/01/26 22:32:55 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/ChangeLog,v 1.28 2015/03/24 15:45:04 mr_bones_ Exp $
+
+*monopd-0.9.8 (24 Mar 2015)
+
+ 24 Mar 2015; Michael Sterrett <mr_bones_@gentoo.org> +monopd-0.9.8.ebuild:
+ version bump (bug #544322)
26 Jan 2015; Michael Sterrett <mr_bones_@gentoo.org> -files/monopd,
-files/monopd-0.9.3-dosfix.patch, -files/monopd-0.9.3-gcc43.patch,
diff --git a/games-server/monopd/monopd-0.9.8.ebuild b/games-server/monopd/monopd-0.9.8.ebuild
new file mode 100644
index 000000000000..74fcdbddae8b
--- /dev/null
+++ b/games-server/monopd/monopd-0.9.8.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/monopd/monopd-0.9.8.ebuild,v 1.1 2015/03/24 15:45:04 mr_bones_ Exp $
+
+EAPI=5
+inherit autotools eutils systemd games
+
+DESCRIPTION="server for atlantik games"
+HOMEPAGE="http://gtkatlantic.gradator.net/"
+SRC_URI="http://download.tuxfamily.org/gtkatlantic/monopd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="systemd"
+
+RDEPEND="systemd? ( sys-apps/systemd )"
+DEPEND="${RDEPEND}
+ >=sys-libs/libmath++-0.0.3"
+
+src_prepare() {
+ sed "s:GENTOO_DIR:\"${GAMES_BINDIR}\":" \
+ "${FILESDIR}"/monopd.in > "${T}"/monopd || die
+ sed -i \
+ -e '/C_SUBST(CXXFLAGS/s/CFLAGS/CXXFLAGS/' \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf $(use_with systemd systemd-daemon)
+}
+
+src_install() {
+ default
+ doinitd "${T}"/monopd
+ systemd_dounit doc/systemd/monopd.s*
+ prepgamesdirs
+}