summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-08 10:52:44 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-08 10:52:44 +0000
commit282b557df0c5787a7d9d1ca8cb08d48045cdd55c (patch)
tree57c115070de4ef99ceb37ae884e702361f895e27 /games-mud/tf/tf-50_beta8.ebuild
parentVersion bump, bug #165695 (diff)
downloadgentoo-2-282b557df0c5787a7d9d1ca8cb08d48045cdd55c.tar.gz
gentoo-2-282b557df0c5787a7d9d1ca8cb08d48045cdd55c.tar.bz2
gentoo-2-282b557df0c5787a7d9d1ca8cb08d48045cdd55c.zip
Version bump, bug #165517
(Portage version: 2.1.2-r8)
Diffstat (limited to 'games-mud/tf/tf-50_beta8.ebuild')
-rw-r--r--games-mud/tf/tf-50_beta8.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/games-mud/tf/tf-50_beta8.ebuild b/games-mud/tf/tf-50_beta8.ebuild
new file mode 100644
index 000000000000..929c819d274d
--- /dev/null
+++ b/games-mud/tf/tf-50_beta8.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/tf/tf-50_beta8.ebuild,v 1.1 2007/02/08 10:52:44 nyhm Exp $
+
+inherit games
+
+MY_P="${P/_beta/b}"
+DESCRIPTION="A small, flexible, screen-oriented MUD client"
+HOMEPAGE="http://tinyfugue.sourceforge.net/"
+SRC_URI="mirror://sourceforge/tinyfugue/${MY_P}.tar.gz
+ doc? ( mirror://sourceforge/tinyfugue/${MY_P}-help.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="debug doc ipv6 ssl"
+
+DEPEND="ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ STRIP=: egamesconf \
+ $(use_enable ssl) \
+ $(use_enable debug core) \
+ $(use_enable ipv6 inet6) \
+ --enable-manpage || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/tf || die "dogamesbin failed"
+ newman src/tf.1.catman tf.1
+ dodoc CHANGES CREDITS README
+
+ insinto "${GAMES_DATADIR}"/${PN}-lib
+ # the application looks for this file here if /changes is called.
+ # see comments on bug #23274
+ doins CHANGES || die "doins failed"
+ insopts -m0755
+ doins tf-lib/* || die "doins failed"
+ if use doc ; then
+ dohtml -r *.html commands topics
+ fi
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ use ipv6 && {
+ echo
+ ewarn "You have merged TinyFugue with IPv6-support."
+ ewarn "Support for IPv6 is still being experimental."
+ ewarn "If you experience problems with connecting to hosts,"
+ ewarn "try re-merging this package with USE="-ipv6""
+ echo
+ }
+}