summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2014-10-15 11:50:38 +0000
committerPacho Ramos <pacho@gentoo.org>2014-10-15 11:50:38 +0000
commit2dc9d8bee03c5c1d0dc056555ad8ea2cfb0ae5ff (patch)
treecb31c081790c243ee95e7b2a5b5b2bb852508939 /games-fps
parentStable for amd64 wrt bug #522906 (diff)
downloadgentoo-2-2dc9d8bee03c5c1d0dc056555ad8ea2cfb0ae5ff.tar.gz
gentoo-2-2dc9d8bee03c5c1d0dc056555ad8ea2cfb0ae5ff.tar.bz2
gentoo-2-2dc9d8bee03c5c1d0dc056555ad8ea2cfb0ae5ff.zip
Support multilib providers for deps. Bump to EAPI=5.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/unreal/ChangeLog5
-rw-r--r--games-fps/unreal/unreal-226.ebuild34
2 files changed, 26 insertions, 13 deletions
diff --git a/games-fps/unreal/ChangeLog b/games-fps/unreal/ChangeLog
index 3e6fc931cead..61ff4931cd4f 100644
--- a/games-fps/unreal/ChangeLog
+++ b/games-fps/unreal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/unreal
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal/ChangeLog,v 1.17 2014/09/07 09:48:57 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal/ChangeLog,v 1.18 2014/10/15 11:50:38 pacho Exp $
+
+ 15 Oct 2014; Pacho Ramos <pacho@gentoo.org> unreal-226.ebuild:
+ Support multilib providers for deps. Bump to EAPI=5.
07 Sep 2014; Ulrich Müller <ulm@gentoo.org> unreal-226.ebuild:
Drop reverse dependencies of sys-libs/lib-compat to unstable, bug 517932.
diff --git a/games-fps/unreal/unreal-226.ebuild b/games-fps/unreal/unreal-226.ebuild
index e62840f324e2..4d5216826f72 100644
--- a/games-fps/unreal/unreal-226.ebuild
+++ b/games-fps/unreal/unreal-226.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal/unreal-226.ebuild,v 1.20 2014/09/07 09:48:57 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal/unreal-226.ebuild,v 1.21 2014/10/15 11:50:38 pacho Exp $
+
+EAPI=5
inherit eutils unpacker cdrom games
@@ -17,17 +19,25 @@ IUSE="X opengl"
RESTRICT="mirror bindist"
DEPEND="sys-libs/lib-compat
- app-arch/unzip"
-RDEPEND="!amd64? (
- x11-libs/libXext
- x11-libs/libX11
- x11-libs/libXau
- x11-libs/libXdmcp
- =media-libs/libsdl-1.2*
- opengl? ( virtual/opengl ) )
- amd64? ( app-emulation/emul-linux-x86-sdl
- app-emulation/emul-linux-x86-baselibs
- app-emulation/emul-linux-x86-xlibs )"
+ app-arch/unzip
+"
+RDEPEND="
+ || (
+ (
+ >=media-libs/libsdl-1.2.15-r5[abi_x86_32(-)]
+ x11-libs/libX11[abi_x86_32(-)]
+ x11-libs/libXau[abi_x86_32(-)]
+ x11-libs/libXdmcp[abi_x86_32(-)]
+ x11-libs/libXext[abi_x86_32(-)]
+ opengl? ( virtual/opengl[abi_x86_32(-)] )
+ )
+ amd64? (
+ app-emulation/emul-linux-x86-sdl[-abi_x86_32(-)]
+ app-emulation/emul-linux-x86-xlibs[-abi_x86_32(-)]
+ opengl? ( app-emulation/emul-linux-x86-opengl[abi_x86_32(-)] )
+ )
+ )
+"
S=${WORKDIR}