summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-10-13 04:18:38 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-10-13 04:18:38 +0000
commitb3270853e6aa46ab0df5db4772205c9334bead4c (patch)
treeeb014ed8f1195b9685285e17907b721047f0321b /games-board
parentadd support for n arguments rather than just one (diff)
downloadgentoo-2-b3270853e6aa46ab0df5db4772205c9334bead4c.tar.gz
gentoo-2-b3270853e6aa46ab0df5db4772205c9334bead4c.tar.bz2
gentoo-2-b3270853e6aa46ab0df5db4772205c9334bead4c.zip
--enable-debug doesn't compile; turned off USE=debug support (bug #109084)
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pio/ChangeLog6
-rw-r--r--games-board/pio/pio-0.9.19.ebuild9
-rw-r--r--games-board/pio/pio-0.9.23.ebuild9
3 files changed, 13 insertions, 11 deletions
diff --git a/games-board/pio/ChangeLog b/games-board/pio/ChangeLog
index b05ac9cf635b..4cdbc15fe970 100644
--- a/games-board/pio/ChangeLog
+++ b/games-board/pio/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-board/pio
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pio/ChangeLog,v 1.2 2005/08/18 17:16:43 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/ChangeLog,v 1.3 2005/10/13 04:18:38 mr_bones_ Exp $
+
+ 13 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org> pio-0.9.19.ebuild,
+ pio-0.9.23.ebuild:
+ --enable-debug doesn't compile; turned off USE=debug support (bug #109084)
*pio-0.9.23 (18 Aug 2005)
diff --git a/games-board/pio/pio-0.9.19.ebuild b/games-board/pio/pio-0.9.19.ebuild
index 94b848d5bd23..6f05f3e42bc5 100644
--- a/games-board/pio/pio-0.9.19.ebuild
+++ b/games-board/pio/pio-0.9.19.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pio/pio-0.9.19.ebuild,v 1.2 2005/07/21 03:08:52 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/pio-0.9.19.ebuild,v 1.3 2005/10/13 04:18:38 mr_bones_ Exp $
inherit eutils gnome2 debug
@@ -11,8 +11,8 @@ SRC_URI="mirror://sourceforge/pio/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ~ppc ~amd64"
-IUSE="nls debug X"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="X nls"
RDEPEND=">=dev-libs/glib-2.0
X? ( >=gnome-base/libgnomeui-2.6.1.1
@@ -24,8 +24,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_compile() {
- export G2CONF="${G2CONF} `use_enable nls`"
- export G2CONF="${G2CONF} `use_enable debug`"
+ export G2CONF="${G2CONF} $(use_enable nls)"
if use X ; then
gnome2_src_compile
diff --git a/games-board/pio/pio-0.9.23.ebuild b/games-board/pio/pio-0.9.23.ebuild
index 3bfe7c194e9e..17b01d4354ac 100644
--- a/games-board/pio/pio-0.9.23.ebuild
+++ b/games-board/pio/pio-0.9.23.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/pio/pio-0.9.23.ebuild,v 1.1 2005/08/18 17:16:43 rizzo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/pio/pio-0.9.23.ebuild,v 1.2 2005/10/13 04:18:38 mr_bones_ Exp $
inherit eutils gnome2 debug
@@ -11,8 +11,8 @@ SRC_URI="mirror://sourceforge/pio/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="nls debug X"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE="X nls"
RDEPEND=">=dev-libs/glib-2.4
>=gnome-base/libgnome-2.10
@@ -25,8 +25,7 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
src_compile() {
- export G2CONF="${G2CONF} `use_enable nls`"
- export G2CONF="${G2CONF} `use_enable debug`"
+ export G2CONF="${G2CONF} $(use_enable nls)"
if use X ; then
gnome2_src_compile