summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-03-15 03:53:43 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-03-15 03:53:43 +0000
commit5f0ad7d51595e2f7a32214af17b7bd4df2b42820 (patch)
treec955ed33177b0036f354ec426fb11ea47856135a /games-arcade/performous
parentVersion bump. (diff)
downloadgentoo-2-5f0ad7d51595e2f7a32214af17b7bd4df2b42820.tar.gz
gentoo-2-5f0ad7d51595e2f7a32214af17b7bd4df2b42820.tar.bz2
gentoo-2-5f0ad7d51595e2f7a32214af17b7bd4df2b42820.zip
use the lastest boost
(Portage version: 2.1.10.44/cvs/Linux i686)
Diffstat (limited to 'games-arcade/performous')
-rw-r--r--games-arcade/performous/ChangeLog5
-rw-r--r--games-arcade/performous/performous-0.6.1.ebuild20
2 files changed, 22 insertions, 3 deletions
diff --git a/games-arcade/performous/ChangeLog b/games-arcade/performous/ChangeLog
index ebfb0c2bdc48..00490dfed5df 100644
--- a/games-arcade/performous/ChangeLog
+++ b/games-arcade/performous/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-arcade/performous
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.5 2012/03/14 19:46:34 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/ChangeLog,v 1.6 2012/03/15 03:53:43 mr_bones_ Exp $
+
+ 15 Mar 2012; Michael Sterrett <mr_bones_@gentoo.org> performous-0.6.1.ebuild:
+ use the lastest boost
14 Mar 2012; Tupone Alfredo <tupone@gentoo.org> performous-0.6.1.ebuild:
Fix install of songs. Bug #408167 by lexofleviafan@gmail.com
diff --git a/games-arcade/performous/performous-0.6.1.ebuild b/games-arcade/performous/performous-0.6.1.ebuild
index ef884da73d06..42efb04b7176 100644
--- a/games-arcade/performous/performous-0.6.1.ebuild
+++ b/games-arcade/performous/performous-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.6.1.ebuild,v 1.5 2012/03/14 19:46:34 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/performous/performous-0.6.1.ebuild,v 1.6 2012/03/15 03:53:43 mr_bones_ Exp $
EAPI="3"
@@ -32,7 +32,7 @@ IUSE="songs tools"
RDEPEND="dev-cpp/glibmm
dev-cpp/libxmlpp
media-libs/portaudio
- dev-libs/boost
+ >=dev-libs/boost-1.36
dev-libs/glib
dev-libs/libxml2
gnome-base/librsvg
@@ -70,11 +70,27 @@ src_prepare() {
append-cppflags -DBOOST_FILESYSTEM_VERSION=2
strip-linguas -u lang
+
+ # how do I hate boost? Let me count the ways...
+ local boost_ver=$(best_version ">=dev-libs/boost-1.36")
+
+ boost_ver=${boost_ver/*boost-/}
+ boost_ver=${boost_ver%.*}
+ boost_ver=${boost_ver/./_}
+
+ einfo "Using boost version ${boost_ver}"
+ append-cxxflags \
+ -I/usr/include/boost-${boost_ver}
+ append-ldflags \
+ -L/usr/$(get_libdir)/boost-${boost_ver}
+ export BOOST_INCLUDEDIR="/usr/include/boost-${boost_ver}"
+ export BOOST_LIBRARYDIR="/usr/$(get_libdir)/boost-${boost_ver}"
}
src_configure() {
local mycmakeargs=(
$(cmake-utils_use_enable tools TOOLS)
+ -DCMAKE_VERBOSE_MAKEFILE=TRUE
-DSHARE_INSTALL="${GAMES_DATADIR}"/${PN}
)
cmake-utils_src_configure