summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-11-20 01:40:24 +0000
committerMike Frysinger <vapier@gentoo.org>2003-11-20 01:40:24 +0000
commitb49804dc063a248961b75a234b83a8b99370015c (patch)
tree8fe403924d4b2db0fd73ccf283ba085456de55d6 /games-action/chromium/chromium-0.9.12-r5.ebuild
parentold (diff)
downloadgentoo-2-b49804dc063a248961b75a234b83a8b99370015c.tar.gz
gentoo-2-b49804dc063a248961b75a234b83a8b99370015c.tar.bz2
gentoo-2-b49804dc063a248961b75a234b83a8b99370015c.zip
DEPEND cleanup #33866 and build it nicer
Diffstat (limited to 'games-action/chromium/chromium-0.9.12-r5.ebuild')
-rw-r--r--games-action/chromium/chromium-0.9.12-r5.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/games-action/chromium/chromium-0.9.12-r5.ebuild b/games-action/chromium/chromium-0.9.12-r5.ebuild
new file mode 100644
index 000000000000..02c15e9b9b46
--- /dev/null
+++ b/games-action/chromium/chromium-0.9.12-r5.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/chromium/chromium-0.9.12-r5.ebuild,v 1.1 2003/11/20 01:40:24 vapier Exp $
+
+inherit games eutils
+
+DESCRIPTION="Chromium B.S.U. - an arcade game"
+HOMEPAGE="http://www.reptilelabour.com/software/chromium/"
+SRC_URI="http://www.reptilelabour.com/software/files/chromium/chromium-src-${PV}.tar.gz
+ http://www.reptilelabour.com/software/files/chromium/chromium-data-${PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="x86 ppc alpha amd64"
+IUSE="arts esd qt sdl svga oggvorbis alsa"
+
+DEPEND="virtual/glibc
+ || (
+ sdl? ( media-libs/libsdl
+ media-libs/smpeg )
+ virtual/glut
+ )
+ oggvorbis? ( media-libs/libvorbis )
+ qt? ( =x11-libs/qt-2* )
+ media-libs/openal
+ virtual/x11"
+
+S=${WORKDIR}/Chromium-0.9
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gcc3-gentoo.patch
+ epatch ${FILESDIR}/${PV}-proper-options.patch
+ append-flags -DPKGDATADIR="'\"${GAMES_DATADIR}/${PN}\"'"
+ append-flags -DPKGBINDIR="'\"${GAMES_BINDIR}\"'"
+ sed -i "s:-O2 -DOLD_OPENAL:${CFLAGS}:" src/Makefile
+ sed -i "s:-g:${CFLAGS}:" src-setup/Makefile
+ sed -i "s:-O2:${CFLAGS}:" support/glpng/src/Makefile
+}
+
+src_compile() {
+ if [ `use sdl` ] ; then
+ export ENABLE_SDL="yes"
+ export ENABLE_SMPEG="yes"
+ else
+ export ENABLE_SDL="no"
+ export ENABLE_SMPEG="no"
+ fi
+ use oggvorbis \
+ && export ENABLE_VORBIS="yes" \
+ || export ENABLE_VORBIS="no"
+ use qt \
+ && export ENABLE_SETUP="yes" \
+ && export QTDIR=/usr/qt/2 \
+ || export ENABLE_SETUP="no"
+ ./configure || die "configure failed"
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ exeinto ${GAMES_BINDIR}
+ doexe bin/chromium*
+
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -r data ${D}/${GAMES_DATADIR}/${PN}/
+
+ find ${D} -name CVS -exec rm -rf '{}' \; >& /dev/null
+
+ prepgamesdirs
+}