summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny van Dyk <kugelfang@gentoo.org>2004-07-03 13:20:06 +0000
committerDanny van Dyk <kugelfang@gentoo.org>2004-07-03 13:20:06 +0000
commit7e9d36a990fc38978c1dc8222263db2776ea04f3 (patch)
tree42fabc4968e57e214ff3950da522c7c54ce33b17 /dev-util
parentRemoving wxPython. (diff)
downloadgentoo-2-7e9d36a990fc38978c1dc8222263db2776ea04f3.tar.gz
gentoo-2-7e9d36a990fc38978c1dc8222263db2776ea04f3.tar.bz2
gentoo-2-7e9d36a990fc38978c1dc8222263db2776ea04f3.zip
Fixed BUG #50255. Waiting for lisa's approval to go for unconditional patch.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/anjuta/anjuta-1.2.2.ebuild14
-rw-r--r--dev-util/anjuta/files/anjuta-1.2.2-64bit.patch109
2 files changed, 117 insertions, 6 deletions
diff --git a/dev-util/anjuta/anjuta-1.2.2.ebuild b/dev-util/anjuta/anjuta-1.2.2.ebuild
index c9615a08d1d1..90729b8bfdcd 100644
--- a/dev-util/anjuta/anjuta-1.2.2.ebuild
+++ b/dev-util/anjuta/anjuta-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-1.2.2.ebuild,v 1.5 2004/06/25 02:19:06 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/anjuta/anjuta-1.2.2.ebuild,v 1.6 2004/07/03 13:20:06 kugelfang Exp $
inherit eutils gnome2
@@ -38,13 +38,15 @@ DOCS="AUTHORS COPYING ChangeLog FUTURE NEWS README THANKS TODO"
MAKEOPTS="${MAKEOPTS} -j1"
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
#lets see if this plays nice this version
-#src_unpack() {
-# unpack ${A}
-#
-# cd ${S}
# epatch ${FILESDIR}/${P}_xim.patch
-#}
+
+ use amd64 && epatch ${FILESDIR}/${P}-64bit.patch
+}
pkg_postinst() {
diff --git a/dev-util/anjuta/files/anjuta-1.2.2-64bit.patch b/dev-util/anjuta/files/anjuta-1.2.2-64bit.patch
new file mode 100644
index 000000000000..1923522126a2
--- /dev/null
+++ b/dev-util/anjuta/files/anjuta-1.2.2-64bit.patch
@@ -0,0 +1,109 @@
+--- scintilla/ScintillaGTK.cxx
++++ scintilla/ScintillaGTK.cxx
+@@ -2120,8 +2120,8 @@
+ extern void Platform_Initialise();
+ extern void Platform_Finalise();
+
+-guint scintilla_get_type() {
+- static guint scintilla_type = 0;
++GType scintilla_get_type() {
++ static GType scintilla_type = 0;
+
+ if (!scintilla_type) {
+ Platform_Initialise();
+--- scintilla/include/ScintillaWidget.h
++++ scintilla/include/ScintillaWidget.h
+@@ -34,7 +34,7 @@
+ void (* notify) (ScintillaObject *ttt);
+ };
+
+-guint scintilla_get_type (void);
++GType scintilla_get_type (void);
+ GtkWidget* scintilla_new (void);
+ void scintilla_set_id (ScintillaObject *sci,int id);
+ sptr_t scintilla_send_message (ScintillaObject *sci,unsigned int iMessage, uptr_t wParam, sptr_t lParam);
+--- src/goto_line.c
++++ src/goto_line.c
+@@ -48,10 +48,10 @@
+ static void on_go_to_line_response (GtkDialog* dialog, gint response,
+ gpointer user_data);
+
+-guint
++GType
+ gotoline_get_type ()
+ {
+- static guint obj_type = 0;
++ static GType obj_type = 0;
+
+ if (!obj_type)
+ {
+--- src/goto_line.h
++++ src/goto_line.h
+@@ -52,7 +52,7 @@
+ };
+
+ /** GTK widget implementation function */
+- guint gotoline_get_type (void);
++ GType gotoline_get_type (void);
+
+ /** Create a new instance of this gotoline dialog */
+ GtkWidget *gotoline_new (void);
+--- src/launcher.c
++++ src/launcher.c
+@@ -158,10 +158,10 @@
+ obj->priv->callback_data = NULL;
+ }
+
+-guint
++GType
+ anjuta_launcher_get_type ()
+ {
+- static guint obj_type = 0;
++ static GType obj_type = 0;
+
+ if (!obj_type)
+ {
+--- src/launcher.h
++++ src/launcher.h
+@@ -66,7 +66,7 @@
+ void (*busy_signal) (AnjutaLauncher *launcher, gboolean busy_flag);
+ };
+
+-guint anjuta_launcher_get_type (void);
++GType anjuta_launcher_get_type (void);
+ GObject *anjuta_launcher_new (void);
+ gboolean anjuta_launcher_is_busy (AnjutaLauncher *launcher);
+ gboolean anjuta_launcher_execute (AnjutaLauncher *launcher,
+--- src/message-manager.cc
++++ src/message-manager.cc
+@@ -80,7 +80,7 @@
+ return amm;
+ }
+
+-guint
++GType
+ an_message_manager_get_type (void)
+ {
+ static GType type = 0;
+--- src/message-manager.h
++++ src/message-manager.h
+@@ -68,7 +68,7 @@
+
+ // Public functions
+ GtkWidget* an_message_manager_new();
+-guint an_message_manager_get_type();
++GType an_message_manager_get_type();
+
+ gboolean an_message_manager_add_type(AnMessageManager* amm, const gint type_name, const gchar* pixmap);
+ gboolean an_message_manager_append(AnMessageManager* amm, const gchar* msg_string, gint type_name);
+--- src/preferences.c
++++ src/preferences.c
+@@ -35,6 +35,8 @@
+
+ #include <glade/glade-parser.h>
+
++#include "anjuta.h"
++
+ struct _AnjutaProperty
+ {
+ GtkWidget *object;