summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-20 14:07:13 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-20 14:07:13 +0000
commit10ce7570e4b8a81234a940cb8add0e1fcad59e64 (patch)
tree1252f509ad8aa40d14602845f71aab67081b6360 /dev-util
parentFixed compilation with gcc-4.3. (diff)
downloadgentoo-2-10ce7570e4b8a81234a940cb8add0e1fcad59e64.tar.gz
gentoo-2-10ce7570e4b8a81234a940cb8add0e1fcad59e64.tar.bz2
gentoo-2-10ce7570e4b8a81234a940cb8add0e1fcad59e64.zip
GCC-4.3 build fix (missing headers). Bug 227879.
(Portage version: 2.1.5.5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/httpup/ChangeLog8
-rw-r--r--dev-util/httpup/files/httpup-0.3.2-gcc43.patch50
-rw-r--r--dev-util/httpup/httpup-0.3.2.ebuild7
3 files changed, 61 insertions, 4 deletions
diff --git a/dev-util/httpup/ChangeLog b/dev-util/httpup/ChangeLog
index 50aef350e219..1bf075e4b4cb 100644
--- a/dev-util/httpup/ChangeLog
+++ b/dev-util/httpup/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/httpup
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/ChangeLog,v 1.4 2007/05/15 09:10:31 bangert Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/ChangeLog,v 1.5 2008/06/20 14:07:12 loki_val Exp $
+
+ 20 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/httpup-0.3.2-gcc43.patch, httpup-0.3.2.ebuild:
+ GCC-4.3 build fix (missing headers). Bug 227879.
14 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add <herd>no-herd</herd>
diff --git a/dev-util/httpup/files/httpup-0.3.2-gcc43.patch b/dev-util/httpup/files/httpup-0.3.2-gcc43.patch
new file mode 100644
index 000000000000..29053ef3b17e
--- /dev/null
+++ b/dev-util/httpup/files/httpup-0.3.2-gcc43.patch
@@ -0,0 +1,50 @@
+diff -NrU5 httpup-0.3.2.orig/configparser.cpp httpup-0.3.2/configparser.cpp
+--- httpup-0.3.2.orig/configparser.cpp 2008-06-20 15:59:35.000000000 +0200
++++ httpup-0.3.2/configparser.cpp 2008-06-20 16:00:07.000000000 +0200
+@@ -8,10 +8,11 @@
+ // the Free Software Foundation; either version 2 of the License, or
+ // (at your option) any later version.
+ ////////////////////////////////////////////////////////////////////////
+
+ #include <iostream>
++#include <cstring>
+ #include "configparser.h"
+
+ using namespace std;
+
+ int ConfigParser::parseConfig(const std::string& fileName,
+diff -NrU5 httpup-0.3.2.orig/httpup.cpp httpup-0.3.2/httpup.cpp
+--- httpup-0.3.2.orig/httpup.cpp 2008-06-20 15:59:35.000000000 +0200
++++ httpup-0.3.2/httpup.cpp 2008-06-20 15:59:43.000000000 +0200
+@@ -13,10 +13,12 @@
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <dirent.h>
++#include <cstring>
++#include <cstdlib>
+
+ #include "fileutils.h"
+ #include "httpup.h"
+ #include "configparser.h"
+
+diff -NrU5 httpup-0.3.2.orig/main.cpp httpup-0.3.2/main.cpp
+--- httpup-0.3.2.orig/main.cpp 2008-06-20 15:59:35.000000000 +0200
++++ httpup-0.3.2/main.cpp 2008-06-20 15:59:43.000000000 +0200
+@@ -8,11 +8,14 @@
+ // the Free Software Foundation; either version 2 of the License, or
+ // (at your option) any later version.
+ ////////////////////////////////////////////////////////////////////////
+
+ #include <iostream>
+-#include <string>
++#include <cstring>
++#include <cstdlib>
++#include <algorithm>
++
+ using namespace std;
+
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <dirent.h>
diff --git a/dev-util/httpup/httpup-0.3.2.ebuild b/dev-util/httpup/httpup-0.3.2.ebuild
index a9af79ac34d3..6308e876052f 100644
--- a/dev-util/httpup/httpup-0.3.2.ebuild
+++ b/dev-util/httpup/httpup-0.3.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/httpup-0.3.2.ebuild,v 1.2 2005/05/07 14:48:18 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/httpup/httpup-0.3.2.ebuild,v 1.3 2008/06/20 14:07:12 loki_val Exp $
+
+inherit eutils
DESCRIPTION="synchronisation tool for http file repositories"
HOMEPAGE="http://clc.berlios.de/projects/httpup/"
@@ -19,6 +21,7 @@ src_unpack() {
sed -i \
-e 's:g++:$(CXX) $(CFLAGS) $(LDFLAGS):' \
Makefile
+ epatch "${FILESDIR}"/${P}-gcc43.patch
}
src_install() {