summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-03-22 19:06:18 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-03-22 19:06:18 +0000
commit4525933368d3cf135410c7e4b8916a532e0f6ecb (patch)
tree7abbe31b82bf1f38862947924849e0e828847cb3 /dev-util/ragel
parentRemove old. (diff)
downloadgentoo-2-4525933368d3cf135410c7e4b8916a532e0f6ecb.tar.gz
gentoo-2-4525933368d3cf135410c7e4b8916a532e0f6ecb.tar.bz2
gentoo-2-4525933368d3cf135410c7e4b8916a532e0f6ecb.zip
Version bump; since the new version tremendously simplified the build system, don't sed it around and simply install the binary by hand. Also download the PDF guide with USE=doc instead of building it from the LaTeX sources.
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/ragel')
-rw-r--r--dev-util/ragel/ChangeLog12
-rw-r--r--dev-util/ragel/ragel-6.4.ebuild39
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-util/ragel/ChangeLog b/dev-util/ragel/ChangeLog
index 39316d90137e..22928769a27c 100644
--- a/dev-util/ragel/ChangeLog
+++ b/dev-util/ragel/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/ragel
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ChangeLog,v 1.19 2008/12/14 16:02:25 aballier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ChangeLog,v 1.20 2009/03/22 19:06:18 flameeyes Exp $
+
+*ragel-6.4 (22 Mar 2009)
+
+ 22 Mar 2009; Diego E. Pettenò <flameeyes@gentoo.org> +ragel-6.4.ebuild:
+ Version bump; since the new version tremendously simplified the build
+ system, don't sed it around and simply install the binary by hand. Also
+ download the PDF guide with USE=doc instead of building it from the LaTeX
+ sources.
14 Dec 2008; Alexis Ballier <aballier@gentoo.org> ragel-6.3.ebuild:
typo: textex -> tetex
diff --git a/dev-util/ragel/ragel-6.4.ebuild b/dev-util/ragel/ragel-6.4.ebuild
new file mode 100644
index 000000000000..663daf8b43df
--- /dev/null
+++ b/dev-util/ragel/ragel-6.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ragel/ragel-6.4.ebuild,v 1.1 2009/03/22 19:06:18 flameeyes Exp $
+
+inherit eutils
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code."
+HOMEPAGE="http://www.complang.org/ragel/"
+SRC_URI="http://www.complang.org/ragel/${P}.tar.gz
+ doc? ( http://www.complang.org/ragel/ragel-guide-${PV}.pdf )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="doc vim-syntax"
+
+DEPEND=""
+RDEPEND=""
+
+src_compile() {
+ emake || die "emake failed"
+ emake -C doc ragel.1 || die "emake manpage failed"
+}
+
+src_install() {
+ dobin ragel/ragel || die "dobin failed"
+ doman doc/ragel.1 || die "doman failed"
+ dodoc ChangeLog CREDITS README TODO || die "dodoc failed"
+
+ if use doc; then
+ insinto /usr/share/doc/"${PF}"
+ newins "${DISTDIR}"/ragel-guide-${PV}.pdf "ragel-guide.pdf" || die "newins ragel-guide failed"
+ fi
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim || die "doins ragel.vim failed"
+ fi
+}