summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-03-31 21:03:25 +0000
committerJustin Lecher <jlec@gentoo.org>2010-03-31 21:03:25 +0000
commitad8664a119cef8b2ff418557d73fab5869480538 (patch)
treecedd005019f3cf951bbe53fcbde7637c060d97ab /dev-tcltk/tclpython
parentMake imagemagick switchable with graphicsmagick, bug #309047. (diff)
downloadgentoo-2-ad8664a119cef8b2ff418557d73fab5869480538.tar.gz
gentoo-2-ad8664a119cef8b2ff418557d73fab5869480538.tar.bz2
gentoo-2-ad8664a119cef8b2ff418557d73fab5869480538.zip
Adopted to new python situation, #312507, minor QA
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-tcltk/tclpython')
-rw-r--r--dev-tcltk/tclpython/ChangeLog11
-rw-r--r--dev-tcltk/tclpython/tclpython-3.1-r1.ebuild37
-rw-r--r--dev-tcltk/tclpython/tclpython-4.1-r2.ebuild37
3 files changed, 83 insertions, 2 deletions
diff --git a/dev-tcltk/tclpython/ChangeLog b/dev-tcltk/tclpython/ChangeLog
index 6929358a928f..80f745d614a7 100644
--- a/dev-tcltk/tclpython/ChangeLog
+++ b/dev-tcltk/tclpython/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-tcltk/tclpython
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.9 2009/04/16 19:13:18 mescalinum Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/ChangeLog,v 1.10 2010/03/31 21:03:25 jlec Exp $
+
+*tclpython-4.1-r2 (31 Mar 2010)
+*tclpython-3.1-r1 (31 Mar 2010)
+
+ 31 Mar 2010; Justin Lecher <jlec@gentoo.org> +tclpython-3.1-r1.ebuild,
+ +tclpython-4.1-r2.ebuild:
+ Adopted to new python situation, #312507, minor QA
*tclpython-4.1-r1 (16 Apr 2009)
diff --git a/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild b/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild
new file mode 100644
index 000000000000..5e77c4070c6c
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-3.1-r1.ebuild,v 1.1 2010/03/31 21:03:25 jlec Exp $
+
+PYTHON_DEPEND="2"
+
+inherit distutils multilib toolchain-funcs
+
+DESCRIPTION="Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/tcl-8.4"
+
+src_compile() {
+ einfo \
+ "$(tc-getCC) -shared ${LDFLAGS} -fPIC ${CFLAGS} -o tclpython.so.${PV} \
+ -I$(python_get_includedir) tclpython.c -lpthread -lutil"
+
+ $(tc-getCC) -shared ${LDFLAGS} -fPIC ${CFLAGS} -o tclpython.so.${PV} \
+ -I$(python_get_includedir) tclpython.c -lpthread -lutil \
+ || die
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/tclpython
+ doexe tclpython.so.${PV} pkgIndex.tcl || die "tcl"
+ dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython.so || die
+
+ dodoc CHANGES INSTALL README || die
+ dohtml tclpython.htm || die
+}
diff --git a/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild b/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild
new file mode 100644
index 000000000000..28c745a57df9
--- /dev/null
+++ b/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-tcltk/tclpython/tclpython-4.1-r2.ebuild,v 1.1 2010/03/31 21:03:25 jlec Exp $
+
+PYTHON_DEPEND="2"
+
+inherit distutils multilib toolchain-funcs
+
+DESCRIPTION="Python package for Tcl"
+HOMEPAGE="http://jfontain.free.fr/tclpython.htm"
+SRC_URI="http://jfontain.free.fr/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=">=dev-lang/tcl-8.4"
+
+src_compile() {
+ einfo \
+ "$(tc-getCC) -shared ${LDFLAGS} -fPIC ${CFLAGS} -o tclpython.so.${PV} \
+ -I$(python_get_includedir) tclpython.c -lpthread -lutil"
+
+ $(tc-getCC) -shared ${LDFLAGS} -fPIC ${CFLAGS} -o tclpython.so.${PV} \
+ -I$(python_get_includedir) tclpython.c -lpthread -lutil \
+ || die
+}
+
+src_install() {
+ exeinto /usr/$(get_libdir)/tclpython
+ doexe tclpython.so.${PV} pkgIndex.tcl || die "tcl"
+ dosym tclpython.so.${PV} /usr/$(get_libdir)/tclpython/tclpython.so || die
+
+ dodoc CHANGES INSTALL README || die
+ dohtml tclpython.htm || die
+}