summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-14 23:48:10 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-14 23:48:10 +0000
commite5c4df6f998a53cde06816f5b081ca58c328373f (patch)
treefa3a089cfc35ff42249181c95ee1f4d6d0133f7a /dev-ruby/test-unit
parentVersion bump. (diff)
downloadgentoo-2-e5c4df6f998a53cde06816f5b081ca58c328373f.tar.gz
gentoo-2-e5c4df6f998a53cde06816f5b081ca58c328373f.tar.bz2
gentoo-2-e5c4df6f998a53cde06816f5b081ca58c328373f.zip
Add test-unit-1.2.3 (classic API), and de-keyword version 2, so that it doesn't get installed. Too many packages actually fail to build with the interface from version 2 (and we force it enabled as it is).
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/test-unit')
-rw-r--r--dev-ruby/test-unit/ChangeLog10
-rw-r--r--dev-ruby/test-unit/test-unit-1.2.3.ebuild32
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.5.ebuild6
-rw-r--r--dev-ruby/test-unit/test-unit-2.0.6.ebuild4
4 files changed, 46 insertions, 6 deletions
diff --git a/dev-ruby/test-unit/ChangeLog b/dev-ruby/test-unit/ChangeLog
index 109d9a180fa5..3a6e4f1b23ae 100644
--- a/dev-ruby/test-unit/ChangeLog
+++ b/dev-ruby/test-unit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/test-unit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.14 2010/01/09 21:04:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/ChangeLog,v 1.15 2010/01/14 23:48:10 flameeyes Exp $
+
+*test-unit-1.2.3 (14 Jan 2010)
+
+ 14 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org>
+ +test-unit-1.2.3.ebuild, test-unit-2.0.5.ebuild, test-unit-2.0.6.ebuild:
+ Add test-unit-1.2.3 (classic API), and de-keyword version 2, so that it
+ doesn't get installed. Too many packages actually fail to build with the
+ interface from version 2 (and we force it enabled as it is).
*test-unit-2.0.6 (09 Jan 2010)
diff --git a/dev-ruby/test-unit/test-unit-1.2.3.ebuild b/dev-ruby/test-unit/test-unit-1.2.3.ebuild
new file mode 100644
index 000000000000..43979f19ff14
--- /dev/null
+++ b/dev-ruby/test-unit/test-unit-1.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-1.2.3.ebuild,v 1.1 2010/01/14 23:48:10 flameeyes Exp $
+
+EAPI=2
+
+# This is only useful for Ruby 1.9 for testsuites using the old
+# test/unit
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC="docs"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.txt History.txt"
+
+# Disable default binwraps
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+ruby_add_bdepend doc dev-ruby/hoe
+ruby_add_bdepend test dev-ruby/hoe
+
+# Tests need to be verified
+RESTRICT=test
+
+DESCRIPTION="Nathaniel Talbott's originial test-unit"
+HOMEPAGE="http://test-unit.rubyforge.org/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
diff --git a/dev-ruby/test-unit/test-unit-2.0.5.ebuild b/dev-ruby/test-unit/test-unit-2.0.5.ebuild
index 87253602943e..1d7078b6039c 100644
--- a/dev-ruby/test-unit/test-unit-2.0.5.ebuild
+++ b/dev-ruby/test-unit/test-unit-2.0.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.5.ebuild,v 1.3 2009/12/20 22:28:28 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.5.ebuild,v 1.4 2010/01/14 23:48:10 flameeyes Exp $
EAPI=2
# One test fails on jruby, might be a jruby bug
@@ -22,7 +22,7 @@ SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+KEYWORDS=""
IUSE=""
each_ruby_test() {
diff --git a/dev-ruby/test-unit/test-unit-2.0.6.ebuild b/dev-ruby/test-unit/test-unit-2.0.6.ebuild
index fda29d719ba3..391c0306f6f9 100644
--- a/dev-ruby/test-unit/test-unit-2.0.6.ebuild
+++ b/dev-ruby/test-unit/test-unit-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.6.ebuild,v 1.1 2010/01/09 21:04:37 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/test-unit/test-unit-2.0.6.ebuild,v 1.2 2010/01/14 23:48:10 flameeyes Exp $
EAPI=2
# One test fails on jruby, might be a jruby bug
@@ -24,7 +24,7 @@ SRC_URI="mirror://rubyforge/${PN}/${P}.tgz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+KEYWORDS=""
IUSE=""
each_ruby_test() {