summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 16:27:46 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-01-28 16:27:46 +0000
commitb3e9a4e4dcb43ad81ff0dce6d59af51d00102082 (patch)
tree6a7e806e11dd0fda9fee5c2fb722dfb70540e62d /dev-ruby/shotgun
parentStable on amd64 wrt bug #301904 (diff)
downloadgentoo-2-b3e9a4e4dcb43ad81ff0dce6d59af51d00102082.tar.gz
gentoo-2-b3e9a4e4dcb43ad81ff0dce6d59af51d00102082.tar.bz2
gentoo-2-b3e9a4e4dcb43ad81ff0dce6d59af51d00102082.zip
Version bump, remove now-obsoleted patch. Now use gem for packaging. Add ~x86 as it's tested in a development guest.
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/shotgun')
-rw-r--r--dev-ruby/shotgun/ChangeLog9
-rw-r--r--dev-ruby/shotgun/files/shotgun-0.5-optional-launchy.patch31
-rw-r--r--dev-ruby/shotgun/shotgun-0.5.ebuild45
-rw-r--r--dev-ruby/shotgun/shotgun-0.6.ebuild26
4 files changed, 34 insertions, 77 deletions
diff --git a/dev-ruby/shotgun/ChangeLog b/dev-ruby/shotgun/ChangeLog
index 00469528c9ca..549d22a8abc9 100644
--- a/dev-ruby/shotgun/ChangeLog
+++ b/dev-ruby/shotgun/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-ruby/shotgun
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shotgun/ChangeLog,v 1.1 2010/01/25 18:55:56 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shotgun/ChangeLog,v 1.2 2010/01/28 16:27:38 flameeyes Exp $
+
+*shotgun-0.6 (28 Jan 2010)
+
+ 28 Jan 2010; Diego E. Pettenò <flameeyes@gentoo.org> -shotgun-0.5.ebuild,
+ -files/shotgun-0.5-optional-launchy.patch, +shotgun-0.6.ebuild:
+ Version bump, remove now-obsoleted patch. Now use gem for packaging. Add
+ ~x86 as it's tested in a development guest.
*shotgun-0.5 (25 Jan 2010)
diff --git a/dev-ruby/shotgun/files/shotgun-0.5-optional-launchy.patch b/dev-ruby/shotgun/files/shotgun-0.5-optional-launchy.patch
deleted file mode 100644
index a060234a4299..000000000000
--- a/dev-ruby/shotgun/files/shotgun-0.5-optional-launchy.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 7d571983f5794f88c92560f1fc5061aa4ac12bac Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Diego=20Elio=20'Flameeyes'=20Petten=C3=B2?= <flameeyes@gmail.com>
-Date: Mon, 25 Jan 2010 19:09:53 +0100
-Subject: [PATCH] Don't fail away if launchy could not be loaded.
-
-Since it's just a minor feature, make launchy optional this way.
----
- bin/shotgun | 8 ++++++--
- 1 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/bin/shotgun b/bin/shotgun
-index d618d29..e12c4d8 100755
---- a/bin/shotgun
-+++ b/bin/shotgun
-@@ -137,7 +137,11 @@ server.run app, options do |inst|
- puts "== Shotgun starting #{server.to_s} on http://#{options[:Host]}:#{options[:Port]}"
-
- if browse
-- require 'launchy'
-- Launchy.open("http://#{options[:Host]}:#{options[:Port]}#{options[:Path]}")
-+ begin
-+ require 'launchy'
-+ Launchy.open("http://#{options[:Host]}:#{options[:Port]}#{options[:Path]}")
-+ rescue LoadError
-+ $stderr.puts "Unable to load 'launchy', the browser won't be launched."
-+ end
- end
- end
---
-1.6.6.1
-
diff --git a/dev-ruby/shotgun/shotgun-0.5.ebuild b/dev-ruby/shotgun/shotgun-0.5.ebuild
deleted file mode 100644
index c01fd4117488..000000000000
--- a/dev-ruby/shotgun/shotgun-0.5.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shotgun/shotgun-0.5.ebuild,v 1.1 2010/01/25 18:55:56 flameeyes Exp $
-
-EAPI=2
-USE_RUBY="ruby18"
-
-# No documentation task
-RUBY_FAKEGEM_TASK_DOC=""
-
-RUBY_FAKEGEM_EXTRADOC="README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Forking implementation of rackup"
-HOMEPAGE="http://rtomayko.github.com/shotgun/"
-
-GITHUB_USER="rtomayko"
-# Untagged, but should correspond to 0.5 release
-TREE_HASH="91f76ba3a75a22f60121b1403881aec70f35d75f"
-
-SRC_URI="http://github.com/${GITHUB_USER}/${PN}/tarball/${TREE_HASH} -> ${PN}-git-${PV}.tgz"
-S="${WORKDIR}/${GITHUB_USER}-${PN}-${TREE_HASH:0:7}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-# Warning: the code does not use gem versioning to make sure to load
-# only the right rack version so we might need to patch it to work :/
-# Has a runtime dependency over launchy, but it's not striclty needed,
-# so we'll patch it and announce its possible requirement.
-ruby_add_rdepend '=dev-ruby/rack-1.0*'
-ruby_add_bdepend test dev-ruby/bacon
-
-all_ruby_prepare() {
- epatch "${FILESDIR}"/${P}-optional-launchy.patch
-}
-
-pkg_postinst() {
- elog "${PN} can also launch your browser at startup, but to do so it needs"
- elog "the dev-ruby/launchy package that is currently available just on the Ruby"
- elog "project's overlay for dependency/license issues."
-}
diff --git a/dev-ruby/shotgun/shotgun-0.6.ebuild b/dev-ruby/shotgun/shotgun-0.6.ebuild
new file mode 100644
index 000000000000..e1058f8e1d44
--- /dev/null
+++ b/dev-ruby/shotgun/shotgun-0.6.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/shotgun/shotgun-0.6.ebuild,v 1.1 2010/01/28 16:27:38 flameeyes Exp $
+
+EAPI=2
+USE_RUBY="ruby18"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Forking implementation of rackup"
+HOMEPAGE="http://rtomayko.github.com/shotgun/"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Warning: the code does not use gem versioning to make sure to load
+# only the right rack version so we might need to patch it to work :/
+ruby_add_rdepend '=dev-ruby/rack-1.0*'
+ruby_add_bdepend test dev-ruby/bacon