summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-09-16 09:01:04 +0000
committerHans de Graaff <graaff@gentoo.org>2012-09-16 09:01:04 +0000
commitb45ecd7cdc7f0aba25c22580bd2db92a1acb2f7c (patch)
tree17d9dab8737add747fefded227cf2e8cfef52ee0 /dev-ruby/ruby-odbc
parentNew revision, fixes bugs #433467 and #430168. Thanks to slepnoga (diff)
downloadgentoo-2-b45ecd7cdc7f0aba25c22580bd2db92a1acb2f7c.tar.gz
gentoo-2-b45ecd7cdc7f0aba25c22580bd2db92a1acb2f7c.tar.bz2
gentoo-2-b45ecd7cdc7f0aba25c22580bd2db92a1acb2f7c.zip
Cleanup.
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/ruby-odbc')
-rw-r--r--dev-ruby/ruby-odbc/ChangeLog6
-rw-r--r--dev-ruby/ruby-odbc/ruby-odbc-0.99992.ebuild64
-rw-r--r--dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild64
3 files changed, 5 insertions, 129 deletions
diff --git a/dev-ruby/ruby-odbc/ChangeLog b/dev-ruby/ruby-odbc/ChangeLog
index 8fbd980fb98e..0f19a6da3d5d 100644
--- a/dev-ruby/ruby-odbc/ChangeLog
+++ b/dev-ruby/ruby-odbc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/ruby-odbc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ChangeLog,v 1.30 2012/08/14 18:52:47 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ChangeLog,v 1.31 2012/09/16 09:01:04 graaff Exp $
+
+ 16 Sep 2012; Hans de Graaff <graaff@gentoo.org> -ruby-odbc-0.99992.ebuild,
+ -ruby-odbc-0.99993.ebuild:
+ Cleanup.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> metadata.xml:
Update metadata.xml so that it's the same as most other packages.
diff --git a/dev-ruby/ruby-odbc/ruby-odbc-0.99992.ebuild b/dev-ruby/ruby-odbc/ruby-odbc-0.99992.ebuild
deleted file mode 100644
index b0e8fa8e618c..000000000000
--- a/dev-ruby/ruby-odbc/ruby-odbc-0.99992.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ruby-odbc-0.99992.ebuild,v 1.2 2012/05/01 18:24:10 armin76 Exp $
-
-EAPI=2
-
-# ruby19 → fails to build
-# jruby → uses C extensions
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
-
-inherit ruby-fakegem
-
-DESCRIPTION="RubyODBC - For accessing ODBC data sources from the Ruby language"
-HOMEPAGE="http://www.ch-werner.de/rubyodbc/"
-SRC_URI="http://www.ch-werner.de/rubyodbc/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=dev-db/unixODBC-2.0.6"
-RDEPEND="${DEPEND}"
-
-# tests require to have an ODBC service enabled, so we can't run them
-# for now :(
-RESTRICT=test
-
-all_ruby_prepare() {
- # Make sure that it doesn't try to use the absolute-local path for
- # the extension as we'd be unable to run it properly otherwise.
- sed -i -e 's:\./odbc:odbc:' test/{,utf8/}test.rb || die
-
- # Since lib should not get installed avoid it entirely…
- mv lib contrib || die
-}
-
-each_ruby_configure() {
- for dir in ext ext/utf8; do
- ${RUBY} -C${dir} extconf.rb --disable-dlopen || die "extconf (${dir}) failed"
- done
-}
-
-each_ruby_compile() {
- for dir in ext ext/utf8; do
- emake -C${dir} || die "emake (${dir}) failed"
- done
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- ruby_fakegem_newins ext/odbc.so lib/odbc.so
- ruby_fakegem_newins ext/utf8/odbc_utf8.so lib/odbc_utf8.so
-}
-
-all_ruby_install() {
- all_fakegem_install
- dohtml doc/*.html || die
-}
diff --git a/dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild b/dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild
deleted file mode 100644
index f843d52f2927..000000000000
--- a/dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild
+++ /dev/null
@@ -1,64 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-odbc/ruby-odbc-0.99993.ebuild,v 1.2 2012/05/01 18:24:10 armin76 Exp $
-
-EAPI=2
-
-# ruby19 → fails to build
-# jruby → uses C extensions
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
-
-inherit ruby-fakegem
-
-DESCRIPTION="RubyODBC - For accessing ODBC data sources from the Ruby language"
-HOMEPAGE="http://www.ch-werner.de/rubyodbc/"
-SRC_URI="http://www.ch-werner.de/rubyodbc/${P}.tar.gz"
-
-LICENSE="|| ( GPL-2 Ruby )"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-DEPEND=">=dev-db/unixODBC-2.0.6"
-RDEPEND="${DEPEND}"
-
-# tests require to have an ODBC service enabled, so we can't run them
-# for now :(
-RESTRICT=test
-
-all_ruby_prepare() {
- # Make sure that it doesn't try to use the absolute-local path for
- # the extension as we'd be unable to run it properly otherwise.
- sed -i -e 's:\./odbc:odbc:' test/{,utf8/}test.rb || die
-
- # Since lib should not get installed avoid it entirely…
- mv lib contrib || die
-}
-
-each_ruby_configure() {
- for dir in ext ext/utf8; do
- ${RUBY} -C${dir} extconf.rb --disable-dlopen || die "extconf (${dir}) failed"
- done
-}
-
-each_ruby_compile() {
- for dir in ext ext/utf8; do
- emake -C${dir} || die "emake (${dir}) failed"
- done
-}
-
-each_ruby_install() {
- each_fakegem_install
-
- ruby_fakegem_newins ext/odbc.so lib/odbc.so
- ruby_fakegem_newins ext/utf8/odbc_utf8.so lib/odbc_utf8.so
-}
-
-all_ruby_install() {
- all_fakegem_install
- dohtml doc/*.html || die
-}