summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2002-04-22 01:07:15 +0000
committerAron Griffis <agriffis@gentoo.org>2002-04-22 01:07:15 +0000
commitf7ea283e63c725a8e30c5fb03870446c2ff590ae (patch)
tree64864fe2cb73600aa5f58a2f05c86c73297ec142 /dev-ruby/ruby-gdkpixbuf
parentupdated package (diff)
downloadgentoo-2-f7ea283e63c725a8e30c5fb03870446c2ff590ae.tar.gz
gentoo-2-f7ea283e63c725a8e30c5fb03870446c2ff590ae.tar.bz2
gentoo-2-f7ea283e63c725a8e30c5fb03870446c2ff590ae.zip
Updated lots of ruby-gtk/gnome stuff. Modified ruby-gtk to use the
unified tarball so that all these other ebuilds can use the same tarball. This makes building easier, too, since the ruby-gtk header files are available for each ebuild (otherwise we'd have to install them).
Diffstat (limited to 'dev-ruby/ruby-gdkpixbuf')
-rw-r--r--dev-ruby/ruby-gdkpixbuf/ChangeLog23
-rw-r--r--dev-ruby/ruby-gdkpixbuf/files/digest-ruby-gdkpixbuf-0.271
-rw-r--r--dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild23
3 files changed, 39 insertions, 8 deletions
diff --git a/dev-ruby/ruby-gdkpixbuf/ChangeLog b/dev-ruby/ruby-gdkpixbuf/ChangeLog
index 43a9cda80e04..0a579dba1958 100644
--- a/dev-ruby/ruby-gdkpixbuf/ChangeLog
+++ b/dev-ruby/ruby-gdkpixbuf/ChangeLog
@@ -1,13 +1,20 @@
# ChangeLog for dev-ruby/ruby-gdkpixbuf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkpixbuf/ChangeLog,v 1.1 2002/02/01 21:53:28 gbevin Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkpixbuf/ChangeLog,v 1.2 2002/04/22 01:07:15 agriffis Exp $
+
+*ruby-gdkpixbuf-0.27 (21 Apr 2002)
+
+ 21 Apr 2002; Aron Griffis <agriffis@gentoo.org> ruby-gdkpixbuf-0.27.ebuild:
+
+ Updated to version 0.27
*ruby-gdkpixbuf-0.26 (1 Feb 2002)
- 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
-
- Added initial ChangeLog which should be updated whenever the package is
- updated in any way. This changelog is targetted to users. This means that the
- comments should well explained and written in clean English. The details about
- writing correct changelogs are explained in the skel.ChangeLog file which you
- can find in the root directory of the portage repository.
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that
+ the comments should well explained and written in clean English. The
+ details about writing correct changelogs are explained in the
+ skel.ChangeLog file which you can find in the root directory of the
+ portage repository.
diff --git a/dev-ruby/ruby-gdkpixbuf/files/digest-ruby-gdkpixbuf-0.27 b/dev-ruby/ruby-gdkpixbuf/files/digest-ruby-gdkpixbuf-0.27
new file mode 100644
index 000000000000..a209756ceebd
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf/files/digest-ruby-gdkpixbuf-0.27
@@ -0,0 +1 @@
+MD5 d7663ba9ca6d3f4e91734879d7d58c4b ruby-gnome-all-0.27.tar.gz 362625
diff --git a/dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild b/dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild
new file mode 100644
index 000000000000..abdde02d0a32
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Jerry Alexandratos <jerry@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/ruby-gdkpixbuf/ruby-gdkpixbuf-0.27.ebuild,v 1.1 2002/04/22 01:07:15 agriffis Exp $
+
+S=${WORKDIR}/ruby-gnome-all-${PV}/gdkpixbuf
+DESCRIPTION="Ruby GdkPixbuf bindings"
+SRC_URI="http://prdownloads.sourceforge.net/ruby-gnome/ruby-gnome-all-${PV}.tar.gz"
+HOMEPAGE="http://ruby-gnome.sourceforge.net/"
+
+DEPEND=">=dev-lang/ruby-1.6.4-r1
+ >=dev-ruby/ruby-gtk-${PV}"
+
+src_compile() {
+ ruby extconf.rb || die "ruby extconf.rb failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ make site-install DESTDIR=${D}
+ dodoc [A-Z]*
+ cp -dr sample ${D}/usr/share/doc/${PF}
+}