summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-01-23 09:39:11 +0000
committerHans de Graaff <graaff@gentoo.org>2011-01-23 09:39:11 +0000
commit9325bb3f2e37cfcf5a0564ce9bb001b2e3926e83 (patch)
tree85880fd2046249ae83d5fa1a7e2d43f8f2c6492b /dev-ruby/redcloth
parentAdded Prefix keywords (diff)
downloadgentoo-2-9325bb3f2e37cfcf5a0564ce9bb001b2e3926e83.tar.gz
gentoo-2-9325bb3f2e37cfcf5a0564ce9bb001b2e3926e83.tar.bz2
gentoo-2-9325bb3f2e37cfcf5a0564ce9bb001b2e3926e83.zip
Revision bump to create stable candidate with ree18.
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/redcloth')
-rw-r--r--dev-ruby/redcloth/ChangeLog10
-rw-r--r--dev-ruby/redcloth/redcloth-4.2.3-r1.ebuild6
-rw-r--r--dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild69
3 files changed, 80 insertions, 5 deletions
diff --git a/dev-ruby/redcloth/ChangeLog b/dev-ruby/redcloth/ChangeLog
index 0716eda9c7b4..5a13167419d2 100644
--- a/dev-ruby/redcloth/ChangeLog
+++ b/dev-ruby/redcloth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ruby/redcloth
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.53 2010/12/04 16:04:50 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/ChangeLog,v 1.54 2011/01/23 09:39:11 graaff Exp $
+
+*redcloth-4.2.3-r2 (23 Jan 2011)
+
+ 23 Jan 2011; Hans de Graaff <graaff@gentoo.org> redcloth-4.2.3-r1.ebuild,
+ +redcloth-4.2.3-r2.ebuild:
+ Revision bump to create stable candidate with ree18.
04 Dec 2010; Fabian Groffen <grobian@gentoo.org> redcloth-4.2.3-r1.ebuild:
Marked ~x64-macos, ~x86-solaris
diff --git a/dev-ruby/redcloth/redcloth-4.2.3-r1.ebuild b/dev-ruby/redcloth/redcloth-4.2.3-r1.ebuild
index b56115c9cc58..2db7ef9e85ac 100644
--- a/dev-ruby/redcloth/redcloth-4.2.3-r1.ebuild
+++ b/dev-ruby/redcloth/redcloth-4.2.3-r1.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.3-r1.ebuild,v 1.4 2010/12/04 16:04:50 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.3-r1.ebuild,v 1.5 2011/01/23 09:39:11 graaff Exp $
EAPI=2
# jruby → tests still fail with UTF-8 characters
# http://jgarber.lighthouseapp.com/projects/13054/tickets/149-redcloth-4-doesnt-support-multi-bytes-content
-USE_RUBY="ruby18 ree18 ruby19"
+USE_RUBY="ruby18 ree18"
RUBY_FAKEGEM_NAME="RedCloth"
diff --git a/dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild b/dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild
new file mode 100644
index 000000000000..24389f12dd07
--- /dev/null
+++ b/dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/redcloth/redcloth-4.2.3-r2.ebuild,v 1.1 2011/01/23 09:39:11 graaff Exp $
+
+EAPI=2
+
+# jruby → tests still fail with UTF-8 characters
+# http://jgarber.lighthouseapp.com/projects/13054/tickets/149-redcloth-4-doesnt-support-multi-bytes-content
+USE_RUBY="ruby18 ree18 ruby19"
+
+RUBY_FAKEGEM_NAME="RedCloth"
+
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_TASK_DOC="docs"
+
+RUBY_FAKEGEM_DOCDIR="doc"
+
+RUBY_FAKEGEM_EXTRADOC="README CHANGELOG"
+
+RUBY_FAKEGEM_REQUIRE_PATHS="lib/case_sensitive_require"
+
+inherit ruby-fakegem versionator
+
+DESCRIPTION="A module for using Textile in Ruby"
+HOMEPAGE="http://redcloth.org/"
+
+SRC_URI="http://github.com/jgarber/redcloth/tarball/RELEASE_$(replace_all_version_separators _) -> ${RUBY_FAKEGEM_NAME}-git-${PV}.tgz
+ http://dev.gentoo.org/~flameeyes/patches/${PN}/${P}+ruby-1.9.2.patch.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+DEPEND="$DEPEND
+ dev-util/ragel"
+RDEPEND="$RDEPEND"
+
+S="${WORKDIR}/jgarber-${PN}-*"
+
+ruby_add_bdepend "
+ dev-ruby/rake
+ >=dev-ruby/echoe-3.0.1
+ test? (
+ dev-ruby/rspec
+ dev-ruby/diff-lcs
+ )"
+
+RUBY_PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${DISTDIR}"/${P}+ruby-1.9.2.patch.bz2
+)
+
+pkg_setup() {
+ # Export the VERBOSE variable to avoid remapping of stdout and
+ # stderr, and that breaks because of bad interactions between
+ # echoe, Ruby and Gentoo.
+ export VERBOSE=1
+}
+
+each_ruby_compile() {
+ # We cannot run this manually easily, because Ragel re-generation
+ # is a mess
+ ${RUBY} -S rake compile || die "rake compile failed"
+}
+
+each_ruby_test() {
+ find spec -name '*_spec.rb' -print0 | xargs -0 ${RUBY} -I lib -S spec -Du -fs
+}