summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-12-06 19:06:40 +0000
committerHans de Graaff <graaff@gentoo.org>2011-12-06 19:06:40 +0000
commit8d16c7d17a226519bed3db4f41fbe18d2cdc1278 (patch)
treeff80504af42507ac84a7babeb8dd377908cf95fd /dev-ruby/gherkin
parents/use shell/use gnome-shell/ (bug #393399, thanks to Rafael Antonio Porras <S... (diff)
downloadgentoo-2-8d16c7d17a226519bed3db4f41fbe18d2cdc1278.tar.gz
gentoo-2-8d16c7d17a226519bed3db4f41fbe18d2cdc1278.tar.bz2
gentoo-2-8d16c7d17a226519bed3db4f41fbe18d2cdc1278.zip
Remove old versions.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/gherkin')
-rw-r--r--dev-ruby/gherkin/ChangeLog6
-rw-r--r--dev-ruby/gherkin/gherkin-2.4.11.ebuild72
-rw-r--r--dev-ruby/gherkin/gherkin-2.4.14.ebuild72
-rw-r--r--dev-ruby/gherkin/gherkin-2.4.15.ebuild72
-rw-r--r--dev-ruby/gherkin/gherkin-2.4.18.ebuild72
5 files changed, 5 insertions, 289 deletions
diff --git a/dev-ruby/gherkin/ChangeLog b/dev-ruby/gherkin/ChangeLog
index 42bb397a62fd..d2628e366800 100644
--- a/dev-ruby/gherkin/ChangeLog
+++ b/dev-ruby/gherkin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-ruby/gherkin
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.32 2011/09/21 06:22:36 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/ChangeLog,v 1.33 2011/12/06 19:06:40 graaff Exp $
+
+ 06 Dec 2011; Hans de Graaff <graaff@gentoo.org> -gherkin-2.4.11.ebuild,
+ -gherkin-2.4.14.ebuild, -gherkin-2.4.15.ebuild, -gherkin-2.4.18.ebuild:
+ Remove old versions.
*gherkin-2.4.21 (21 Sep 2011)
diff --git a/dev-ruby/gherkin/gherkin-2.4.11.ebuild b/dev-ruby/gherkin/gherkin-2.4.11.ebuild
deleted file mode 100644
index ce90091bf4c7..000000000000
--- a/dev-ruby/gherkin/gherkin-2.4.11.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.4.11.ebuild,v 1.1 2011/08/20 08:41:57 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-RUBY_S="cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.4.0
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.0.0
- >=dev-ruby/rspec-2.6.0
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.7.2 )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}
diff --git a/dev-ruby/gherkin/gherkin-2.4.14.ebuild b/dev-ruby/gherkin/gherkin-2.4.14.ebuild
deleted file mode 100644
index 6232b94dd305..000000000000
--- a/dev-ruby/gherkin/gherkin-2.4.14.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.4.14.ebuild,v 1.1 2011/08/21 06:50:35 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-RUBY_S="cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.4.0
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.0.0
- >=dev-ruby/rspec-2.6.0
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.7.2 )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}
diff --git a/dev-ruby/gherkin/gherkin-2.4.15.ebuild b/dev-ruby/gherkin/gherkin-2.4.15.ebuild
deleted file mode 100644
index f70c3fc6b5d1..000000000000
--- a/dev-ruby/gherkin/gherkin-2.4.15.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.4.15.ebuild,v 1.1 2011/08/26 06:07:26 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-RUBY_S="cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.4.0
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.0.0
- >=dev-ruby/rspec-2.6.0
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.7.2 )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}
diff --git a/dev-ruby/gherkin/gherkin-2.4.18.ebuild b/dev-ruby/gherkin/gherkin-2.4.18.ebuild
deleted file mode 100644
index 17a12e74fe4c..000000000000
--- a/dev-ruby/gherkin/gherkin-2.4.18.ebuild
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/gherkin/gherkin-2.4.18.ebuild,v 1.1 2011/09/10 09:42:39 graaff Exp $
-
-EAPI=4
-USE_RUBY="ruby18 ree18"
-
-RUBY_FAKEGEM_TASK_DOC="yard"
-RUBY_FAKEGEM_TASK_TEST=""
-
-RUBY_FAKEGEM_DOCDIR="rdoc"
-RUBY_FAKEGEM_EXTRADOC="History.md README.md"
-
-inherit ruby-fakegem
-
-DESCRIPTION="Fast Gherkin lexer and parser based on Ragel."
-HOMEPAGE="http://wiki.github.com/aslakhellesoy/cucumber/gherkin"
-LICENSE="MIT"
-SRC_URI="https://github.com/cucumber/gherkin/tarball/v${PV} -> ${P}.tgz"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="doc test"
-
-DEPEND="${DEPEND} dev-util/ragel"
-RDEPEND="${RDEPEND}"
-
-RUBY_S="cucumber-gherkin-*"
-
-ruby_add_bdepend "
- dev-ruby/rake-compiler
- test? (
- >=dev-ruby/awesome_print-0.4.0
- >=dev-ruby/builder-2.1.2
- >=dev-util/cucumber-1.0.0
- >=dev-ruby/rspec-2.6.0
- >=dev-ruby/term-ansicolor-1.0.5
- )
- doc? ( >=dev-ruby/yard-0.7.2 )"
-
-ruby_add_rdepend ">=dev-ruby/json-1.4.6"
-
-all_ruby_prepare() {
- # Remove Bundler-related things.
- sed -i -e '/[Bb]undler/d' Rakefile spec/spec_helper.rb features/support/env.rb || die
- rm Gemfile || die
-
- # Don't use compile dependencies to avoid building again for specs.
- sed -i -e '/:compile/d' Rakefile
-
- # Remove feature that depends on direct access to the cucumber
- # source. We could probably set this up by downloading the source
- # and unpacking it, but skipping this now in the interest of time.
- rm features/pretty_formatter.feature || die
-
- # We need to remove these tasks during bootstrapping since it tries
- # to load cucumber already but we can be sure it isn't installed
- # yet. Also remove other rake tasks for which we may not yet have
- # dependencies.
- if ! use test ; then
- rm tasks/cucumber.rake tasks/rspec.rake || die "Unable to remove rake tasks."
- fi
-}
-
-each_ruby_compile() {
- ${RUBY} -I lib -S rake -rrake/clean -f tasks/compile.rake compile || die
-}
-
-each_ruby_test() {
- ${RUBY} -I lib -S rake spec || die "Specs failed"
- CUCUMBER_HOME="${HOME}" RUBYLIB=lib ${RUBY} -S cucumber features || die "Cucumber features failed"
-}