summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2010-09-18 15:50:07 +0000
committerHans de Graaff <graaff@gentoo.org>2010-09-18 15:50:07 +0000
commitebe17fc78c0de7a628246b475c8f57557f69af92 (patch)
tree5b585229264d68f965e0ee3c8a723ed259639c65 /dev-ruby/facter
parentalpha/arm/ia64/sh/sparc stable wrt #334959 (diff)
downloadgentoo-2-ebe17fc78c0de7a628246b475c8f57557f69af92.tar.gz
gentoo-2-ebe17fc78c0de7a628246b475c8f57557f69af92.tar.bz2
gentoo-2-ebe17fc78c0de7a628246b475c8f57557f69af92.zip
Version bump with various bug fixes. Drop all 1.5.7 patches because all changes appear to be incorporated in 1.5.8. Run specs and drop hppa because of the new dependency this introduces: bug 337956.
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'dev-ruby/facter')
-rw-r--r--dev-ruby/facter/ChangeLog10
-rw-r--r--dev-ruby/facter/facter-1.5.8.ebuild25
-rw-r--r--dev-ruby/facter/files/facter-1.5.8-freebsd-spec.patch18
3 files changed, 52 insertions, 1 deletions
diff --git a/dev-ruby/facter/ChangeLog b/dev-ruby/facter/ChangeLog
index d7b38fc1d097..fe0e0a956af2 100644
--- a/dev-ruby/facter/ChangeLog
+++ b/dev-ruby/facter/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-ruby/facter
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.29 2010/07/29 08:43:54 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/ChangeLog,v 1.30 2010/09/18 15:50:07 graaff Exp $
+
+*facter-1.5.8 (18 Sep 2010)
+
+ 18 Sep 2010; Hans de Graaff <graaff@gentoo.org> +facter-1.5.8.ebuild,
+ +files/facter-1.5.8-freebsd-spec.patch:
+ Version bump with various bug fixes. Drop all 1.5.7 patches because all
+ changes appear to be incorporated in 1.5.8. Run specs and drop hppa
+ because of the new dependency this introduces: bug 337956.
29 Jul 2010; Guy Martin <gmsoft@gentoo.org> facter-1.5.7-r1.ebuild:
Added ~hppa to KEYWORDS.
diff --git a/dev-ruby/facter/facter-1.5.8.ebuild b/dev-ruby/facter/facter-1.5.8.ebuild
new file mode 100644
index 000000000000..726670aebb2a
--- /dev/null
+++ b/dev-ruby/facter/facter-1.5.8.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/facter/facter-1.5.8.ebuild,v 1.1 2010/09/18 15:50:07 graaff Exp $
+
+EAPI="2"
+# jruby failed to install
+USE_RUBY="ruby18 ruby19 ree18"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="spec"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README* TODO"
+RUBY_FAKEGEM_BINWRAP="facter"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A cross-platform Ruby library for retrieving facts from operating systems"
+HOMEPAGE="http://www.puppetlabs.com/puppet/related-projects/facter/"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+
+RUBY_PATCHES=( "${P}-freebsd-spec.patch" )
+
+ruby_add_bdepend "test? ( dev-ruby/rspec:0 )"
diff --git a/dev-ruby/facter/files/facter-1.5.8-freebsd-spec.patch b/dev-ruby/facter/files/facter-1.5.8-freebsd-spec.patch
new file mode 100644
index 000000000000..411780154366
--- /dev/null
+++ b/dev-ruby/facter/files/facter-1.5.8-freebsd-spec.patch
@@ -0,0 +1,18 @@
+commit 1125e1e050a3807df2ada4d8cf2d36c22a75ed2b
+Author: Hans de Graaff <hans@degraaff.org>
+Date: Sat Sep 18 17:31:11 2010 +0200
+
+ Make sure FreeBSD spec also works on systems that have /proc/cpuinfo.
+
+diff --git a/spec/unit/util/virtual.rb b/spec/unit/util/virtual.rb
+index 1e31a2f..cc528d1 100644
+--- a/spec/unit/util/virtual.rb
++++ b/spec/unit/util/virtual.rb
+@@ -101,6 +101,7 @@ describe Facter::Util::Virtual do
+ end
+
+ it "should detect kvm on FreeBSD" do
++ FileTest.stubs(:exists?).with("/proc/cpuinfo").returns(false)
+ Facter.fact(:kernel).stubs(:value).returns("FreeBSD")
+ Facter::Util::Resolution.stubs(:exec).with("/sbin/sysctl -n hw.model").returns("QEMU Virtual CPU version 0.12.4")
+ Facter::Util::Virtual.should be_kvm