summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-27 23:06:40 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-27 23:06:40 +0000
commite786137e911a021cc6153d40f5e1aaa4a34b77d4 (patch)
tree108b9ae9b5a89f4c7d3d275a9656e0d9ea3e21d1 /dev-ruby/celluloid
parentremove old unp versions (diff)
downloadgentoo-2-e786137e911a021cc6153d40f5e1aaa4a34b77d4.tar.gz
gentoo-2-e786137e911a021cc6153d40f5e1aaa4a34b77d4.tar.bz2
gentoo-2-e786137e911a021cc6153d40f5e1aaa4a34b77d4.zip
Add ruby21 target.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'dev-ruby/celluloid')
-rw-r--r--dev-ruby/celluloid/ChangeLog5
-rw-r--r--dev-ruby/celluloid/celluloid-0.15.2-r2.ebuild6
2 files changed, 7 insertions, 4 deletions
diff --git a/dev-ruby/celluloid/ChangeLog b/dev-ruby/celluloid/ChangeLog
index 319f3ecefd2b..a0bcf1035282 100644
--- a/dev-ruby/celluloid/ChangeLog
+++ b/dev-ruby/celluloid/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ruby/celluloid
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/ChangeLog,v 1.9 2014/08/12 22:45:35 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/ChangeLog,v 1.10 2014/08/27 23:06:40 mrueg Exp $
+
+ 27 Aug 2014; Manuel Rüger <mrueg@gentoo.org> celluloid-0.15.2-r2.ebuild:
+ Add ruby21 target.
12 Aug 2014; Anthony G. Basile <blueness@gentoo.org>
celluloid-0.15.2-r2.ebuild:
diff --git a/dev-ruby/celluloid/celluloid-0.15.2-r2.ebuild b/dev-ruby/celluloid/celluloid-0.15.2-r2.ebuild
index 559c203908ce..8871b8c7ee3e 100644
--- a/dev-ruby/celluloid/celluloid-0.15.2-r2.ebuild
+++ b/dev-ruby/celluloid/celluloid-0.15.2-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/celluloid-0.15.2-r2.ebuild,v 1.2 2014/08/12 22:45:35 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ruby/celluloid/celluloid-0.15.2-r2.ebuild,v 1.3 2014/08/27 23:06:40 mrueg Exp $
EAPI=5
# rbx or jruby recommended, but only in 1.9 mode.
-USE_RUBY="ruby19 ruby20"
+USE_RUBY="ruby19 ruby20 ruby21"
RUBY_FAKEGEM_RECIPE_TEST="rspec"
#Needed by dev-ruby/listen
@@ -28,5 +28,5 @@ ruby_add_rdepend ">=dev-ruby/timers-1.0.0"
all_ruby_prepare() {
rm Gemfile .rspec || die
- sed -i -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
}