summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-12-16 07:14:55 +0000
committerIan Delaney <idella4@gentoo.org>2014-12-16 07:14:55 +0000
commit3c126cc3467c9ca42412501bf51064d35e8ed9bc (patch)
treec6ade70b11afcdcfed53b05e74812dc5b6350f86 /dev-python
parentVersion bump (diff)
downloadgentoo-2-3c126cc3467c9ca42412501bf51064d35e8ed9bc.tar.gz
gentoo-2-3c126cc3467c9ca42412501bf51064d35e8ed9bc.tar.bz2
gentoo-2-3c126cc3467c9ca42412501bf51064d35e8ed9bc.zip
drop old impl add py3.4 in 1.3.0, correction to deps
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/oct2py/ChangeLog6
-rw-r--r--dev-python/oct2py/oct2py-1.3.0-r1.ebuild6
-rw-r--r--dev-python/oct2py/oct2py-1.3.0.ebuild8
3 files changed, 12 insertions, 8 deletions
diff --git a/dev-python/oct2py/ChangeLog b/dev-python/oct2py/ChangeLog
index 5f5651631a2d..ff368e558874 100644
--- a/dev-python/oct2py/ChangeLog
+++ b/dev-python/oct2py/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/oct2py
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.19 2014/11/29 20:06:55 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.20 2014/12/16 07:14:55 idella4 Exp $
+
+ 16 Dec 2014; Ian Delaney <idella4@gentoo.org> oct2py-1.3.0-r1.ebuild,
+ oct2py-1.3.0.ebuild:
+ drop old impl add py3.4 in 1.3.0, correction to deps
29 Nov 2014; Markus Meier <maekke@gentoo.org> oct2py-1.3.0-r1.ebuild:
add ~arm, bug #518742
diff --git a/dev-python/oct2py/oct2py-1.3.0-r1.ebuild b/dev-python/oct2py/oct2py-1.3.0-r1.ebuild
index 6a90586c5edd..3aefb1ff5e20 100644
--- a/dev-python/oct2py/oct2py-1.3.0-r1.ebuild
+++ b/dev-python/oct2py/oct2py-1.3.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.3.0-r1.ebuild,v 1.4 2014/11/29 20:06:55 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.3.0-r1.ebuild,v 1.5 2014/12/16 07:14:55 idella4 Exp $
EAPI=5
@@ -22,8 +22,8 @@ RDEPEND="
sci-mathematics/octave"
DEPEND="${RDEPEND}
doc? (
- dev-python/sphinx-bootstrap-theme
- dev-python/numpydoc
+ dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
)
test? (
dev-python/nose[${PYTHON_USEDEP}]
diff --git a/dev-python/oct2py/oct2py-1.3.0.ebuild b/dev-python/oct2py/oct2py-1.3.0.ebuild
index 5b3a71948357..5f2052ce4e6e 100644
--- a/dev-python/oct2py/oct2py-1.3.0.ebuild
+++ b/dev-python/oct2py/oct2py-1.3.0.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.3.0.ebuild,v 1.3 2014/08/14 23:31:25 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-1.3.0.ebuild,v 1.4 2014/12/16 07:14:55 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7,3_3} )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
inherit distutils-r1
@@ -22,8 +22,8 @@ RDEPEND="
sci-mathematics/octave"
DEPEND="${RDEPEND}
doc? (
- dev-python/sphinx-bootstrap-theme
- dev-python/numpydoc
+ dev-python/sphinx-bootstrap-theme[${PYTHON_USEDEP}]
+ dev-python/numpydoc[${PYTHON_USEDEP}]
)
test? (
dev-python/nose[${PYTHON_USEDEP}]