summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-05-23 08:16:59 +0000
committerJustin Lecher <jlec@gentoo.org>2015-05-23 08:16:59 +0000
commitd2b131489d1d105fadd4fcf173496928d3ed96bb (patch)
tree6313c9f6820a66f5136054d5f5dda94bebb711d4 /dev-python/virtualenv
parentCleanup. (diff)
downloadgentoo-2-d2b131489d1d105fadd4fcf173496928d3ed96bb.tar.gz
gentoo-2-d2b131489d1d105fadd4fcf173496928d3ed96bb.tar.bz2
gentoo-2-d2b131489d1d105fadd4fcf173496928d3ed96bb.zip
Version Bump
(Portage version: 2.2.19/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/ChangeLog7
-rw-r--r--dev-python/virtualenv/virtualenv-13.0.1.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/dev-python/virtualenv/ChangeLog b/dev-python/virtualenv/ChangeLog
index 0557e10b5f95..541faa045a02 100644
--- a/dev-python/virtualenv/ChangeLog
+++ b/dev-python/virtualenv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/virtualenv
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/ChangeLog,v 1.144 2015/05/22 11:38:39 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/ChangeLog,v 1.145 2015/05/23 08:16:59 jlec Exp $
+
+*virtualenv-13.0.1 (23 May 2015)
+
+ 23 May 2015; Justin Lecher <jlec@gentoo.org> +virtualenv-13.0.1.ebuild:
+ Version Bump
*virtualenv-13.0.0 (22 May 2015)
diff --git a/dev-python/virtualenv/virtualenv-13.0.1.ebuild b/dev-python/virtualenv/virtualenv-13.0.1.ebuild
new file mode 100644
index 000000000000..d3516e33bfc6
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-13.0.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/virtualenv/virtualenv-13.0.1.ebuild,v 1.1 2015/05/23 08:16:59 jlec Exp $
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="http://www.virtualenv.org/ http://pypi.python.org/pypi/virtualenv https://github.com/pypa/virtualenv/"
+SRC_URI="https://github.com/pypa/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+SLOT="0"
+IUSE="doc test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+DOCS=( docs/index.rst docs/changes.rst )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.2-no-versioned-script.patch
+ "${FILESDIR}"/${PN}-12.1.1-skip-broken-test.patch
+)
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${S}"/docs/_build/html/. )
+ distutils-r1_python_install_all
+}