summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2009-12-21 17:18:41 +0000
committerSebastian Pipping <sping@gentoo.org>2009-12-21 17:18:41 +0000
commit38562d3c4b593f4dd4d0e8f3cd598e9cac02528f (patch)
tree8f47d94c94283a7e54c383323f2ed0f2ae199a98 /dev-python/sclapp
parentUpdate gcc-4.4 patch. Thanks to Yu Yuwei in bug #297721. (diff)
downloadgentoo-2-38562d3c4b593f4dd4d0e8f3cd598e9cac02528f.tar.gz
gentoo-2-38562d3c4b593f4dd4d0e8f3cd598e9cac02528f.tar.bz2
gentoo-2-38562d3c4b593f4dd4d0e8f3cd598e9cac02528f.zip
dev-python/sclapp: Integrate testsuite patch
(Portage version: 2.2_rc54/cvs/Linux i686)
Diffstat (limited to 'dev-python/sclapp')
-rw-r--r--dev-python/sclapp/ChangeLog6
-rw-r--r--dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch40
-rw-r--r--dev-python/sclapp/sclapp-0.5.3.ebuild6
3 files changed, 47 insertions, 5 deletions
diff --git a/dev-python/sclapp/ChangeLog b/dev-python/sclapp/ChangeLog
index 51febfe80299..7482699d9963 100644
--- a/dev-python/sclapp/ChangeLog
+++ b/dev-python/sclapp/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/sclapp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sclapp/ChangeLog,v 1.2 2009/12/20 21:44:57 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sclapp/ChangeLog,v 1.3 2009/12/21 17:18:41 sping Exp $
+
+ 21 Dec 2009; Sebastian Pipping <sping@gentoo.org> sclapp-0.5.3.ebuild,
+ +files/sclapp-0.5.3-testsuite-fix-from-r235.patch:
+ Integrate fresh testsuite patch from upstream revision 235
20 Dec 2009; Torsten Veller <tove@gentoo.org> metadata.xml:
Fix metadata: maintainer-wanted herd does not exist
diff --git a/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch b/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch
new file mode 100644
index 000000000000..45965f01b1de
--- /dev/null
+++ b/dev-python/sclapp/files/sclapp-0.5.3-testsuite-fix-from-r235.patch
@@ -0,0 +1,40 @@
+=== modified file 'NEWS'
+--- NEWS 2009-01-14 11:11:28 +0000
++++ NEWS 2009-12-21 14:12:02 +0000
+@@ -25,6 +25,9 @@
+
+ (Forest Bond)
+
++ * Fixed output protection test that was failing on some systems.
++ (Forest Bond)
++
+
+ sclapp 0.5.3 2008-07-21
+ =======================
+
+=== modified file 'tests/output_protection.py'
+--- tests/output_protection.py 2008-05-18 21:46:03 +0000
++++ tests/output_protection.py 2009-12-21 14:12:02 +0000
+@@ -109,8 +109,10 @@
+ exceptions = ()):
+ def test_fn():
+ pid = failure_fn(main_fn)
+- assertLogFileContainsExactly('foo', foos)
+- assertLogFileContainsExactly('bar', bars)
++ if foos is not None:
++ assertLogFileContainsExactly('foo', foos)
++ if bars is not None:
++ assertLogFileContainsExactly('bar', bars)
+ for signal in signals:
+ assertSignalCaught(signal, pid)
+ for exception in exceptions:
+@@ -171,7 +173,7 @@
+ 'test_stdout_fails_without_signal_handling_without_output_protection',
+ _stdout_fails,
+ main_without_signal_handling_without_output_protection,
+- 2, 2, ()
++ 2, None, ()
+ )))
+ test_stdout_stderr_fail_without_signal_handling_without_output_protection = (
+ staticmethod(_make_test_fn(
+
diff --git a/dev-python/sclapp/sclapp-0.5.3.ebuild b/dev-python/sclapp/sclapp-0.5.3.ebuild
index b65485fccc5f..8c705d594acb 100644
--- a/dev-python/sclapp/sclapp-0.5.3.ebuild
+++ b/dev-python/sclapp/sclapp-0.5.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/sclapp/sclapp-0.5.3.ebuild,v 1.1 2009/12/20 20:43:41 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/sclapp/sclapp-0.5.3.ebuild,v 1.2 2009/12/21 17:18:41 sping Exp $
EAPI="2"
SUPPORT_PYTHON_ABIS="1"
@@ -21,9 +21,7 @@ RDEPEND=""
RESTRICT_PYTHON_ABIS="3.*"
src_prepare() {
- # Disable failing test
- sed -e "s/test_stdout_fails_without_signal_handling_without_output_protection/_&/" \
- -i tests/output_protection.py || die "sed failed"
+ epatch "${FILESDIR}/${P}-testsuite-fix-from-r235.patch"
}
src_test() {