summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-04-24 08:45:32 +0000
committerIan Delaney <idella4@gentoo.org>2015-04-24 08:45:32 +0000
commit3210438b6ad8969e5a25b8ab84b7a17e389e25e4 (patch)
tree39eec9ff11f5194c352e35f94e11680262694dff /dev-python/pythondialog
parentBackport upstream patch to compile with hardened gcc, bug 542610. Drop unneed... (diff)
downloadgentoo-2-3210438b6ad8969e5a25b8ab84b7a17e389e25e4.tar.gz
gentoo-2-3210438b6ad8969e5a25b8ab84b7a17e389e25e4.tar.bz2
gentoo-2-3210438b6ad8969e5a25b8ab84b7a17e389e25e4.zip
bump and rm old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pythondialog')
-rw-r--r--dev-python/pythondialog/ChangeLog8
-rw-r--r--dev-python/pythondialog/pythondialog-2.7.ebuild29
-rw-r--r--dev-python/pythondialog/pythondialog-3.2.2.ebuild37
3 files changed, 44 insertions, 30 deletions
diff --git a/dev-python/pythondialog/ChangeLog b/dev-python/pythondialog/ChangeLog
index 96c4a347ccb0..1177ce623d32 100644
--- a/dev-python/pythondialog/ChangeLog
+++ b/dev-python/pythondialog/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pythondialog
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/ChangeLog,v 1.29 2015/02/28 13:37:45 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/ChangeLog,v 1.30 2015/04/24 08:45:32 idella4 Exp $
+
+*pythondialog-3.2.2 (24 Apr 2015)
+
+ 24 Apr 2015; Ian Delaney <idella4@gentoo.org> +pythondialog-3.2.2.ebuild,
+ -pythondialog-2.7.ebuild:
+ bump and rm old
28 Feb 2015; Agostino Sarubbo <ago@gentoo.org> pythondialog-3.2.0.ebuild:
Stable for ia64, wrt bug #532648
diff --git a/dev-python/pythondialog/pythondialog-2.7.ebuild b/dev-python/pythondialog/pythondialog-2.7.ebuild
deleted file mode 100644
index 67f36345fed6..000000000000
--- a/dev-python/pythondialog/pythondialog-2.7.ebuild
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-2.7.ebuild,v 1.12 2014/08/10 21:20:11 slyfox Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils
-
-DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
-HOMEPAGE="http://pythondialog.sourceforge.net/"
-SRC_URI="mirror://sourceforge/pythondialog/${PF}.tar.bz2"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-IUSE=""
-
-DEPEND="dev-util/dialog"
-RDEPEND="${DEPEND}"
-
-PYTHON_MODNAME="dialog.py"
-
-src_prepare() {
- distutils_src_prepare
- sed -e "/^prefix=/d" -i setup.cfg || die "sed failed"
-}
diff --git a/dev-python/pythondialog/pythondialog-3.2.2.ebuild b/dev-python/pythondialog/pythondialog-3.2.2.ebuild
new file mode 100644
index 000000000000..99ae89fc4591
--- /dev/null
+++ b/dev-python/pythondialog/pythondialog-3.2.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pythondialog/pythondialog-3.2.2.ebuild,v 1.1 2015/04/24 08:45:32 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{3_3,3_4} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python module for making simple text/console-mode user interfaces"
+HOMEPAGE="http://pythondialog.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pythondialog//${PV}/python3-${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-util/dialog
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ sed -e "/^ 'sphinx.ext.intersphinx',/d" -i doc/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+}