summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-04 20:02:38 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-04 20:02:38 +0000
commita96aa352a730d9a1684a620e77988ac8b0947dd5 (patch)
treed6c7e913ef5431cf1541691faf80049387b58b96 /dev-python/python-docs
parentRemoved python support untils numarray -> numpy is changed by upstream, #3267... (diff)
downloadgentoo-2-a96aa352a730d9a1684a620e77988ac8b0947dd5.tar.gz
gentoo-2-a96aa352a730d9a1684a620e77988ac8b0947dd5.tar.bz2
gentoo-2-a96aa352a730d9a1684a620e77988ac8b0947dd5.zip
Synchronize ebuilds.
Diffstat (limited to 'dev-python/python-docs')
-rw-r--r--dev-python/python-docs/python-docs-2.4.4-r1.ebuild27
-rw-r--r--dev-python/python-docs/python-docs-2.5.4-r1.ebuild25
2 files changed, 27 insertions, 25 deletions
diff --git a/dev-python/python-docs/python-docs-2.4.4-r1.ebuild b/dev-python/python-docs/python-docs-2.4.4-r1.ebuild
index 974efa35efea..68f82cde23eb 100644
--- a/dev-python/python-docs/python-docs-2.4.4-r1.ebuild
+++ b/dev-python/python-docs/python-docs-2.4.4-r1.ebuild
@@ -1,34 +1,38 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.4.4-r1.ebuild,v 1.5 2009/10/11 11:22:18 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.4.4-r1.ebuild,v 1.6 2010/07/04 20:02:38 arfrever Exp $
+
+EAPI="3"
DESCRIPTION="HTML documentation for Python"
HOMEPAGE="http://www.python.org/doc/"
SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2
-http://www.python.org/ftp/python/doc/${PV}/info-${PV}.tar.bz2"
+ http://www.python.org/ftp/python/doc/${PV}/info-${PV}.tar.bz2"
LICENSE="PSF-2.2"
SLOT="2.4"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-DEPEND=">=app-admin/eselect-python-20090606"
+DEPEND=">=app-admin/eselect-python-20091230"
RDEPEND="${DEPEND}"
-S=${WORKDIR}
+S="${WORKDIR}"
src_unpack() {
unpack html-${PV}.tar.bz2
mkdir "${S}/info"
cd "${S}/info"
unpack info-${PV}.tar.bz2
+}
+
+src_prepare() {
rm -f README python.dir
}
src_install() {
- [[ -z ${ED} ]] && local ED=${D}
docinto html
- cp -R "${S}/Python-Docs-${PV}/"* "${ED}/usr/share/doc/${PF}/html"
+ cp -R "${S}/Python-Docs-${PV}/"* "${ED}usr/share/doc/${PF}/html"
insinto /usr/share/info
doins "${S}/info/"*
@@ -38,13 +42,13 @@ src_install() {
}
eselect_python_update() {
- local ignored_python_slots
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local eselect_python_options
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+ eselect python update --python2 > /dev/null
- eselect python update ${ignored_python_slots}
+ eselect python update ${eselect_python_options}
}
pkg_postinst() {
@@ -52,7 +56,6 @@ pkg_postinst() {
}
pkg_postrm() {
- [[ -z ${EROOT} ]] && local EROOT=${ROOT}
eselect_python_update
if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then
diff --git a/dev-python/python-docs/python-docs-2.5.4-r1.ebuild b/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
index 80cc955fcb1d..b2354e04efd8 100644
--- a/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
+++ b/dev-python/python-docs/python-docs-2.5.4-r1.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.5.4-r1.ebuild,v 1.5 2009/10/11 11:22:18 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.5.4-r1.ebuild,v 1.6 2010/07/04 20:02:38 arfrever Exp $
+
+EAPI="3"
DESCRIPTION="HTML documentation for Python"
HOMEPAGE="http://www.python.org/doc/"
@@ -11,33 +13,31 @@ SLOT="2.5"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
IUSE=""
-DEPEND=">=app-admin/eselect-python-20090606"
+DEPEND=">=app-admin/eselect-python-20091230"
RDEPEND="${DEPEND}"
-S=${WORKDIR}
+S="${WORKDIR}"
-src_unpack() {
- unpack html-${PV}.tar.bz2
+src_prepare() {
rm -f README python.dir
}
src_install() {
- [[ -z ${ED} ]] && local ED=${D}
docinto html
- cp -R "${S}/Python-Docs-${PV}/"* "${ED}/usr/share/doc/${PF}/html"
+ cp -R "${S}/Python-Docs-${PV}/"* "${ED}usr/share/doc/${PF}/html"
echo "PYTHONDOCS_${SLOT//./_}=\"${EPREFIX}/usr/share/doc/${PF}/html\"" > "60python-docs-${SLOT}"
doenvd "60python-docs-${SLOT}"
}
eselect_python_update() {
- local ignored_python_slots
- [[ "$(eselect python show)" == "python2."* ]] && ignored_python_slots="--ignore 3.0 --ignore 3.1 --ignore 3.2"
+ local eselect_python_options
+ [[ "$(eselect python show)" == "python2."* ]] && eselect_python_options="--python2"
# Create python2 symlink.
- eselect python update --ignore 3.0 --ignore 3.1 --ignore 3.2 > /dev/null
+ eselect python update --python2 > /dev/null
- eselect python update ${ignored_python_slots}
+ eselect python update ${eselect_python_options}
}
pkg_postinst() {
@@ -45,7 +45,6 @@ pkg_postinst() {
}
pkg_postrm() {
- [[ -z ${EROOT} ]] && local EROOT=${ROOT}
eselect_python_update
if ! has_version "<dev-python/python-docs-${SLOT}_alpha" && ! has_version ">=dev-python/python-docs-${SLOT%.*}.$((${SLOT#*.}+1))_alpha"; then