summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-23 21:33:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-23 21:33:35 +0000
commitd63a50b5fad36a493525dc1392f8631ec0c56c90 (patch)
tree1773a3552ada9b4e50298ff941af30e3eb63d9fa /dev-python/pylzma
parentAdd fpc 2.2.4 (#266988) (diff)
downloadgentoo-2-d63a50b5fad36a493525dc1392f8631ec0c56c90.tar.gz
gentoo-2-d63a50b5fad36a493525dc1392f8631ec0c56c90.tar.bz2
gentoo-2-d63a50b5fad36a493525dc1392f8631ec0c56c90.zip
Initial import from sunrise overlay. Fixes #166953
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pylzma')
-rw-r--r--dev-python/pylzma/ChangeLog24
-rw-r--r--dev-python/pylzma/files/pylzma-0.3.0-fbsd.patch13
-rw-r--r--dev-python/pylzma/metadata.xml5
-rw-r--r--dev-python/pylzma/pylzma-0.3.0.ebuild41
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pylzma/ChangeLog b/dev-python/pylzma/ChangeLog
new file mode 100644
index 000000000000..f76f61574120
--- /dev/null
+++ b/dev-python/pylzma/ChangeLog
@@ -0,0 +1,24 @@
+# ChangeLog for dev-python/pylzma
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylzma/ChangeLog,v 1.1 2009/04/23 21:33:35 patrick Exp $
+
+*pylzma-0.3.0 (23 Apr 2009)
+
+ 23 Apr 2009; Patrick Lauer <patrick@gentoo.org>
+ +files/pylzma-0.3.0-fbsd.patch, +metadata.xml, +pylzma-0.3.0.ebuild:
+ Initial import from sunrise overlay. Fixes #166953
+
+ 10 Apr 2007; Ali Polatel (hawking) <polatel@gmail.com>
+ pylzma-0.3.0.ebuild, +files/pylzma-0.3.0-fbsd.patch:
+ Add freebsd patch and ~x86-fbsd keyword
+
+ 16 Feb 2007; Tiziano Müller <dev-zero@gentoo.org> pylzma-0.3.0.ebuild:
+ Corrected python dependency. Fixed tests.
+
+ 16 Feb 2007; Christian Faulhammer <opfer@gentoo.org> pylzma-0.3.0.ebuild:
+ don't depend on base packages: removed python from DEPEND
+
+ 15 Feb 2007; Ali Polatel (hawking) <polatel@nerdshack.com>
+ +pylzma-0.3.0.ebuild, +metadata.xml:
+ New ebuild for bug 166953 thanks to pigfoot
+
diff --git a/dev-python/pylzma/files/pylzma-0.3.0-fbsd.patch b/dev-python/pylzma/files/pylzma-0.3.0-fbsd.patch
new file mode 100644
index 000000000000..e6b32643a65e
--- /dev/null
+++ b/dev-python/pylzma/files/pylzma-0.3.0-fbsd.patch
@@ -0,0 +1,13 @@
+--- 7zip/LzmaCompatDecode.h.orig Thu Dec 28 06:27:50 2006
++++ 7zip/LzmaCompatDecode.h Thu Dec 28 06:27:56 2006
+@@ -39,10 +39,6 @@
+ # define LZMACALL
+ #endif
+
+-#ifndef malloc
+-#include <malloc.h>
+-#endif
+-
+ #ifndef UInt32
+ #ifdef _LZMA_UINT32_IS_ULONG
+ #define UInt32 unsigned long
diff --git a/dev-python/pylzma/metadata.xml b/dev-python/pylzma/metadata.xml
new file mode 100644
index 000000000000..7e3286984488
--- /dev/null
+++ b/dev-python/pylzma/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>maintainer-wanted</herd>
+</pkgmetadata>
diff --git a/dev-python/pylzma/pylzma-0.3.0.ebuild b/dev-python/pylzma/pylzma-0.3.0.ebuild
new file mode 100644
index 000000000000..b1096d69d3d2
--- /dev/null
+++ b/dev-python/pylzma/pylzma-0.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pylzma/pylzma-0.3.0.ebuild,v 1.1 2009/04/23 21:33:35 patrick Exp $
+
+NEED_PYTHON=2.4
+
+inherit distutils eutils
+
+DESCRIPTION="Python bindings for the LZMA compression library."
+HOMEPAGE="http://www.joachim-bauch.de/projects/python/pylzma/"
+SRC_URI="http://www.joachim-bauch.de/projects/python/${PN}/releases/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+# fails horribly on amd64 at the moment.
+KEYWORDS="-amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+DOCS="doc/usage.txt readme.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ use x86-fbsd && epatch "${FILESDIR}/${P}-fbsd.patch"
+}
+
+src_test() {
+ einfo "Testing 7zfiles"
+ export PYTHONPATH="$(ls -d build/lib.*)"
+ "${python}" tests/test_7zfiles.py || die "7zfiles test failed"
+ einfo "Testing compatibility"
+ "${python}" tests/test_compatibility.py || die "Compatibility test failed"
+ einfo "Testing pylzma"
+ "${python}" tests/test_pylzma.py || die "pylzma test failed"
+ einfo "Testing usage"
+ "${python}" tests/test_usage.py || die "usage test failed"
+}