summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-27 08:55:34 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-27 08:55:34 +0000
commit03c217f620a386f4d368f1f1f8af7cd17f368642 (patch)
tree49b69b447031e1d999825ccbea8ee8a11dabee31 /dev-python/oslotest
parentfix to doc install (diff)
downloadgentoo-2-03c217f620a386f4d368f1f1f8af7cd17f368642.tar.gz
gentoo-2-03c217f620a386f4d368f1f1f8af7cd17f368642.tar.bz2
gentoo-2-03c217f620a386f4d368f1f1f8af7cd17f368642.zip
firther fix to doc install
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/oslotest')
-rw-r--r--dev-python/oslotest/oslotest-1.1.0.ebuild14
1 files changed, 9 insertions, 5 deletions
diff --git a/dev-python/oslotest/oslotest-1.1.0.ebuild b/dev-python/oslotest/oslotest-1.1.0.ebuild
index be611f617512..6e1e893a6b4b 100644
--- a/dev-python/oslotest/oslotest-1.1.0.ebuild
+++ b/dev-python/oslotest/oslotest-1.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/oslotest-1.1.0.ebuild,v 1.3 2014/09/27 08:40:28 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslotest/oslotest-1.1.0.ebuild,v 1.4 2014/09/27 08:55:34 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3} )
@@ -37,8 +37,6 @@ RDEPEND=">=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
>=dev-python/mock-1.0[${PYTHON_USEDEP}]
>=dev-python/mox3-0.7.0[${PYTHON_USEDEP}]"
-# This time half the doc files are missing; Do you want them?
-
python_compile_all() {
use doc && esetup.py build_sphinx
}
@@ -48,8 +46,14 @@ python_test() {
}
python_install_all() {
- use doc && HTML_DOCS=( doc/build/html/. )
- doman doc/build/man/oslotest.1
+ if use doc; then
+ local HTML_DOCS=( doc/build/html/. )
+ doman doc/build/man/oslotest.1
+ fi
distutils-r1_python_install_all
}
+
+pkg_postinst() {
+ elog; elog "to acquire the man page, re-emerge with USE=doc"
+}