summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexys Jacob <ultrabug@gentoo.org>2015-05-23 18:16:39 +0000
committerAlexys Jacob <ultrabug@gentoo.org>2015-05-23 18:16:39 +0000
commit516a2ae506fe46f2d40067de6b1a60460822fe47 (patch)
tree81beba34e5e93512e1d4f9c7923298cb744e9852 /dev-python/gevent
parentia64 stable wrt bug #548756 (diff)
downloadgentoo-2-516a2ae506fe46f2d40067de6b1a60460822fe47.tar.gz
gentoo-2-516a2ae506fe46f2d40067de6b1a60460822fe47.tar.bz2
gentoo-2-516a2ae506fe46f2d40067de6b1a60460822fe47.zip
version bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B658FA13)
Diffstat (limited to 'dev-python/gevent')
-rw-r--r--dev-python/gevent/ChangeLog7
-rw-r--r--dev-python/gevent/gevent-1.0.2.ebuild66
2 files changed, 72 insertions, 1 deletions
diff --git a/dev-python/gevent/ChangeLog b/dev-python/gevent/ChangeLog
index af5031c797de..1507896d9dc7 100644
--- a/dev-python/gevent/ChangeLog
+++ b/dev-python/gevent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/gevent
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/ChangeLog,v 1.32 2015/04/08 08:05:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/ChangeLog,v 1.33 2015/05/23 18:16:39 ultrabug Exp $
+
+*gevent-1.0.2 (23 May 2015)
+
+ 23 May 2015; Ultrabug <ultrabug@gentoo.org> +gevent-1.0.2.ebuild:
+ version bump
08 Apr 2015; Michał Górny <mgorny@gentoo.org> gevent-1.0.1.ebuild,
gevent-1.0.ebuild:
diff --git a/dev-python/gevent/gevent-1.0.2.ebuild b/dev-python/gevent/gevent-1.0.2.ebuild
new file mode 100644
index 000000000000..11f77d0a40de
--- /dev/null
+++ b/dev-python/gevent/gevent-1.0.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/gevent/gevent-1.0.2.ebuild,v 1.1 2015/05/23 18:16:39 ultrabug Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="ssl"
+
+inherit distutils-r1 flag-o-matic
+
+MY_PV=${PV/_/}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="Python networking library that uses greenlet to provide synchronous API"
+HOMEPAGE="http://gevent.org/ http://pypi.python.org/pypi/gevent/"
+SRC_URI="https://github.com/surfly/${PN}/releases/download/v${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="dev-libs/libev
+ net-dns/c-ares
+ >=dev-python/greenlet-0.3.2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+
+# Tests take long and fail terribly a few times.
+# It also seems that they require network access.
+RESTRICT="test"
+
+S=${WORKDIR}/${MY_P}
+
+python_prepare_all() {
+ rm -r {libev,c-ares} || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ cd greentest || die
+ "${PYTHON}" testrunner.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ dodoc changelog.rst
+
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}