summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-30 16:34:02 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-30 16:34:02 +0000
commit781a36a042f36295104d01b66a878626f1c1e3f4 (patch)
treea5963722ffe29967b586faf6904a6200acb8b82f /dev-ml/xml-light
parentVersion bump; remove one old. (diff)
downloadgentoo-2-781a36a042f36295104d01b66a878626f1c1e3f4.tar.gz
gentoo-2-781a36a042f36295104d01b66a878626f1c1e3f4.tar.bz2
gentoo-2-781a36a042f36295104d01b66a878626f1c1e3f4.zip
build & install native binaries if wanted, bug #520100 by José Romildo Malaquias
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/xml-light')
-rw-r--r--dev-ml/xml-light/ChangeLog8
-rw-r--r--dev-ml/xml-light/xml-light-2.2-r3.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-ml/xml-light/ChangeLog b/dev-ml/xml-light/ChangeLog
index 3c412d1594e8..2658644b1ae7 100644
--- a/dev-ml/xml-light/ChangeLog
+++ b/dev-ml/xml-light/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/xml-light
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/xml-light/ChangeLog,v 1.10 2014/03/03 23:38:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/xml-light/ChangeLog,v 1.11 2014/10/30 16:34:02 aballier Exp $
+
+*xml-light-2.2-r3 (30 Oct 2014)
+
+ 30 Oct 2014; Alexis Ballier <aballier@gentoo.org> +xml-light-2.2-r3.ebuild:
+ build & install native binaries if wanted, bug #520100 by José Romildo
+ Malaquias
03 Mar 2014; Pacho Ramos <pacho@gentoo.org> xml-light-2.2-r2.ebuild:
amd64 stable, bug #492064
diff --git a/dev-ml/xml-light/xml-light-2.2-r3.ebuild b/dev-ml/xml-light/xml-light-2.2-r3.ebuild
new file mode 100644
index 000000000000..440a730a38c3
--- /dev/null
+++ b/dev-ml/xml-light/xml-light-2.2-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/xml-light/xml-light-2.2-r3.ebuild,v 1.1 2014/10/30 16:34:02 aballier Exp $
+
+EAPI=5
+
+inherit eutils multilib
+
+DESCRIPTION="Minimal Xml parser and printer for OCaml"
+HOMEPAGE="http://tech.motion-twin.com/xmllight.html"
+SRC_URI="http://tech.motion-twin.com/zip/${P}.zip"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +ocamlopt"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt?]"
+DEPEND="app-arch/unzip
+ ${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ EPATCH_FORCE=yes EPATCH_SUFFIX=dpatch EPATCH_SOURCE="${FILESDIR}" \
+ epatch
+}
+
+src_compile() {
+ emake -j1
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+ if use doc;then
+ emake doc
+ fi
+}
+
+src_test() {
+ # There are no tests...
+ :
+}
+
+src_install() {
+ dodir /usr/$(get_libdir)/ocaml/${PN}
+ emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml/${PN} install
+ cat > "${D}"/usr/$(get_libdir)/ocaml/${PN}/META << EOF
+name="${PN}"
+version="${PV}"
+description="${DESCRIPTION}"
+requires=""
+archive(byte)="xml-light.cma"
+EOF
+ if use ocamlopt; then
+ emake INSTALLDIR="${D}"/usr/$(get_libdir)/ocaml/${PN} installopt
+ echo 'archive(native)="xml-light.cmxa"' >> "${D}"/usr/$(get_libdir)/ocaml/${PN}/META
+ fi
+ dodoc README
+ if use doc; then
+ emake doc
+ dohtml doc/*
+ fi
+}