summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2011-12-07 13:20:42 +0000
committerAlexis Ballier <aballier@gentoo.org>2011-12-07 13:20:42 +0000
commit0983912e2f78127cdd7971ffbb5a04afe2deeec8 (patch)
tree533f9fc3feb35fefad4ce516463d4d255e602aae /dev-ml/pcre-ocaml
parentremove old (diff)
downloadgentoo-2-0983912e2f78127cdd7971ffbb5a04afe2deeec8.tar.gz
gentoo-2-0983912e2f78127cdd7971ffbb5a04afe2deeec8.tar.bz2
gentoo-2-0983912e2f78127cdd7971ffbb5a04afe2deeec8.zip
version bump
(Portage version: 2.2.0_alpha79/cvs/Linux x86_64)
Diffstat (limited to 'dev-ml/pcre-ocaml')
-rw-r--r--dev-ml/pcre-ocaml/ChangeLog7
-rw-r--r--dev-ml/pcre-ocaml/pcre-ocaml-6.2.3.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/dev-ml/pcre-ocaml/ChangeLog b/dev-ml/pcre-ocaml/ChangeLog
index 2c3b9da27012..cd0efc249cc9 100644
--- a/dev-ml/pcre-ocaml/ChangeLog
+++ b/dev-ml/pcre-ocaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-ml/pcre-ocaml
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.39 2011/07/24 19:50:42 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/ChangeLog,v 1.40 2011/12/07 13:20:42 aballier Exp $
+
+*pcre-ocaml-6.2.3 (07 Dec 2011)
+
+ 07 Dec 2011; Alexis Ballier <aballier@gentoo.org> +pcre-ocaml-6.2.3.ebuild:
+ version bump
24 Jul 2011; Thomas Kahle <tomka@gentoo.org> pcre-ocaml-6.2.2.ebuild:
x86 stable per bug 374971
diff --git a/dev-ml/pcre-ocaml/pcre-ocaml-6.2.3.ebuild b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.3.ebuild
new file mode 100644
index 000000000000..ba1f0ef252a3
--- /dev/null
+++ b/dev-ml/pcre-ocaml/pcre-ocaml-6.2.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/pcre-ocaml/pcre-ocaml-6.2.3.ebuild,v 1.1 2011/12/07 13:20:42 aballier Exp $
+
+EAPI="2"
+
+inherit findlib eutils
+
+DESCRIPTION="Perl Compatibility Regular Expressions for O'Caml"
+HOMEPAGE="http://www.ocaml.info/home/ocaml_sources.html"
+SRC_URI="http://www.ocaml.info/ocaml_sources/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+
+RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt?]
+ >=dev-libs/libpcre-4.5"
+DEPEND="${RDEPEND}"
+SLOT="0"
+IUSE="examples +ocamlopt"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-6.0.1-linkopts.patch"
+}
+
+src_compile() {
+ cd "${S}/lib"
+ emake byte-code-library || die "Failed to build byte code library"
+ if use ocamlopt; then
+ emake native-code-library || die "Failed to build native code library"
+ fi
+}
+
+src_install () {
+ export OCAMLFIND_INSTFLAGS="-optional"
+ findlib_src_install
+
+ # install documentation
+ dodoc README.txt Changelog
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}