summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-03-10 10:54:56 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-03-10 10:54:56 +0000
commitac5f4fd752bc13daa9c2fa4c7fd2a42d310e1a97 (patch)
tree92f318c29be66bb0cb25b17876179e25f4731da4 /dev-ml/odns
parentdefine subslot for real this time (diff)
downloadgentoo-2-ac5f4fd752bc13daa9c2fa4c7fd2a42d310e1a97.tar.gz
gentoo-2-ac5f4fd752bc13daa9c2fa4c7fd2a42d310e1a97.tar.bz2
gentoo-2-ac5f4fd752bc13daa9c2fa4c7fd2a42d310e1a97.zip
eapi5: define subslot, slot dep on ocaml, remove useless || die
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'dev-ml/odns')
-rw-r--r--dev-ml/odns/ChangeLog7
-rw-r--r--dev-ml/odns/odns-0.3.ebuild14
2 files changed, 12 insertions, 9 deletions
diff --git a/dev-ml/odns/ChangeLog b/dev-ml/odns/ChangeLog
index 166cca96aac2..33fe1cc470a6 100644
--- a/dev-ml/odns/ChangeLog
+++ b/dev-ml/odns/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-ml/odns
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/ChangeLog,v 1.5 2012/08/22 14:26:16 aballier Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/ChangeLog,v 1.6 2013/03/10 10:54:56 aballier Exp $
+
+ 10 Mar 2013; Alexis Ballier <aballier@gentoo.org> odns-0.3.ebuild:
+ eapi5: define subslot, slot dep on ocaml, remove useless || die
22 Aug 2012; Alexis Ballier <aballier@gentoo.org> odns-0.3.ebuild:
set empty CLIBS, fixing bug #422683
diff --git a/dev-ml/odns/odns-0.3.ebuild b/dev-ml/odns/odns-0.3.ebuild
index 85465111fa13..70fbad553347 100644
--- a/dev-ml/odns/odns-0.3.ebuild
+++ b/dev-ml/odns/odns-0.3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/odns-0.3.ebuild,v 1.3 2012/08/22 14:26:16 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/odns/odns-0.3.ebuild,v 1.4 2013/03/10 10:54:56 aballier Exp $
-EAPI=3
+EAPI=5
inherit findlib eutils
@@ -11,11 +11,11 @@ HOMEPAGE="http://odns.tuxfamily.org/"
SRC_URI="http://download.tuxfamily.org/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT="0"
+SLOT="0/${PV}"
KEYWORDS="~amd64"
IUSE=""
-RDEPEND=">=dev-lang/ocaml-3.10.2[ocamlopt]"
+RDEPEND=">=dev-lang/ocaml-3.10.2:=[ocamlopt]"
DEPEND="${RDEPEND}"
CLIBS="" # Workaround for bug #422683
@@ -27,6 +27,6 @@ src_prepare() {
src_install() {
findlib_src_preinst
- PREFIX="${D}/usr" emake install || die
- dodoc AUTHORS README || die
+ PREFIX="${D}/usr" emake install
+ dodoc AUTHORS README
}