summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-04-08 22:13:57 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-04-08 22:13:57 +0000
commit27acfe50d7c539cabd5816851efee09a9c1bcd93 (patch)
tree48a021f11817c121e5f48a203d804ca0fff8da36 /dev-ml/ocaml-sqlite3
parentremove old (diff)
downloadgentoo-2-27acfe50d7c539cabd5816851efee09a9c1bcd93.tar.gz
gentoo-2-27acfe50d7c539cabd5816851efee09a9c1bcd93.tar.bz2
gentoo-2-27acfe50d7c539cabd5816851efee09a9c1bcd93.zip
version bump
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-ml/ocaml-sqlite3')
-rw-r--r--dev-ml/ocaml-sqlite3/ChangeLog8
-rw-r--r--dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild57
2 files changed, 64 insertions, 1 deletions
diff --git a/dev-ml/ocaml-sqlite3/ChangeLog b/dev-ml/ocaml-sqlite3/ChangeLog
index cc4afc2bbcb6..de7e863af620 100644
--- a/dev-ml/ocaml-sqlite3/ChangeLog
+++ b/dev-ml/ocaml-sqlite3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-ml/ocaml-sqlite3
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.4 2008/04/08 22:02:55 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ChangeLog,v 1.5 2008/04/08 22:13:57 aballier Exp $
+
+*ocaml-sqlite3-1.0.2 (08 Apr 2008)
+
+ 08 Apr 2008; Alexis Ballier <aballier@gentoo.org>
+ +ocaml-sqlite3-1.0.2.ebuild:
+ version bump
08 Apr 2008; Alexis Ballier <aballier@gentoo.org>
-ocaml-sqlite3-0.22.0.ebuild:
diff --git a/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild
new file mode 100644
index 000000000000..782ad1005c87
--- /dev/null
+++ b/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-ml/ocaml-sqlite3/ocaml-sqlite3-1.0.2.ebuild,v 1.1 2008/04/08 22:13:57 aballier Exp $
+
+inherit findlib eutils
+
+EAPI="1"
+
+IUSE="doc +ocamlopt"
+
+DESCRIPTION="A package for ocaml that provides access to SQLite databases."
+SRC_URI="http://ocaml.info/ocaml_sources/${P}.tar.bz2"
+HOMEPAGE="http://ocaml.info/home/ocaml_sources.html#ocaml-sqlite3"
+
+DEPEND=">=dev-lang/ocaml-3.09
+ >=dev-db/sqlite-3.3.3"
+
+RDEPEND="${DEPEND}"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+pkg_setup() {
+ if use ocamlopt && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build ${PN} with native code support from ocaml"
+ eerror "You first need to have a native code ocaml compiler."
+ eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
+ die "Please install ocaml with ocamlopt useflag"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-0.22.0-destdir.patch"
+ epatch "${FILESDIR}/${PN}-0.23.0-noocamlopt.patch"
+}
+
+src_compile() {
+ econf
+ emake -j1 bytecode || die "make bytecode failed"
+ if use ocamlopt; then
+ emake -j1 opt || die "make opt failed"
+ fi
+ if use doc; then
+ emake -j1 docs || die "make doc failed"
+ fi
+}
+
+src_install() {
+ findlib_src_preinst
+ export OCAMLPATH="${OCAMLFIND_DESTDIR}"
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc CHANGES README TODO
+ use doc && dohtml doc/*
+}