summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2015-05-29 02:08:27 +0000
committerPatrick Lauer <patrick@gentoo.org>2015-05-29 02:08:27 +0000
commitead2ceab3f1771af765e2be9eec9f2574c7e809b (patch)
tree84f20c602c96a9479e2437da11b22124009adbb1 /dev-libs/libmacaroons
parentBump (diff)
downloadgentoo-2-ead2ceab3f1771af765e2be9eec9f2574c7e809b.tar.gz
gentoo-2-ead2ceab3f1771af765e2be9eec9f2574c7e809b.tar.bz2
gentoo-2-ead2ceab3f1771af765e2be9eec9f2574c7e809b.zip
Bump
(Portage version: 2.2.20/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-libs/libmacaroons')
-rw-r--r--dev-libs/libmacaroons/ChangeLog7
-rw-r--r--dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild41
2 files changed, 47 insertions, 1 deletions
diff --git a/dev-libs/libmacaroons/ChangeLog b/dev-libs/libmacaroons/ChangeLog
index e71077c52643..187fc1907ff6 100644
--- a/dev-libs/libmacaroons/ChangeLog
+++ b/dev-libs/libmacaroons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-libs/libmacaroons
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/ChangeLog,v 1.4 2015/01/15 05:47:45 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/ChangeLog,v 1.5 2015/05/29 02:08:27 patrick Exp $
+
+*libmacaroons-0.3.0 (29 May 2015)
+
+ 29 May 2015; Patrick Lauer <patrick@gentoo.org> +libmacaroons-0.3.0.ebuild:
+ Bump
*libmacaroons-0.2.0-r1 (15 Jan 2015)
diff --git a/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild b/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
new file mode 100644
index 000000000000..d910527045c1
--- /dev/null
+++ b/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libmacaroons/libmacaroons-0.3.0.ebuild,v 1.1 2015/05/29 02:08:27 patrick Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit eutils python-single-r1
+
+# Tests can't function after 2014-12-31 ...
+RESTRICT="test"
+
+DESCRIPTION="Hyperdex macaroons support library"
+
+HOMEPAGE="http://hyperdex.org"
+SRC_URI="http://hyperdex.org/src/${P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="test +python"
+
+RDEPEND="dev-libs/libsodium
+ dev-libs/json-c"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+REQUIRED_USE="test? ( python )"
+
+src_prepare() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_configure() {
+ econf $(use_enable python python-bindings)
+}
+
+src_test() {
+ emake -j1 check || die
+}