summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2010-01-21 11:27:31 +0000
committerGeorge Shapovalov <george@gentoo.org>2010-01-21 11:27:31 +0000
commit13594bfe2788d1310b52618e8d87fdcd61fa926c (patch)
tree5605097e6a941ec97fe5cb5f69336e744961bf1f /dev-lang
parentWhile JRuby does not work yet, predispose the ebuild to support it; also add ... (diff)
downloadgentoo-2-13594bfe2788d1310b52618e8d87fdcd61fa926c.tar.gz
gentoo-2-13594bfe2788d1310b52618e8d87fdcd61fa926c.tar.bz2
gentoo-2-13594bfe2788d1310b52618e8d87fdcd61fa926c.zip
new revision, uses new gcc-4.3 based bootstrap
(Portage version: 2.1.7.16/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/gnat-gcc/ChangeLog10
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.3.3-r1.ebuild63
2 files changed, 71 insertions, 2 deletions
diff --git a/dev-lang/gnat-gcc/ChangeLog b/dev-lang/gnat-gcc/ChangeLog
index 62abe790779d..f1bdefd83c86 100644
--- a/dev-lang/gnat-gcc/ChangeLog
+++ b/dev-lang/gnat-gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-lang/gnat-gcc
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.31 2009/03/28 15:47:25 nixnut Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/ChangeLog,v 1.32 2010/01/21 11:27:31 george Exp $
+
+*gnat-gcc-4.3.3-r1 (21 Jan 2010)
+
+ 21 Jan 2010; George Shapovalov <george@gentoo.org>
+ +gnat-gcc-4.3.3-r1.ebuild:
+ new revision, uses new bootstrap, based on gcc-4.3
28 Mar 2009; nixnut <nixnut@gentoo.org> gnat-gcc-4.3.2.ebuild:
ppc stable #257800
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.3.3-r1.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.3.3-r1.ebuild
new file mode 100644
index 000000000000..fb0cd4af916b
--- /dev/null
+++ b/dev-lang/gnat-gcc/gnat-gcc-4.3.3-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.3.3-r1.ebuild,v 1.1 2010/01/21 11:27:31 george Exp $
+
+# Need to let configure know where to find stddef.h
+#EXTRA_CONFGCC="${WORKDIR}/usr/lib/include/"
+
+inherit gnatbuild
+
+DESCRIPTION="GNAT Ada Compiler - gcc version"
+HOMEPAGE="http://gcc.gnu.org/"
+LICENSE="GMGPL"
+
+IUSE=""
+
+# using new bootstrap
+BOOT_SLOT="4.3"
+
+# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
+# so the URI's are static.
+SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
+ ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
+ amd64? ( http://dev.gentoo.org/~george/src/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )"
+# ppc? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-ppc.tar.bz2 )
+# x86? ( mirror://gentoo/gnatboot-${BOOT_SLOT}-i386.tar.bz2 )
+
+KEYWORDS="~amd64"
+
+# starting with 4.3.0 gnat needs these libs
+DEPEND=">=dev-libs/mpfr-2.3.1
+ >=dev-libs/gmp-4.2.2"
+
+#QA_EXECSTACK="${BINPATH:1}/gnatls ${BINPATH:1}/gnatbind ${BINPATH:1}/gnatmake
+# ${LIBEXECPATH:1}/gnat1 ${LIBPATH:1}/adalib/libgnat-${SLOT}.so"
+
+src_unpack() {
+ gnatbuild_src_unpack
+
+ #fixup some hardwired flags
+ cd "${S}"/gcc/ada
+
+ # universal gcc -> gnatgcc substitution occasionally produces lines too long
+ # and then build halts on the style check.
+ #
+ # The sed in makegpr.adb is actually not for the line length but rather to
+ # "undo" the fixing, Last3 is matching just that - the last three characters
+ # of the compiler name.
+ sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
+ sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
+ die "reversing [gnat]gcc substitution in comments failed"
+
+ # looks like wrapper has problems with all the quotation
+ sed -i -e "/-DREVISION/d" -e "/-DDEVPHASE/d" \
+ -e "s: -DDATESTAMP=\$(DATESTAMP_s)::" "${S}"/gcc/Makefile.in
+ sed -i -e "s: DATESTAMP DEVPHASE REVISION::" \
+ -e "s:PKGVERSION:\"\":" "${S}"/gcc/version.c
+}
+
+src_compile() {
+ # looks like gnatlib_and_tools and gnatlib_shared have become part of
+ # bootstrap
+ gnatbuild_src_compile configure make-tools bootstrap
+}