summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-06-03 19:46:10 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-06-03 19:46:10 +0000
commitc534b535fcebd2610dcb5bb7a85c6772ad7cc52e (patch)
treea99abf85b02428ba95be832d09a2de030be788d0 /dev-lang/yasm
parentDelete older ebuild. (diff)
downloadgentoo-2-c534b535fcebd2610dcb5bb7a85c6772ad7cc52e.tar.gz
gentoo-2-c534b535fcebd2610dcb5bb7a85c6772ad7cc52e.tar.bz2
gentoo-2-c534b535fcebd2610dcb5bb7a85c6772ad7cc52e.zip
Version bump (bug #322655)
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-lang/yasm')
-rw-r--r--dev-lang/yasm/ChangeLog7
-rw-r--r--dev-lang/yasm/yasm-1.0.1.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-lang/yasm/ChangeLog b/dev-lang/yasm/ChangeLog
index 8ae017d0c9e2..591fe2fc6542 100644
--- a/dev-lang/yasm/ChangeLog
+++ b/dev-lang/yasm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/yasm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.37 2010/04/12 19:50:02 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/ChangeLog,v 1.38 2010/06/03 19:46:10 polynomial-c Exp $
+
+*yasm-1.0.1 (03 Jun 2010)
+
+ 03 Jun 2010; Lars Wendler <polynomial-c@gentoo.org> +yasm-1.0.1.ebuild:
+ Version bump (bug #322655).
12 Apr 2010; Samuli Suominen <ssuominen@gentoo.org> yasm-1.0.0.ebuild:
LICENSE is all of Artistic, BSD, GPL-2 and LGPL-2.
diff --git a/dev-lang/yasm/yasm-1.0.1.ebuild b/dev-lang/yasm/yasm-1.0.1.ebuild
new file mode 100644
index 000000000000..0a03e5871989
--- /dev/null
+++ b/dev-lang/yasm/yasm-1.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/yasm/yasm-1.0.1.ebuild,v 1.1 2010/06/03 19:46:10 polynomial-c Exp $
+
+EAPI=2
+
+DESCRIPTION="Assembler that supports amd64"
+HOMEPAGE="http://www.tortall.net/projects/yasm/"
+SRC_URI="http://www.tortall.net/projects/yasm/releases/${P}.tar.gz"
+
+LICENSE="Artistic BSD GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="nls? ( sys-devel/gettext )"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}