summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-02-15 19:57:08 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-02-15 19:57:08 +0000
commitc367353ac979528ae6a14ae1b7087d9977026152 (patch)
treed110d21492d39e41962978228889b73a61b13ed2 /dev-java/batik
parentMarked stable on sparc to fix bug #40631. (Manifest recommit) (diff)
downloadgentoo-2-c367353ac979528ae6a14ae1b7087d9977026152.tar.gz
gentoo-2-c367353ac979528ae6a14ae1b7087d9977026152.tar.bz2
gentoo-2-c367353ac979528ae6a14ae1b7087d9977026152.zip
Version Bump + Misc Fixes + Jikes
Diffstat (limited to 'dev-java/batik')
-rw-r--r--dev-java/batik/ChangeLog9
-rw-r--r--dev-java/batik/Manifest6
-rw-r--r--dev-java/batik/batik-1.5.ebuild37
-rw-r--r--dev-java/batik/files/digest-batik-1.51
4 files changed, 49 insertions, 4 deletions
diff --git a/dev-java/batik/ChangeLog b/dev-java/batik/ChangeLog
index 0f18b265749e..fc1b939d3f8a 100644
--- a/dev-java/batik/ChangeLog
+++ b/dev-java/batik/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/batik
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/ChangeLog,v 1.2 2003/04/27 18:38:46 tberman Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/ChangeLog,v 1.3 2004/02/15 19:57:08 zx Exp $
+
+*batik-1.5 (15 Feb 2004)
+
+ 15 Feb 2004; Chris Aniszczyk <zx@gentoo.org> batik-1.5.ebuild:
+ Version Bump + Misc Fixes. Bug #30308
*batik-1.1.1 (27 Apr 2003)
diff --git a/dev-java/batik/Manifest b/dev-java/batik/Manifest
index a75e1dbfe6fc..79bc9a90a18e 100644
--- a/dev-java/batik/Manifest
+++ b/dev-java/batik/Manifest
@@ -1,4 +1,6 @@
-MD5 c71c9d5feba821198bb212d1f3c923f1 ChangeLog 468
-MD5 990d133a384ca100799ed1b1f4b8142c batik-1.1.1.ebuild 922
+MD5 ffcccdeaa307036a7f6451babe2a3ff4 batik-1.1.1.ebuild 921
+MD5 6e02139ec9b57644c76d8e451e4cb1c6 ChangeLog 467
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 7b21d5a8c40c4b1117f1e3f4a33991ac batik-1.5.ebuild 826
+MD5 479ed0922a69b318b40b485614a6af16 files/digest-batik-1.5 63
MD5 685865b8912d441af280a79904e061c8 files/digest-batik-1.1.1 65
diff --git a/dev-java/batik/batik-1.5.ebuild b/dev-java/batik/batik-1.5.ebuild
new file mode 100644
index 000000000000..a4c2a13c0d34
--- /dev/null
+++ b/dev-java/batik/batik-1.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/batik/batik-1.5.ebuild,v 1.1 2004/02/15 19:57:08 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="Batik is a Java(tm) technology based toolkit for applications or applets that want to use images in the Scalable Vector Graphics (SVG) format for various purposes, such as viewing, generation or manipulation."
+SRC_URI="http://xml.apache.org/batik/dist/${PN}-src-${PV}.zip"
+HOMEPAGE="http://xml.apache.org/batik/"
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ dev-java/ant
+ jikes? ( dev-java/jikes )"
+
+REDEPND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ~sparc ~ppc"
+
+S=${WORKDIR}/xml-batik
+
+src_unpack() {
+ jar xvf ${DISTDIR}/${PN}-src-${PV}.zip
+}
+
+src_compile() {
+ local antflags="jars"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install () {
+ java-pkg_dojar ${P}/batik*.jar ${P}/lib/*.jar
+
+ dodoc README LICENSE
+ use doc && dohtml -r ${P}/docs/
+}
diff --git a/dev-java/batik/files/digest-batik-1.5 b/dev-java/batik/files/digest-batik-1.5
new file mode 100644
index 000000000000..75f845fbef96
--- /dev/null
+++ b/dev-java/batik/files/digest-batik-1.5
@@ -0,0 +1 @@
+MD5 94d3e981014a5ed6f8c0e3fd80be3033 batik-src-1.5.zip 9234151