summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2009-04-23 16:09:35 +0000
committerPatrick Lauer <patrick@gentoo.org>2009-04-23 16:09:35 +0000
commitd0e8ae01e38848f84e0e3ddb3a01ec60f2929aa8 (patch)
tree9c3246a5037fe3468efb0f9d1fb3f2900c488d3f /dev-db/pygresql
parentUnmasking qt-creator (diff)
downloadgentoo-2-d0e8ae01e38848f84e0e3ddb3a01ec60f2929aa8.tar.gz
gentoo-2-d0e8ae01e38848f84e0e3ddb3a01ec60f2929aa8.tar.bz2
gentoo-2-d0e8ae01e38848f84e0e3ddb3a01ec60f2929aa8.zip
Bump to 4.0. Fixes #256329
(Portage version: 2.2_rc31/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/pygresql')
-rw-r--r--dev-db/pygresql/ChangeLog9
-rw-r--r--dev-db/pygresql/pygresql-4.0.ebuild33
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-db/pygresql/ChangeLog b/dev-db/pygresql/ChangeLog
index 04f8be5f3bc1..ebd7d8de88ac 100644
--- a/dev-db/pygresql/ChangeLog
+++ b/dev-db/pygresql/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-db/pygresql
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.45 2008/05/19 19:14:12 dev-zero Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/ChangeLog,v 1.46 2009/04/23 16:09:35 patrick Exp $
+
+*pygresql-4.0 (23 Apr 2009)
+
+ 23 Apr 2009; Patrick Lauer <patrick@gentoo.org> +pygresql-4.0.ebuild:
+ Bump to 4.0. Fixes #256329
19 May 2008; Tiziano Müller <dev-zero@gentoo.org> pygresql-3.5.ebuild,
pygresql-3.6.2.ebuild, pygresql-3.6.2-r1.ebuild, pygresql-3.8.1.ebuild:
diff --git a/dev-db/pygresql/pygresql-4.0.ebuild b/dev-db/pygresql/pygresql-4.0.ebuild
new file mode 100644
index 000000000000..d65f374b5a1e
--- /dev/null
+++ b/dev-db/pygresql/pygresql-4.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/pygresql/pygresql-4.0.ebuild,v 1.1 2009/04/23 16:09:35 patrick Exp $
+
+inherit eutils distutils
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+
+MY_P="PyGreSQL-${PV}"
+
+DESCRIPTION="A Python interface for the PostgreSQL database."
+SRC_URI="ftp://ftp.pygresql.org/pub/distrib/${MY_P}.tgz"
+HOMEPAGE="http://www.pygresql.org/"
+LICENSE="as-is"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=virtual/postgresql-base-7.4"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_install() {
+ distutils_src_install
+
+ dodoc docs/*.txt
+
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/tutorial
+ doins tutorial/*
+ dohtml docs/*.{html,css}
+ fi
+}