summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-14 13:30:26 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-07-14 13:30:26 +0000
commit5d89720fb901b705de87024e3d234c2602135412 (patch)
treedf6bb48fb1de4691561240b2fe9265aa1d8ceb3c /dev-db/metakit
parentstable x86, bug 325633 (diff)
downloadgentoo-2-5d89720fb901b705de87024e3d234c2602135412.tar.gz
gentoo-2-5d89720fb901b705de87024e3d234c2602135412.tar.bz2
gentoo-2-5d89720fb901b705de87024e3d234c2602135412.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-db/metakit')
-rw-r--r--dev-db/metakit/ChangeLog6
-rw-r--r--dev-db/metakit/metakit-2.4.9.7.ebuild75
2 files changed, 59 insertions, 22 deletions
diff --git a/dev-db/metakit/ChangeLog b/dev-db/metakit/ChangeLog
index 695ef4f3ead3..51f8e3b33cdb 100644
--- a/dev-db/metakit/ChangeLog
+++ b/dev-db/metakit/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/metakit
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/ChangeLog,v 1.47 2010/06/21 19:27:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/ChangeLog,v 1.48 2010/07/14 13:30:26 arfrever Exp $
+
+ 14 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ metakit-2.4.9.7.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
21 Jun 2010; Jeroen Roovers <jer@gentoo.org> metakit-2.4.9.6.ebuild,
metakit-2.4.9.7.ebuild:
diff --git a/dev-db/metakit/metakit-2.4.9.7.ebuild b/dev-db/metakit/metakit-2.4.9.7.ebuild
index 50707577eae9..83cc982a574b 100644
--- a/dev-db/metakit/metakit-2.4.9.7.ebuild
+++ b/dev-db/metakit/metakit-2.4.9.7.ebuild
@@ -1,6 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.7.ebuild,v 1.5 2010/06/21 19:27:23 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/metakit/metakit-2.4.9.7.ebuild,v 1.6 2010/07/14 13:30:26 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit eutils multilib python
@@ -13,28 +18,21 @@ SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~s390 ~sparc ~x86"
IUSE="python static tcl"
-DEPEND=">=sys-apps/sed-4
- python? ( >=dev-lang/python-2.2.1 )
- tcl? ( >=dev-lang/tcl-8.3.3-r2 )"
+DEPEND="tcl? ( >=dev-lang/tcl-8.3.3-r2 )"
+RDEPEND="${DEPEND}"
RESTRICT="test"
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Fix all hardcoded python2.5 paths
- for name in python/scxx/PWOBase.h python/PyHead.h python/PyStorage.cpp; do
- sed -i -e "s:Python.h:python$(python_get_version)/Python.h:" ${name}
- done
- sed -i -e "s:python2.5:python$(python_get_version):" unix/configure
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
}
-src_compile() {
+src_configure() {
local myconf mycxxflags
- use python && myconf="--with-python=$(python_get_includedir),$(python_get_sitedir)"
- use tcl && myconf="${myconf} --with-tcl=/usr/include,/usr/$(get_libdir)"
- use static && myconf="${myconf} --disable-shared"
+ use tcl && myconf+=" --with-tcl=/usr/include,/usr/$(get_libdir)"
+ use static && myconf+=" --disable-shared"
use static || mycxxflags="-fPIC"
sed -i -e "s:^\(CXXFLAGS = \).*:\1${CXXFLAGS} ${mycxxflags} -I\$(srcdir)/../include:" unix/Makefile.in
@@ -45,16 +43,51 @@ src_compile() {
--prefix=/usr \
--libdir=/usr/$(get_libdir) \
--infodir=/usr/share/info \
- --mandir=/usr/share/man || die "./configure failed"
+ --mandir=/usr/share/man || die "configure failed"
+}
+
+src_compile() {
+ default
- emake || die
+ if use python; then
+ python_copy_sources
+
+ building() {
+ emake \
+ pyincludedir="$(python_get_includedir)" \
+ python
+ }
+ python_execute_function -s building
+ fi
}
src_install () {
- use python && dodir $(python_get_sitedir)
- make DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use python; then
+ installation() {
+ dodir "$(python_get_sitedir)" || return 1
+ emake \
+ DESTDIR="${D}" \
+ pylibdir="$(python_get_sitedir)" \
+ install-python
+ }
+ python_execute_function -s installation
+ fi
dodoc CHANGES README
dohtml Metakit.html
dohtml -a html,gif,png,jpg -r doc/*
}
+
+pkg_postinst() {
+ if use python; then
+ python_mod_optimize metakit.py
+ fi
+}
+
+pkg_postrm() {
+ if use python; then
+ python_mod_cleanup metakit.py
+ fi
+}