summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2010-10-26 07:41:46 +0000
committerTim Harder <radhermit@gentoo.org>2010-10-26 07:41:46 +0000
commit3b8fad1cade46b82b8ce66dfbe6d9e3d329d096a (patch)
tree0ca85b0f6f71dafcd7bc8307dac75735961f5897 /dev-cpp/ctemplate
parentAvoid undef warning: Use of uninitialized value $opt{"syslog-socket"} in spam... (diff)
downloadgentoo-2-3b8fad1cade46b82b8ce66dfbe6d9e3d329d096a.tar.gz
gentoo-2-3b8fad1cade46b82b8ce66dfbe6d9e3d329d096a.tar.bz2
gentoo-2-3b8fad1cade46b82b8ce66dfbe6d9e3d329d096a.zip
Version bump for bug #301463 and remove old.
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'dev-cpp/ctemplate')
-rw-r--r--dev-cpp/ctemplate/ChangeLog9
-rw-r--r--dev-cpp/ctemplate/ctemplate-0.98.ebuild (renamed from dev-cpp/ctemplate/ctemplate-0.90.ebuild)24
-rw-r--r--dev-cpp/ctemplate/files/0.90-missing_includes.patch16
3 files changed, 18 insertions, 31 deletions
diff --git a/dev-cpp/ctemplate/ChangeLog b/dev-cpp/ctemplate/ChangeLog
index 715f31d05e4a..355a45efc87d 100644
--- a/dev-cpp/ctemplate/ChangeLog
+++ b/dev-cpp/ctemplate/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-cpp/ctemplate
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.7 2010/10/20 13:54:28 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ChangeLog,v 1.8 2010/10/26 07:41:45 radhermit Exp $
+
+*ctemplate-0.98 (26 Oct 2010)
+
+ 26 Oct 2010; Tim Harder <radhermit@gentoo.org>
+ -files/0.90-missing_includes.patch, -ctemplate-0.90.ebuild,
+ +ctemplate-0.98.ebuild:
+ Version bump for bug #301463 and remove old.
20 Oct 2010; Jeremy Olexa <darkside@gentoo.org> ctemplate-0.95.ebuild:
Use EAPI3, add prefix keywords as tested in bug 339818 by Thomas Burkard
diff --git a/dev-cpp/ctemplate/ctemplate-0.90.ebuild b/dev-cpp/ctemplate/ctemplate-0.98.ebuild
index 64b4e38321fe..e4ba1ca890b6 100644
--- a/dev-cpp/ctemplate/ctemplate-0.90.ebuild
+++ b/dev-cpp/ctemplate/ctemplate-0.98.ebuild
@@ -1,16 +1,19 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-0.90.ebuild,v 1.2 2008/09/17 11:59:42 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/ctemplate/ctemplate-0.98.ebuild,v 1.1 2010/10/26 07:41:45 radhermit Exp $
-inherit elisp-common eutils
+EAPI="3"
+
+inherit elisp-common
DESCRIPTION="A simple but powerful template language for C++"
HOMEPAGE="http://code.google.com/p/google-ctemplate/"
SRC_URI="http://google-ctemplate.googlecode.com/files/${P}.tar.gz"
+
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="emacs vim-syntax"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc emacs vim-syntax"
DEPEND=""
RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
@@ -18,14 +21,7 @@ RDEPEND="vim-syntax? ( >=app-editors/vim-core-7 )
SITEFILE="70ctemplate-gentoo.el"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PV}-missing_includes.patch"
-}
-
src_compile() {
- econf || die "econf failed"
emake || die "emake failed"
if use emacs ; then
@@ -37,10 +33,10 @@ src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
# Installs just every piece
- rm -rf "${D}/usr/share/doc"
+ rm -rf "${ED}/usr/share/doc"
dodoc AUTHORS ChangeLog NEWS README
- dohtml doc/*
+ use doc && dohtml doc/*
if use vim-syntax ; then
cd "${S}/contrib"
diff --git a/dev-cpp/ctemplate/files/0.90-missing_includes.patch b/dev-cpp/ctemplate/files/0.90-missing_includes.patch
deleted file mode 100644
index eb26058158ed..000000000000
--- a/dev-cpp/ctemplate/files/0.90-missing_includes.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -Naur ctemplate-0.90.orig/src/tests/htmlparser_test.cc ctemplate-0.90/src/tests/htmlparser_test.cc
---- ctemplate-0.90.orig/src/tests/htmlparser_test.cc 2008-08-10 15:33:53.000000000 +0200
-+++ ctemplate-0.90/src/tests/htmlparser_test.cc 2008-08-10 15:35:10.000000000 +0200
-@@ -62,9 +62,10 @@
- // insert_text: Executes HtmlParser::InsertText() if the argument is true.
-
- #include "config_for_unittests.h"
--#include <stdlib.h>
-+#include <cstdlib>
- #include <ctype.h>
--#include <assert.h>
-+#include <cassert>
-+#include <cstring>
- #include <string>
- #include <utility>
- #include <vector>