summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2010-06-28 00:26:34 +0000
committerZac Medico <zmedico@gentoo.org>2010-06-28 00:26:34 +0000
commit3220ca8616ead7ceb56a991d07ac9b106a8b5c30 (patch)
tree09dfac89d5355e62a7806b6b4704659bcf686432 /app-text
parentx86 stable, bug 322791 (diff)
downloadgentoo-2-3220ca8616ead7ceb56a991d07ac9b106a8b5c30.tar.gz
gentoo-2-3220ca8616ead7ceb56a991d07ac9b106a8b5c30.tar.bz2
gentoo-2-3220ca8616ead7ceb56a991d07ac9b106a8b5c30.zip
0.8.1 version bump.
(Portage version: 2.2_rc67_p176/cvs/Linux i686)
Diffstat (limited to 'app-text')
-rw-r--r--app-text/podofo/ChangeLog7
-rw-r--r--app-text/podofo/podofo-0.8.1.ebuild55
2 files changed, 61 insertions, 1 deletions
diff --git a/app-text/podofo/ChangeLog b/app-text/podofo/ChangeLog
index 5e5f95e91e05..ff5edaa37849 100644
--- a/app-text/podofo/ChangeLog
+++ b/app-text/podofo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-text/podofo
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.10 2010/06/05 21:37:21 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/ChangeLog,v 1.11 2010/06/28 00:26:34 zmedico Exp $
+
+*podofo-0.8.1 (27 Jun 2010)
+
+ 27 Jun 2010; Zac Medico <zmedico@gentoo.org> +podofo-0.8.1.ebuild:
+ 0.8.1 version bump.
05 Jun 2010; Zac Medico <zmedico@gentoo.org> podofo-0.7.0.ebuild,
podofo-0.8.0.ebuild:
diff --git a/app-text/podofo/podofo-0.8.1.ebuild b/app-text/podofo/podofo-0.8.1.ebuild
new file mode 100644
index 000000000000..06f8d3337877
--- /dev/null
+++ b/app-text/podofo/podofo-0.8.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/podofo/podofo-0.8.1.ebuild,v 1.1 2010/06/28 00:26:34 zmedico Exp $
+
+EAPI=2
+inherit cmake-utils multilib
+
+DESCRIPTION="PoDoFo is a C++ library to work with the PDF file format."
+HOMEPAGE="http://sourceforge.net/projects/podofo/"
+SRC_URI="mirror://sourceforge/podofo/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+boost debug test"
+
+RDEPEND="dev-lang/lua
+ dev-libs/openssl
+ >=dev-libs/STLport-5.1.5
+ media-libs/fontconfig
+ media-libs/freetype:2
+ media-libs/jpeg:0
+ media-libs/libpng
+ media-libs/tiff
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ boost? ( dev-util/boost-build )
+ test? ( dev-util/cppunit )"
+
+DOCS="AUTHORS ChangeLog TODO"
+
+src_prepare() {
+ sed -i \
+ -e "s:LIBDIRNAME \"lib\":LIBDIRNAME \"$(get_libdir)\":" \
+ CMakeLists.txt || die
+
+ # Apply r1251 from upstream, to fix ambiguous conversion error.
+ sed -e 's/"), \([[:digit:]]L\)/"\), static_cast<pdf_int64>(\1)/' -i \
+ test/unit/EncryptTest.cpp || die
+}
+
+src_configure() {
+ mycmakeargs+=(
+ "-DPODOFO_BUILD_SHARED=1"
+ "-DPODOFO_HAVE_JPEG_LIB=1"
+ "-DPODOFO_HAVE_PNG_LIB=1"
+ "-DPODOFO_HAVE_TIFF_LIB=1"
+ "-DWANT_FONTCONFIG=1"
+ "-DUSE_STLPORT=1"
+ $(cmake-utils_use_want boost)
+ $(cmake-utils_use_has test CPPUNIT)
+ )
+
+ cmake-utils_src_configure
+}