summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2004-11-11 15:05:13 +0000
committerAaron Walker <ka0ttic@gentoo.org>2004-11-11 15:05:13 +0000
commit986019d5857e370a64aee74aeb17f1c10174ccee (patch)
tree04e8f87a96fcb9e0fe0e84d66ef9de890818dd6f /app-shells
parentbackported nss/nspr fix to 1.4.6 (Manifest recommit) (diff)
downloadgentoo-2-986019d5857e370a64aee74aeb17f1c10174ccee.tar.gz
gentoo-2-986019d5857e370a64aee74aeb17f1c10174ccee.tar.bz2
gentoo-2-986019d5857e370a64aee74aeb17f1c10174ccee.zip
Revision bump; added support for static and diet (dietlibc) USE flags as requested in bug #70768. Also, ebuild now respects user CFLAGS as it should.
Diffstat (limited to 'app-shells')
-rw-r--r--app-shells/dash/ChangeLog8
-rw-r--r--app-shells/dash/Manifest14
-rw-r--r--app-shells/dash/dash-0.5.1.3-r1.ebuild48
-rw-r--r--app-shells/dash/files/digest-dash-0.5.1.3-r12
4 files changed, 60 insertions, 12 deletions
diff --git a/app-shells/dash/ChangeLog b/app-shells/dash/ChangeLog
index 2dd7bac24d71..f5157ec8a2f9 100644
--- a/app-shells/dash/ChangeLog
+++ b/app-shells/dash/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-shells/dash
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.11 2004/10/30 22:04:54 ka0ttic Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/ChangeLog,v 1.12 2004/11/11 15:05:13 ka0ttic Exp $
+
+*dash-0.5.1.3-r1 (11 Nov 2004)
+
+ 11 Nov 2004; Aaron Walker <ka0ttic@gentoo.org> +dash-0.5.1.3-r1.ebuild:
+ Revision bump; added support for static and diet (dietlibc) USE flags as
+ requested in bug #70768. Also, ebuild now respects user CFLAGS as it should.
30 Oct 2004; Aaron Walker <ka0ttic@gentoo.org> dash-0.5.1.3.ebuild:
Marked stable on x86.
diff --git a/app-shells/dash/Manifest b/app-shells/dash/Manifest
index 8b52127c9347..fcbd4ca957f3 100644
--- a/app-shells/dash/Manifest
+++ b/app-shells/dash/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 6b2f8b09dfaa27c8edf878ecbfe24a68 dash-0.5.1.3-r1.ebuild 1162
MD5 ce5a1f82be33d804e0f85952cce77026 dash-0.5.1.1.ebuild 872
MD5 e923eb6b9e3574263777280eb89fc5b8 dash-0.5.1.3.ebuild 876
-MD5 3ed1b99ea7d72d8533c5aac8e62f1938 ChangeLog 1739
+MD5 c3e9250e7204f2e5dc2cf9361ad017c9 ChangeLog 2000
MD5 f8d10f350e91f30316ea4e1bd1e76470 metadata.xml 254
MD5 115b4f38170f7c82c6c9e3259c55108c files/digest-dash-0.5.1.1 131
MD5 789070e5451f8e3151926438cfb4744b files/digest-dash-0.5.1.3 131
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.6 (GNU/Linux)
-
-iD8DBQFBhBAPEZCkKN40op4RAnrUAJ4zdwVi30KSlpy+p2D2YeKWwyaiGACfcM+1
-FYjZuIFlRh7AZloCtskvzIE=
-=Dqjn
------END PGP SIGNATURE-----
+MD5 789070e5451f8e3151926438cfb4744b files/digest-dash-0.5.1.3-r1 131
diff --git a/app-shells/dash/dash-0.5.1.3-r1.ebuild b/app-shells/dash/dash-0.5.1.3-r1.ebuild
new file mode 100644
index 000000000000..0c4e52f031b7
--- /dev/null
+++ b/app-shells/dash/dash-0.5.1.3-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-shells/dash/dash-0.5.1.3-r1.ebuild,v 1.1 2004/11/11 15:05:13 ka0ttic Exp $
+
+inherit eutils versionator flag-o-matic toolchain-funcs
+
+DEB_P="${PN}_$(replace_version_separator 3 '-')"
+MY_P2="${DEB_P%-*}"
+MY_P=${MY_P2/_/-}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="Debian-version of NetBSD's lightweight bourne shell"
+HOMEPAGE="http://ftp.debian.org/debian/pool/main/d/dash/"
+SRC_URI="mirror://debian/pool/main/d/dash/${MY_P2}.orig.tar.gz \
+ mirror://debian/pool/main/d/dash/${DEB_P}.diff.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~x86 ~ppc"
+IUSE="diet static"
+
+DEPEND="diet? ( dev-libs/dietlibc )
+ !diet? ( virtual/libc )
+ sys-apps/sed
+ dev-util/yacc"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${WORKDIR}/${DEB_P}.diff
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ CC="$(tc-getCC)"
+ use diet && CC="diet ${CC}"
+
+ econf CC="${CC}" || die "econf failed"
+ emake CFLAGS="${CFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ exeinto /bin
+ newexe src/dash dash
+ newman src/dash.1 dash.1
+ dodoc COPYING debian/changelog
+}
diff --git a/app-shells/dash/files/digest-dash-0.5.1.3-r1 b/app-shells/dash/files/digest-dash-0.5.1.3-r1
new file mode 100644
index 000000000000..d50e49379717
--- /dev/null
+++ b/app-shells/dash/files/digest-dash-0.5.1.3-r1
@@ -0,0 +1,2 @@
+MD5 8bcc29c879d053fcb9301ccf6fe373ac dash_0.5.1.orig.tar.gz 227723
+MD5 9e9616bb238475bff3cccd6b1f3e5a26 dash_0.5.1-3.diff.gz 20029