summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2008-02-24 22:03:17 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2008-02-24 22:03:17 +0000
commitc76cdb0dc980351a68ec6d34e14573c36f57514e (patch)
tree456eb209c455f19726a0d4dbe90fd4355e8d82de /app-pda
parentInstall cmake modules for libkdegames, bug #211199 (diff)
downloadgentoo-2-c76cdb0dc980351a68ec6d34e14573c36f57514e.tar.gz
gentoo-2-c76cdb0dc980351a68ec6d34e14573c36f57514e.tar.bz2
gentoo-2-c76cdb0dc980351a68ec6d34e14573c36f57514e.zip
fix python/distutils eclass use, bug #207667
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-pda')
-rw-r--r--app-pda/pilot-link/ChangeLog6
-rw-r--r--app-pda/pilot-link/files/pilot-link-0.12.3-distutils.patch19
-rw-r--r--app-pda/pilot-link/pilot-link-0.12.3.ebuild29
3 files changed, 51 insertions, 3 deletions
diff --git a/app-pda/pilot-link/ChangeLog b/app-pda/pilot-link/ChangeLog
index 37000a7c4ed1..f832c557a9cb 100644
--- a/app-pda/pilot-link/ChangeLog
+++ b/app-pda/pilot-link/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-pda/pilot-link
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.38 2008/01/31 01:59:03 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/ChangeLog,v 1.39 2008/02/24 22:03:16 eva Exp $
+
+ 17 Feb 2008; Gilles Dartiguelongue <eva@gentoo.org>
+ +files/pilot-link-0.12.3-distutils.patch, pilot-link-0.12.3.ebuild:
+ fix python/distutils eclass use, bug #207667
31 Jan 2008; Brent Baude <ranger@gentoo.org> pilot-link-0.12.3.ebuild:
Marking pilot-link-0.12.3 ppc for bug 207634
diff --git a/app-pda/pilot-link/files/pilot-link-0.12.3-distutils.patch b/app-pda/pilot-link/files/pilot-link-0.12.3-distutils.patch
new file mode 100644
index 000000000000..db229f855278
--- /dev/null
+++ b/app-pda/pilot-link/files/pilot-link-0.12.3-distutils.patch
@@ -0,0 +1,19 @@
+--- bindings/Makefile.am.old 2008-02-24 22:47:19.000000000 +0100
++++ bindings/Makefile.am 2008-02-24 22:47:40.000000000 +0100
+@@ -25,16 +25,10 @@
+ -cd $(srcdir)/Python && $(PYTHON) setup.py clean
+ -cd $(srcdir)/Python && rm -rf build
+
+-if WITH_PYTHON
+-PYTHON_ALL = python-build
+-PYTHON_INSTALL = python-install
+-PYTHON_CLEAN = python-clean
+-else
+ PYTHON_ALL =
+ PYTHON_INSTALL =
+ PYTHON_MCLEAN =
+ PYTHON_CLEAN =
+-endif
+
+ #
+ # Perl Building
diff --git a/app-pda/pilot-link/pilot-link-0.12.3.ebuild b/app-pda/pilot-link/pilot-link-0.12.3.ebuild
index 2f79c487bb37..35873cdce260 100644
--- a/app-pda/pilot-link/pilot-link-0.12.3.ebuild
+++ b/app-pda/pilot-link/pilot-link-0.12.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3.ebuild,v 1.7 2008/01/31 01:59:03 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-pda/pilot-link/pilot-link-0.12.3.ebuild,v 1.8 2008/02/24 22:03:16 eva Exp $
-inherit perl-module java-pkg-opt-2 eutils autotools
+inherit perl-module java-pkg-opt-2 eutils autotools distutils
DESCRIPTION="suite of tools for moving data between a Palm device and a desktop"
HOMEPAGE="http://www.pilot-link.org/"
@@ -49,6 +49,10 @@ src_unpack() {
# their installation here.
use java && epatch "${FILESDIR}/${P}-java-install.patch"
+ # We install the Python bindings using the eclass functions so we disable
+ # their makefile.am rules here
+ use python && epatch "${FILESDIR}/${P}-distutils.patch"
+
# Upstream patch to fix 64-bit issues.
epatch "${FILESDIR}/${P}-int_types.patch"
@@ -81,6 +85,11 @@ src_compile() {
perl-module_src_prep
perl-module_src_compile
fi
+
+ if use python; then
+ cd "${S}/bindings/Python"
+ distutils_src_compile
+ fi
}
src_install() {
@@ -98,4 +107,20 @@ src_install() {
cd "${S}/bindings/Perl"
perl-module_src_install
fi
+
+ if use python; then
+ cd "${S}/bindings/Python"
+ distutils_src_install
+ fi
+}
+
+pkg_postinst() {
+ if use python; then
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/python${PYVER}/site-packages
+ fi
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
}