summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJurek Bartuszek <jurek@gentoo.org>2007-02-07 00:34:39 +0000
committerJurek Bartuszek <jurek@gentoo.org>2007-02-07 00:34:39 +0000
commit344d7064fb1770a09fb2ef165b5d45fcde02ad89 (patch)
treef08d3e3f6e37df55d5605c1cedbd4ce693f8ee5a /app-pda/dopi
parentRemove old version. (diff)
downloadgentoo-2-344d7064fb1770a09fb2ef165b5d45fcde02ad89.tar.gz
gentoo-2-344d7064fb1770a09fb2ef165b5d45fcde02ad89.tar.bz2
gentoo-2-344d7064fb1770a09fb2ef165b5d45fcde02ad89.zip
app-pda/dopi: Version bump fixing bug #158727. Adding Jurek Bartuszek <jurek@gentoo.org> to metadata.xml
(Portage version: 2.1.1-r2)
Diffstat (limited to 'app-pda/dopi')
-rw-r--r--app-pda/dopi/ChangeLog13
-rw-r--r--app-pda/dopi/dopi-0.3.4.ebuild44
-rw-r--r--app-pda/dopi/files/digest-dopi-0.3.43
-rw-r--r--app-pda/dopi/files/noicon-exception-fix.diff16
-rw-r--r--app-pda/dopi/metadata.xml19
5 files changed, 84 insertions, 11 deletions
diff --git a/app-pda/dopi/ChangeLog b/app-pda/dopi/ChangeLog
index c770b18ea5a5..9e3ff481995c 100644
--- a/app-pda/dopi/ChangeLog
+++ b/app-pda/dopi/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-pda/dopi
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-pda/dopi/ChangeLog,v 1.1 2006/04/20 07:51:58 latexer Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/dopi/ChangeLog,v 1.2 2007/02/07 00:34:39 jurek Exp $
+
+*dopi-0.3.4 (07 Feb 2007)
+
+ 07 Feb 2007; Jurek Bartuszek <jurek@gentoo.org>
+ +files/noicon-exception-fix.diff, metadata.xml, +dopi-0.3.4.ebuild:
+ - Version bump (0.3.4). Credit goes to Dieter Verfaillie
+ <dieterv@optionexplicit.be> for providing and maintaining the ebuild. Fixing
+ bug #158727
+ - Added Jurek Bartuszek <jurek@gentoo.org> to metadata.xml
*dopi-0.3.2 (20 Apr 2006)
diff --git a/app-pda/dopi/dopi-0.3.4.ebuild b/app-pda/dopi/dopi-0.3.4.ebuild
new file mode 100644
index 000000000000..c86488de39f2
--- /dev/null
+++ b/app-pda/dopi/dopi-0.3.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-pda/dopi/dopi-0.3.4.ebuild,v 1.1 2007/02/07 00:34:39 jurek Exp $
+
+inherit eutils fdo-mime mono
+
+DESCRIPTION="Dopi is a little application for updating Apple iPod devices"
+HOMEPAGE="http://www.snorp.net/"
+SRC_URI="http://www.snorp.net/files/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+DEPEND="dev-lang/mono
+ >=dev-dotnet/ipod-sharp-0.6.2
+ >=dev-dotnet/glade-sharp-2.4.0
+ >=dev-dotnet/gtk-sharp-2.4.0
+ >=dev-libs/glib-2.0"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/noicon-exception-fix.diff
+}
+
+src_compile() {
+ econf || die
+
+ #This build is not parallel safe
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+}
diff --git a/app-pda/dopi/files/digest-dopi-0.3.4 b/app-pda/dopi/files/digest-dopi-0.3.4
new file mode 100644
index 000000000000..61dafa336d5a
--- /dev/null
+++ b/app-pda/dopi/files/digest-dopi-0.3.4
@@ -0,0 +1,3 @@
+MD5 9e56cb6b0665c2bfdeccfa55f5171b34 dopi-0.3.4.tar.gz 446439
+RMD160 c48bf48376ac6af7489f601793ea4e524555d17b dopi-0.3.4.tar.gz 446439
+SHA256 9e49bbd27ea54799359fa67fe6f703ae065df6df09e4ca286ada35c823165519 dopi-0.3.4.tar.gz 446439
diff --git a/app-pda/dopi/files/noicon-exception-fix.diff b/app-pda/dopi/files/noicon-exception-fix.diff
new file mode 100644
index 000000000000..8e5558733d29
--- /dev/null
+++ b/app-pda/dopi/files/noicon-exception-fix.diff
@@ -0,0 +1,16 @@
+--- dopi-old/src/DopiWindow.cs 2007-02-05 23:53:15.000000000 +0100
++++ dopi/src/DopiWindow.cs 2007-02-06 23:33:42.000000000 +0100
+@@ -54,7 +54,12 @@ namespace Dopi {
+
+ tips = new Tooltips ();
+
+- Gdk.Pixbuf pixbuf = IconTheme.Default.LoadIcon ("gnome-dev-ipod", 24, 0);
++ Gdk.Pixbuf pixbuf = null;
++ try {
++ pixbuf = IconTheme.Default.LoadIcon ("gnome-dev-ipod", 24, 0);
++ } catch (GLib.GException e) {
++ }
++
+ if (pixbuf != null) {
+ this.Icon = pixbuf;
+ }
diff --git a/app-pda/dopi/metadata.xml b/app-pda/dopi/metadata.xml
index ffd09712b991..d422d13e51ff 100644
--- a/app-pda/dopi/metadata.xml
+++ b/app-pda/dopi/metadata.xml
@@ -1,14 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>dotnet</herd>
-<maintainer>
-<email>latexer@gentoo.org</email>
-<name>Peter Johanson</name>
-</maintainer>
-<longdescription lang="en">
-Dopi is an application that allows you to update the songs stored on your Apple
-iPod®.
-</longdescription>
+ <herd>dotnet</herd>
+ <maintainer>
+ <email>latexer@gentoo.org</email>
+ <name>Peter Johanson</name>
+ </maintainer>
+ <maintainer>
+ <email>jurek@gentoo.org</email>
+ <name>Jurek Bartuszek</name>
+ </maintainer>
+ <longdescription lang="en">Dopi is an application that allows you to update the songs stored on your Apple iPod.</longdescription>
</pkgmetadata>