summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2002-11-24 05:04:13 +0000
committerDan Armak <danarmak@gentoo.org>2002-11-24 05:04:13 +0000
commit416b0e1700a43d7420fb7c463166d3209b01aa16 (patch)
treeaf08ad4518e4d8cf6a0bcd8db74f4aac788a2134 /app-office
parentfixor (diff)
downloadgentoo-2-416b0e1700a43d7420fb7c463166d3209b01aa16.tar.gz
gentoo-2-416b0e1700a43d7420fb7c463166d3209b01aa16.tar.bz2
gentoo-2-416b0e1700a43d7420fb7c463166d3209b01aa16.zip
Fix #7893: add a patch that fixes the kivio connector tool.
Diffstat (limited to 'app-office')
-rw-r--r--app-office/koffice/ChangeLog8
-rw-r--r--app-office/koffice/files/digest-koffice-1.2-r11
-rw-r--r--app-office/koffice/files/koffice-1.2-connectortool.diff11
-rw-r--r--app-office/koffice/koffice-1.2-r1.ebuild32
4 files changed, 51 insertions, 1 deletions
diff --git a/app-office/koffice/ChangeLog b/app-office/koffice/ChangeLog
index 08cdd7dbe6a9..57d79119a366 100644
--- a/app-office/koffice/ChangeLog
+++ b/app-office/koffice/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-office/koffice
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.13 2002/09/15 13:35:08 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/ChangeLog,v 1.14 2002/11/24 05:04:13 danarmak Exp $
+
+*koffice-1.2-r1 (24 Nov 2002)
+
+ 24 Nov 2002; Dan Armak <danarmak@gentoo.org> ChangeLog :
+
+ Fix #7893: add a patch that fixes the kivio connector tool.
*koffice-1.2 (15 Sep 2002)
diff --git a/app-office/koffice/files/digest-koffice-1.2-r1 b/app-office/koffice/files/digest-koffice-1.2-r1
new file mode 100644
index 000000000000..e4febdfaf1c9
--- /dev/null
+++ b/app-office/koffice/files/digest-koffice-1.2-r1
@@ -0,0 +1 @@
+MD5 34cb13104bc1d4f0916b0dda6dec7ee0 koffice-1.2.tar.bz2 9321755
diff --git a/app-office/koffice/files/koffice-1.2-connectortool.diff b/app-office/koffice/files/koffice-1.2-connectortool.diff
new file mode 100644
index 000000000000..f64bce219526
--- /dev/null
+++ b/app-office/koffice/files/koffice-1.2-connectortool.diff
@@ -0,0 +1,11 @@
+--- kivio/plugins/kivioconnectortool/straight_connector/Makefile.am 2002/05/25 16:08:19 1.8
++++ kivio/plugins/kivioconnectortool/straight_connector/Makefile.am 2002/09/13 08:30:39 1.8.2.1
+@@ -2,7 +2,7 @@
+ #### Makefile.am generated automatically by KDEStudio ####
+ #### WARNING! All changes made in this part will be lost! ####
+ ##############################################################
+-
++libdir = $(kde_datadir)/kivio/autoloadStencils
+ lib_LTLIBRARIES =libstraight_connector.la
+
+
diff --git a/app-office/koffice/koffice-1.2-r1.ebuild b/app-office/koffice/koffice-1.2-r1.ebuild
new file mode 100644
index 000000000000..d51688748bcb
--- /dev/null
+++ b/app-office/koffice/koffice-1.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/koffice/koffice-1.2-r1.ebuild,v 1.1 2002/11/24 05:04:13 danarmak Exp $
+inherit kde-base flag-o-matic
+
+filter-flags "-fomit-frame-pointer"
+
+need-kde 3
+
+DESCRIPTION="A free, integrated office suite for KDE, the K Desktop Environment."
+HOMEPAGE="http://www.koffice.org/"
+LICENSE="GPL-2 LGPL-2"
+SRC_URI="mirror://kde/stable/$P/src/$P.tar.bz2"
+
+KEYWORDS="x86 ppc"
+
+DEPEND="$DEPEND
+ >=dev-lang/python-2.2.1
+ >=media-libs/libart_lgpl-2.3.9
+ >=media-gfx/imagemagick-5.4.5"
+
+export LIBPYTHON="`python-config --libs`"
+export LIBPYTHON="${LIBPYTHON//-L \/usr\/lib\/python2.2\/config}"
+
+need-automake 1.5
+need-autoconf 2.5
+
+set_enable_final
+
+# fix bug #7893 - kde bug #47146.
+# patch from koffice cvs - stable tree
+PATCHES="$FILESDIR/$P-connectortool.diff"