summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2010-07-17 10:50:57 +0000
committerLars Wendler <polynomial-c@gentoo.org>2010-07-17 10:50:57 +0000
commitd6a00faa68864a4fd9c1050522f6255fdbc9a585 (patch)
tree6b2b5031314966c82920fdde8ad32be094fefdf9 /app-emulation
parentRemove duplicate savedconfig.eclass code. (diff)
downloadgentoo-2-d6a00faa68864a4fd9c1050522f6255fdbc9a585.tar.gz
gentoo-2-d6a00faa68864a4fd9c1050522f6255fdbc9a585.tar.bz2
gentoo-2-d6a00faa68864a4fd9c1050522f6255fdbc9a585.zip
Removed old.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/virtualbox-modules/ChangeLog8
-rw-r--r--app-emulation/virtualbox-modules/files/virtualbox-modules-1.6.6_2.6.27.patch79
-rw-r--r--app-emulation/virtualbox-modules/files/virtualbox-modules-2.6.29_rc.patch11
-rw-r--r--app-emulation/virtualbox-modules/virtualbox-modules-3.0.12.ebuild61
4 files changed, 7 insertions, 152 deletions
diff --git a/app-emulation/virtualbox-modules/ChangeLog b/app-emulation/virtualbox-modules/ChangeLog
index 15e8871e27d7..8a5efeda4b24 100644
--- a/app-emulation/virtualbox-modules/ChangeLog
+++ b/app-emulation/virtualbox-modules/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/virtualbox-modules
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-modules/ChangeLog,v 1.66 2010/07/14 13:03:37 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-modules/ChangeLog,v 1.67 2010/07/17 10:50:57 polynomial-c Exp $
+
+ 17 Jul 2010; Lars Wendler <polynomial-c@gentoo.org>
+ -files/virtualbox-modules-1.6.6_2.6.27.patch,
+ -files/virtualbox-modules-2.6.29_rc.patch,
+ -virtualbox-modules-3.0.12.ebuild:
+ Removed old.
14 Jul 2010; Christian Faulhammer <fauli@gentoo.org>
virtualbox-modules-3.1.8.ebuild:
diff --git a/app-emulation/virtualbox-modules/files/virtualbox-modules-1.6.6_2.6.27.patch b/app-emulation/virtualbox-modules/files/virtualbox-modules-1.6.6_2.6.27.patch
deleted file mode 100644
index 2fa70a28df4e..000000000000
--- a/app-emulation/virtualbox-modules/files/virtualbox-modules-1.6.6_2.6.27.patch
+++ /dev/null
@@ -1,79 +0,0 @@
---- a/linux/SUPDrv-linux.c
-+++ b/linux/SUPDrv-linux.c
-@@ -115,44 +115,6 @@
- # error "CONFIG_X86_HIGH_ENTRY is not supported by VBoxDrv at this time."
- #endif
-
--/*
-- * This sucks soooo badly on x86! Why don't they export __PAGE_KERNEL_EXEC so PAGE_KERNEL_EXEC would be usable?
-- */
--#if defined(RT_ARCH_AMD64)
--# define MY_PAGE_KERNEL_EXEC PAGE_KERNEL_EXEC
--#elif defined(PAGE_KERNEL_EXEC) && defined(CONFIG_X86_PAE)
--# define MY_PAGE_KERNEL_EXEC __pgprot(cpu_has_pge ? _PAGE_KERNEL_EXEC | _PAGE_GLOBAL : _PAGE_KERNEL_EXEC)
--#else
--# define MY_PAGE_KERNEL_EXEC PAGE_KERNEL
--#endif
--
--/*
-- * The redhat hack section.
-- * - The current hacks are for 2.4.21-15.EL only.
-- */
--#ifndef NO_REDHAT_HACKS
--/* accounting. */
--# if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
--# ifdef VM_ACCOUNT
--# define MY_DO_MUNMAP(a,b,c) do_munmap(a, b, c, 0) /* should it be 1 or 0? */
--# endif
--# endif
--
--/* backported remap_page_range. */
--# if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
--# include <asm/tlb.h>
--# ifdef tlb_vma /* probably not good enough... */
--# define HAVE_26_STYLE_REMAP_PAGE_RANGE 1
--# endif
--# endif
--
--#endif /* !NO_REDHAT_HACKS */
--
--
--#ifndef MY_DO_MUNMAP
--# define MY_DO_MUNMAP(a,b,c) do_munmap(a, b, c)
--#endif
--
-
- /** @def ONE_MSEC_IN_JIFFIES
- * The number of jiffies that make up 1 millisecond. Must be at least 1! */
---- a/r0drv/linux/alloc-r0drv-linux.c
-+++ b/r0drv/linux/alloc-r0drv-linux.c
-@@ -131,11 +131,10 @@ PRTMEMHDR rtMemAlloc(size_t cb, uint32_t
- }
- else
- # endif
-- pHdr = (PRTMEMHDR)__vmalloc(cb + sizeof(*pHdr), GFP_KERNEL | __GFP_HIGHMEM, PAGE_KERNEL_EXEC);
-+ pHdr = (PRTMEMHDR)__vmalloc(cb + sizeof(*pHdr), GFP_KERNEL | __GFP_HIGHMEM, MY_PAGE_KERNEL_EXEC);
-
- #elif defined(PAGE_KERNEL_EXEC) && defined(CONFIG_X86_PAE)
-- pHdr = (PRTMEMHDR)__vmalloc(cb + sizeof(*pHdr), GFP_KERNEL | __GFP_HIGHMEM,
-- __pgprot(cpu_has_pge ? _PAGE_KERNEL_EXEC | _PAGE_GLOBAL : _PAGE_KERNEL_EXEC));
-+ pHdr = (PRTMEMHDR)__vmalloc(cb + sizeof(*pHdr), GFP_KERNEL | __GFP_HIGHMEM, MY_PAGE_KERNEL_EXEC);
- #else
- pHdr = (PRTMEMHDR)vmalloc(cb + sizeof(*pHdr));
- #endif
---- a/r0drv/linux/the-linux-kernel.h
-+++ b/r0drv/linux/the-linux-kernel.h
-@@ -174,7 +174,12 @@ DECLINLINE(unsigned long) msecs_to_jiffi
- #if defined(RT_ARCH_AMD64)
- # define MY_PAGE_KERNEL_EXEC PAGE_KERNEL_EXEC
- #elif defined(PAGE_KERNEL_EXEC) && defined(CONFIG_X86_PAE)
--# define MY_PAGE_KERNEL_EXEC __pgprot(cpu_has_pge ? _PAGE_KERNEL_EXEC | _PAGE_GLOBAL : _PAGE_KERNEL_EXEC)
-+# ifdef __PAGE_KERNEL_EXEC
-+ /* >= 2.6.27 */
-+# define MY_PAGE_KERNEL_EXEC __pgprot(cpu_has_pge ? __PAGE_KERNEL_EXEC | _PAGE_GLOBAL : __PAGE_KERNEL_EXEC)
-+# else
-+# define MY_PAGE_KERNEL_EXEC __pgprot(cpu_has_pge ? _PAGE_KERNEL_EXEC | _PAGE_GLOBAL : _PAGE_KERNEL_EXEC)
-+# endif
- #else
- # define MY_PAGE_KERNEL_EXEC PAGE_KERNEL
- #endif
diff --git a/app-emulation/virtualbox-modules/files/virtualbox-modules-2.6.29_rc.patch b/app-emulation/virtualbox-modules/files/virtualbox-modules-2.6.29_rc.patch
deleted file mode 100644
index 0724b4d8e70d..000000000000
--- a/app-emulation/virtualbox-modules/files/virtualbox-modules-2.6.29_rc.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- vboxdrv/Makefile.orig 2009-02-25 01:22:57.626074529 +0100
-+++ vboxdrv/Makefile 2009-02-25 01:23:36.419076205 +0100
-@@ -67,7 +67,7 @@
- endif
-
- # use vm_insert_page() API (if available) to map kernel pages to userland - better debugging
--# VBOX_USE_INSERT_PAGE = 1
-+VBOX_USE_INSERT_PAGE = 1
-
- # override is required by the Debian guys
- override MODULE = vboxdrv
diff --git a/app-emulation/virtualbox-modules/virtualbox-modules-3.0.12.ebuild b/app-emulation/virtualbox-modules/virtualbox-modules-3.0.12.ebuild
deleted file mode 100644
index 36747e70ccbe..000000000000
--- a/app-emulation/virtualbox-modules/virtualbox-modules-3.0.12.ebuild
+++ /dev/null
@@ -1,61 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/virtualbox-modules/virtualbox-modules-3.0.12.ebuild,v 1.3 2009/11/30 11:11:01 maekke Exp $
-
-# XXX: the tarball here is just the kernel modules split out of the binary
-# package that comes from virtualbox-bin
-
-EAPI=2
-
-inherit eutils linux-mod
-
-MY_P=vbox-kernel-module-src-${PV}
-DESCRIPTION="Kernel Modules for Virtualbox"
-HOMEPAGE="http://www.virtualbox.org/"
-SRC_URI="http://gentoo.zerodev.it/files/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND="!=app-emulation/virtualbox-ose-9999"
-
-S=${WORKDIR}
-
-BUILD_TARGETS="all"
-BUILD_TARGET_ARCH="${ARCH}"
-MODULE_NAMES="vboxdrv(misc:${S}) vboxnetflt(misc:${S}) vboxnetadp(misc:${S})"
-
-pkg_setup() {
- linux-mod_pkg_setup
- BUILD_PARAMS="KERN_DIR=${KV_DIR} KERNOUT=${KV_OUT_DIR}"
- enewgroup vboxusers
-}
-
-src_install() {
- linux-mod_src_install
-
- # udev rule for vboxdrv
- dodir /etc/udev/rules.d
- echo 'KERNEL=="vboxdrv", NAME="vboxdrv", OWNER="root", GROUP="", MODE=""' \
- > "${D}/etc/udev/rules.d/10-virtualbox.rules"
- echo 'SUBSYSTEM=="usb_device", GROUP="", MODE=""' \
- >> "${D}/etc/udev/rules.d/10-virtualbox.rules"
- echo 'SUBSYSTEM=="usb", ENV{DEVTYPE}=="usb_device", GROUP="", MODE=""' \
- >> "${D}/etc/udev/rules.d/10-virtualbox.rules"
-}
-
-pkg_postinst() {
- linux-mod_pkg_postinst
- elog "Starting with the 3.x release new kernel modules were added,"
- elog "be sure to load all the needed modules."
- elog ""
- elog "Please add \"vboxdrv\", \"vboxnetflt\" and \"vboxnetadp\" to:"
- if has_version sys-apps/openrc; then
- elog "/etc/conf.d/modules"
- else
- elog "/etc/modules.autoload.d/kernel-${KV_MAJOR}.${KV_MINOR}"
- fi
- elog ""
-}