summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2007-03-15 20:47:05 +0000
committerDavid Holm <dholm@gentoo.org>2007-03-15 20:47:05 +0000
commitb50539c10deb99216fc61fe2fe41c33604c050f6 (patch)
tree04dccb0177775185354946ad192cfb9beabe0578 /app-emulation/aranym
parentChanged cmake-dependency to 2.4.6, bug #162366. Small cleanups. Old version d... (diff)
downloadgentoo-2-b50539c10deb99216fc61fe2fe41c33604c050f6.tar.gz
gentoo-2-b50539c10deb99216fc61fe2fe41c33604c050f6.tar.bz2
gentoo-2-b50539c10deb99216fc61fe2fe41c33604c050f6.zip
Removed old versions
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-emulation/aranym')
-rw-r--r--app-emulation/aranym/ChangeLog6
-rw-r--r--app-emulation/aranym/aranym-0.8.6_beta.ebuild57
-rw-r--r--app-emulation/aranym/aranym-0.9.0.ebuild56
-rw-r--r--app-emulation/aranym/files/digest-aranym-0.8.6_beta6
-rw-r--r--app-emulation/aranym/files/digest-aranym-0.9.06
5 files changed, 5 insertions, 126 deletions
diff --git a/app-emulation/aranym/ChangeLog b/app-emulation/aranym/ChangeLog
index d9ad28357507..4872ae4ec5f1 100644
--- a/app-emulation/aranym/ChangeLog
+++ b/app-emulation/aranym/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/aranym
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.10 2007/03/15 20:34:30 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/ChangeLog,v 1.11 2007/03/15 20:47:05 dholm Exp $
+
+ 15 Mar 2007; <dholm@gentoo.org> -aranym-0.8.6_beta.ebuild,
+ -aranym-0.9.0.ebuild:
+ Removed old versions. This also relates to bug #160519.
*aranym-0.9.4_beta2 (15 Mar 2007)
diff --git a/app-emulation/aranym/aranym-0.8.6_beta.ebuild b/app-emulation/aranym/aranym-0.8.6_beta.ebuild
deleted file mode 100644
index 4cf8b5662ec8..000000000000
--- a/app-emulation/aranym/aranym-0.8.6_beta.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.8.6_beta.ebuild,v 1.9 2007/01/25 21:55:49 genone Exp $
-
-inherit flag-o-matic
-
-AFROS="afros-20040206.zip"
-S="${WORKDIR}/${PN}-0.8.6beta"
-DESCRIPTION="Atari Running on Any Machine, is a virtual machine software for running Atari ST/TT/Falcon operating systems and TOS/GEM applications"
-HOMEPAGE="http://aranym.sourceforge.net/"
-SRC_URI="mirror://sourceforge/aranym/${PN}-0.8.6beta.tar.gz
- mirror://sourceforge/aranym/${AFROS}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~ppc ~x86"
-IUSE="opengl"
-
-RDEPEND="media-libs/libsdl
- games-emulation/emutos
- opengl? ( virtual/opengl )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${PN}-0.8.6beta.tar.gz
-}
-
-src_compile() {
- filter-flags -mpowerpc-gfxopt
-
- use opengl && myconf="--enable-opengl"
- if [ "${ARCH}" = "x86" ]; then
- myconf="${myconf} --enable-jit-compiler"
- fi
-
- cd ${S}/src/Unix
- econf ${myconf} || die "configure failed"
-
- emake dep || die "failed while building dependencies"
- emake || die "failed during compilation"
-}
-
-src_install() {
- cd ${S}/src/Unix
- emake DESTDIR=${D} install || die "installation failed"
-
- dosym /usr/games/lib/etos512k.img /usr/share/aranym
-
- cd ${D}/usr/share/aranym
- unzip ${DISTDIR}/${AFROS}
- sed -i -e "s|tmp|usr/share/aranym|g" ${D}/usr/share/aranym/afros/config
-}
-
-pkg_postinst() {
- elog "To run ARAnyM with AFROS type: aranym -c /usr/share/aranym/afros/config"
-}
diff --git a/app-emulation/aranym/aranym-0.9.0.ebuild b/app-emulation/aranym/aranym-0.9.0.ebuild
deleted file mode 100644
index d6732738f6dc..000000000000
--- a/app-emulation/aranym/aranym-0.9.0.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/aranym/aranym-0.9.0.ebuild,v 1.2 2007/01/25 21:55:49 genone Exp $
-
-inherit flag-o-matic eutils
-
-AFROS="afros-20050424.zip"
-DESCRIPTION="Atari Running on Any Machine, is a virtual machine software for running Atari ST/TT/Falcon operating systems and TOS/GEM applications"
-HOMEPAGE="http://aranym.sourceforge.net/"
-SRC_URI="mirror://sourceforge/aranym/${P}.tar.gz
- mirror://sourceforge/aranym/${AFROS}"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="-*" # At the moment it doesn't compile due to our linux-headers
-IUSE="opengl"
-
-RDEPEND="media-libs/libsdl
- games-emulation/emutos
- opengl? ( virtual/opengl )"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-src_unpack() {
- unpack ${P}.tar.gz
-}
-
-src_compile() {
- filter-flags -mpowerpc-gfxopt
-
- use opengl && myconf="--enable-opengl"
- if [ "${ARCH}" = "x86" ]; then
- myconf="${myconf} --enable-jit-compiler"
- fi
-
- cd ${S}/src/Unix
- econf ${myconf} || die "configure failed"
-
- emake dep || die "failed while building dependencies"
- emake || die "failed during compilation"
-}
-
-src_install() {
- cd ${S}/src/Unix
- emake DESTDIR=${D} install || die "installation failed"
-
- dosym /usr/games/lib/etos512k.img /usr/share/aranym
-
- cd ${D}/usr/share/aranym
- unzip ${DISTDIR}/${AFROS}
- sed -i -e "s|tmp|usr/share/aranym|g" ${D}/usr/share/aranym/afros/config
-}
-
-pkg_postinst() {
- elog "To run ARAnyM with AFROS type: aranym --config /usr/share/aranym/afros/config"
-}
diff --git a/app-emulation/aranym/files/digest-aranym-0.8.6_beta b/app-emulation/aranym/files/digest-aranym-0.8.6_beta
deleted file mode 100644
index e71613c302f3..000000000000
--- a/app-emulation/aranym/files/digest-aranym-0.8.6_beta
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 95a69f503315a6eb7ccad1f85728bb3f afros-20040206.zip 1283233
-RMD160 5aed2251ff9454ed80fcf4796dd8e827566334d1 afros-20040206.zip 1283233
-SHA256 be97d863f056834000a8b667c455b438069916defbf301f31fcefb4f7d2189b2 afros-20040206.zip 1283233
-MD5 566ee14e5acefa076a96ef0ee4a42de7 aranym-0.8.6beta.tar.gz 1226355
-RMD160 4ae708848223104a8483ea6ea093f1526e5f447b aranym-0.8.6beta.tar.gz 1226355
-SHA256 3ce1afef6e910076545c297e38fed2fe2bdefc311f7c2bb6ee0d2760a6199030 aranym-0.8.6beta.tar.gz 1226355
diff --git a/app-emulation/aranym/files/digest-aranym-0.9.0 b/app-emulation/aranym/files/digest-aranym-0.9.0
deleted file mode 100644
index fb055790b503..000000000000
--- a/app-emulation/aranym/files/digest-aranym-0.9.0
+++ /dev/null
@@ -1,6 +0,0 @@
-MD5 949b659a476c508cc58d2fd43c6c54e6 afros-20050424.zip 1776526
-RMD160 b3858e7a8dd930fc6a5d5dea33d2434e61263f7b afros-20050424.zip 1776526
-SHA256 08f88037c92be472eae168943f455470934e33911dcbb71044bb8ed4e4b53d3c afros-20050424.zip 1776526
-MD5 20657ea8187f824ef34663ee7431aaca aranym-0.9.0.tar.gz 1615930
-RMD160 37047bc1b9c87077597817597ca53e8971b6345a aranym-0.9.0.tar.gz 1615930
-SHA256 1dfb87ea2b51893c266d45447799b8ef2a232cadd8f31d3abe51e521fa96e17b aranym-0.9.0.tar.gz 1615930