summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2009-12-01 19:28:48 +0000
committerUlrich Müller <ulm@gentoo.org>2009-12-01 19:28:48 +0000
commitdf43a2ae7b97e292e2816d4d06d7ff2550458c86 (patch)
treeed644f239b3f693c21a8c884fad79ac7ef87d8d6 /app-emacs
parentUnmask KDE 4.3.4 (diff)
downloadgentoo-2-df43a2ae7b97e292e2816d4d06d7ff2550458c86.tar.gz
gentoo-2-df43a2ae7b97e292e2816d4d06d7ff2550458c86.tar.bz2
gentoo-2-df43a2ae7b97e292e2816d4d06d7ff2550458c86.zip
Version bump.
(Portage version: 2.2_rc52/cvs/Linux i686)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gentoo-syntax/ChangeLog7
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-1.16.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-emacs/gentoo-syntax/ChangeLog b/app-emacs/gentoo-syntax/ChangeLog
index de2f7c909455..8266d5578bf9 100644
--- a/app-emacs/gentoo-syntax/ChangeLog
+++ b/app-emacs/gentoo-syntax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/gentoo-syntax
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.59 2009/11/24 20:57:24 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.60 2009/12/01 19:28:48 ulm Exp $
+
+*gentoo-syntax-1.16 (01 Dec 2009)
+
+ 01 Dec 2009; Ulrich Mueller <ulm@gentoo.org> +gentoo-syntax-1.16.ebuild:
+ Version bump.
24 Nov 2009; Christian Faulhammer <fauli@gentoo.org>
gentoo-syntax-1.12.ebuild, gentoo-syntax-1.15-r1.ebuild:
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-1.16.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-1.16.ebuild
new file mode 100644
index 000000000000..97d7688cd438
--- /dev/null
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-1.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.16.ebuild,v 1.1 2009/12/01 19:28:48 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+
+DOCS="ChangeLog"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ makeinfo gentoo-syntax.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ sed -e "s:@PORTDIR@:${PORTDIR}:" \
+ "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" || die
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo gentoo-syntax.info || die
+ dodoc ${DOCS} || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Some optional features may require installation of additional"
+ elog "packages, like app-portage/gentoolkit-dev for echangelog."
+}